summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-04-03 17:31:00 +0200
committerRemi Collet <remi@remirepo.net>2017-04-03 17:31:00 +0200
commita0324e604df520328ce0b5a6a0a177d6354ec639 (patch)
tree1992bcea8b5c6f21894b70686f83a6e1da2c25c5
parent8f3f9f426cb35897e771935c0c5f07b8a05fb531 (diff)
v3.1.0
-rw-r--r--.gitignore7
-rw-r--r--composer.json2
-rw-r--r--php-sebastian-exporter3.spec13
3 files changed, 16 insertions, 6 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..1ab5c4f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/composer.json b/composer.json
index 0062e40..33fc5bd 100644
--- a/composer.json
+++ b/composer.json
@@ -41,7 +41,7 @@
},
"extra": {
"branch-alias": {
- "dev-master": "3.0.x-dev"
+ "dev-master": "3.1.x-dev"
}
}
}
diff --git a/php-sebastian-exporter3.spec b/php-sebastian-exporter3.spec
index 2bf284f..ac7bad3 100644
--- a/php-sebastian-exporter3.spec
+++ b/php-sebastian-exporter3.spec
@@ -6,8 +6,8 @@
#
# Please, preserve the changelog entries
#
-%global bootstrap 1
-%global gh_commit b82d077cb3459e393abcf4867ae8f7230dcb51f6
+%global bootstrap 0
+%global gh_commit 234199f4528de6d12aaa58b612e98f7d36adb937
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project exporter
@@ -24,7 +24,7 @@
%endif
Name: php-%{pk_vendor}-%{pk_project}%{major}
-Version: 3.0.0
+Version: 3.1.0
Release: 1%{?dist}
Summary: Export PHP variables for visualization
@@ -35,7 +35,7 @@ Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit
BuildArch: noarch
BuildRequires: php(language) >= 7.0
-BuildRequires: php-fedora-autoloader-devel
+BuildRequires: php-fedora-autoloader-devel >= 1.0.0
%if %{with_tests}
# from composer.json, "require-dev": {
# "phpunit/phpunit": "^6.0",
@@ -71,7 +71,7 @@ Provides the functionality to export PHP variables for visualization.
%build
# generate the Autoloader
-phpab --template fedora --output src/autoload.php src
+phpab --template fedora2 --output src/autoload.php src
# Rely on include_path as in PHPUnit dependencies
cat <<EOF | tee -a src/autoload.php
@@ -111,6 +111,9 @@ exit $ret
%changelog
+* Mon Apr 3 2017 Remi Collet <remi@remirepo.net> - 3.1.0-1
+- Update to 3.1.0
+
* Fri Mar 3 2017 Remi Collet <remi@fedoraproject.org> - 3.0.0-1
- update to 3.0.0
- rename to php-sebastian-exporter3