summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2017-03-03 15:25:31 +0100
committerRemi Collet <fedora@famillecollet.com>2017-03-03 15:25:31 +0100
commit3c07e75293bec501d0f75f247be4e3b043b4de00 (patch)
tree667fe442b800be9f6357f8bcc7fca4f384f82139
php-sebastian-exporter3: 3.0.0 - New package
-rw-r--r--Makefile4
-rw-r--r--composer.json48
-rw-r--r--php-sebastian-exporter3.spec158
3 files changed, 210 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..0062e40
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,48 @@
+{
+ "name": "sebastian/exporter",
+ "description": "Provides the functionality to export PHP variables for visualization",
+ "keywords": ["exporter","export"],
+ "homepage": "http://www.github.com/sebastianbergmann/exporter",
+ "license": "BSD-3-Clause",
+ "authors": [
+ {
+ "name": "Sebastian Bergmann",
+ "email": "sebastian@phpunit.de"
+ },
+ {
+ "name": "Jeff Welch",
+ "email": "whatthejeff@gmail.com"
+ },
+ {
+ "name": "Volker Dusch",
+ "email": "github@wallbash.com"
+ },
+ {
+ "name": "Adam Harvey",
+ "email": "aharvey@php.net"
+ },
+ {
+ "name": "Bernhard Schussek",
+ "email": "bschussek@2bepublished.at"
+ }
+ ],
+ "require": {
+ "php": "^7.0",
+ "sebastian/recursion-context": "^3.0"
+ },
+ "require-dev": {
+ "phpunit/phpunit": "^6.0",
+ "ext-mbstring": "*"
+ },
+ "autoload": {
+ "classmap": [
+ "src/"
+ ]
+ },
+ "extra": {
+ "branch-alias": {
+ "dev-master": "3.0.x-dev"
+ }
+ }
+}
+
diff --git a/php-sebastian-exporter3.spec b/php-sebastian-exporter3.spec
new file mode 100644
index 0000000..a6762d9
--- /dev/null
+++ b/php-sebastian-exporter3.spec
@@ -0,0 +1,158 @@
+# remirepo/fedora spec file for php-sebastian-exporter3
+#
+# Copyright (c) 2013-2017 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+%global bootstrap 0
+%global gh_commit b82d077cb3459e393abcf4867ae8f7230dcb51f6
+%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
+%global gh_owner sebastianbergmann
+%global gh_project exporter
+%global pk_vendor sebastian
+%global pk_project %{gh_project}
+%global major 3
+%global php_home %{_datadir}/php
+%global pear_name Exporter
+%global pear_channel pear.phpunit.de
+%if %{bootstrap}
+%global with_tests %{?_with_tests:1}%{!?_with_tests:0}
+%else
+%global with_tests %{?_without_tests:0}%{!?_without_tests:1}
+%endif
+
+Name: php-%{pk_vendor}-%{pk_project}%{major}
+Version: 3.0.0
+Release: 1%{?dist}
+Summary: Export PHP variables for visualization
+
+Group: Development/Libraries
+License: BSD
+URL: https://github.com/%{gh_owner}/%{gh_project}
+Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{name}-%{version}-%{gh_short}.tar.gz
+
+BuildArch: noarch
+BuildRequires: php(language) >= 7.0
+BuildRequires: php-fedora-autoloader-devel
+%if %{with_tests}
+# from composer.json, "require-dev": {
+# "phpunit/phpunit": "^6.0",
+# "ext-mbstring": "*"
+BuildRequires: phpunit6
+BuildRequires: php-mbstring
+BuildRequires: php-composer(%{pk_vendor}/recursion-context) >= 3.0
+%endif
+
+# from composer.json
+# "php": "^7.0",
+# "sebastian/recursion-context": "^3.0"
+Requires: php(language) >= 7.0
+Requires: php-composer(%{pk_vendor}/recursion-context) >= 3.0
+Requires: php-composer(%{pk_vendor}/recursion-context) < 4
+# from phpcompatinfo report for version 3.0.0
+Requires: php-mbstring
+Requires: php-pcre
+Requires: php-spl
+# Autoloader
+Requires: php-composer(fedora/autoloader)
+
+Provides: php-composer(%{pk_vendor}/%{pk_project}) = %{version}
+
+
+%description
+Provides the functionality to export PHP variables for visualization.
+
+
+%prep
+%setup -q -n %{gh_project}-%{gh_commit}
+
+
+%build
+# generate the Autoloader
+phpab --template fedora --output src/autoload.php src
+
+# Rely on include_path as in PHPUnit dependencies
+cat <<EOF | tee -a src/autoload.php
+// Dependency' autoloader
+require_once 'SebastianBergmann/RecursionContext3/autoload.php';
+EOF
+
+
+%install
+mkdir -p %{buildroot}%{php_home}/SebastianBergmann
+cp -pr src %{buildroot}%{php_home}/SebastianBergmann/Exporter%{major}
+
+
+%if %{with_tests}
+%check
+mkdir vendor
+touch vendor/autoload.php
+
+: Run upstream test suite
+ret=0
+for cmd in php70 php71 php; do
+ if which $cmd; then
+ %{_bindir}/php -d include_path=.:%{buildroot}%{_datadir}/php:%{_datadir}/php \
+ %{_bindir}/phpunit6 --verbose || ret=1
+ fi
+done
+exit $ret
+%endif
+
+
+%files
+%{!?_licensedir:%global license %%doc}
+%license LICENSE
+%doc README.md
+%doc composer.json
+%{php_home}/SebastianBergmann/Exporter%{major}
+
+
+%changelog
+* Fri Mar 3 2017 Remi Collet <remi@fedoraproject.org> - 3.0.0-1
+- update to 3.0.0
+- rename to php-sebastian-exporter3
+- raise dependency on PHP 7
+- raise dependency on recursion-context 3
+
+* Tue Nov 22 2016 Remi Collet <remi@fedoraproject.org> - 2.0.0-1
+- update to 2.0.0
+- raise dependency on sebastian/recursion-context 2.0
+- switch to fedora/autoloader
+
+* Fri Jun 17 2016 Remi Collet <remi@fedoraproject.org> - 1.2.2-1
+- update to 1.2.2
+- run test suite with both PHP 5 and 7 when available
+
+* Sun Jul 26 2015 Remi Collet <remi@fedoraproject.org> - 1.2.1-1
+- update to 1.2.1 (only CS)
+
+* Fri Jan 30 2015 Remi Collet <remi@fedoraproject.org> - 1.2.0-1
+- update to 1.2.0
+
+* Sat Jan 24 2015 Remi Collet <remi@fedoraproject.org> - 1.1.0-1
+- update to 1.1.0
+- add dependency on sebastian/recursion-context
+
+* Sun Oct 5 2014 Remi Collet <remi@fedoraproject.org> - 1.0.2-1
+- update to 1.0.2
+- enable test suite
+
+* Fri Jul 18 2014 Remi Collet <remi@fedoraproject.org> - 1.0.1-4
+- add composer dependencies
+
+* Wed Apr 30 2014 Remi Collet <remi@fedoraproject.org> - 1.0.1-2
+- cleanup pear registry
+
+* Sun Apr 6 2014 Remi Collet <remi@fedoraproject.org> - 1.0.1-1
+- update to 1.0.1
+- get sources from github
+- run test suite when build --with tests
+
+* Sun Oct 20 2013 Remi Collet <remi@fedoraproject.org> - 1.0.0-2
+- rename to lowercase
+
+* Thu Sep 12 2013 Remi Collet <remi@fedoraproject.org> - 1.0.0-1
+- initial package