summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-06-16 07:50:56 +0200
committerRemi Collet <remi@remirepo.net>2020-06-16 07:50:56 +0200
commitda93e7976856bcc18182f6d311f238842595002f (patch)
tree40437099dce5dd565851520086474089d4ce7778
parent1e4f00412c17c27b89777b52303d5a64113838b4 (diff)
update to 5.1.1
sources from git snapshot
-rwxr-xr-xmakesrc.sh28
-rw-r--r--php-sebastian-environment5.spec12
2 files changed, 37 insertions, 3 deletions
diff --git a/makesrc.sh b/makesrc.sh
new file mode 100755
index 0000000..4190c13
--- /dev/null
+++ b/makesrc.sh
@@ -0,0 +1,28 @@
+#!/bin/bash
+
+NAME=$(basename $PWD)
+OWNER=$(sed -n '/^%global gh_owner/{s/.* //;p}' $NAME.spec)
+PROJECT=$(sed -n '/^%global gh_project/{s/.* //;p}' $NAME.spec)
+VERSION=$(sed -n '/^Version:/{s/.* //;p}' $NAME.spec)
+COMMIT=$(sed -n '/^%global gh_commit/{s/.* //;p}' $NAME.spec)
+SHORT=${COMMIT:0:7}
+
+echo -e "\nCreate git snapshot\nName=$NAME, Owner=$OWNER, Project=$PROJECT, Version=$VERSION\n"
+
+echo "Cloning..."
+rm -rf $PROJECT-$COMMIT
+git clone https://github.com/$OWNER/$PROJECT.git $PROJECT-$COMMIT
+
+echo "Getting commit..."
+pushd $PROJECT-$COMMIT
+git checkout $COMMIT
+cp composer.json ../composer.json
+popd
+
+echo "Archiving..."
+tar czf $NAME-$VERSION-$SHORT.tgz --exclude-vcs --exclude tools $PROJECT-$COMMIT
+
+echo "Cleaning..."
+rm -rf $PROJECT-$COMMIT
+
+echo "Done."
diff --git a/php-sebastian-environment5.spec b/php-sebastian-environment5.spec
index a052125..ec235e8 100644
--- a/php-sebastian-environment5.spec
+++ b/php-sebastian-environment5.spec
@@ -8,7 +8,7 @@
#
%global bootstrap 0
# Sources
-%global gh_commit c753f04d68cd489b6973cf9b4e505e191af3b05c
+%global gh_commit 16eb0fa43e29c33d7f2117ed23072e26fc5ab34e
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project environment
@@ -27,13 +27,15 @@
%endif
Name: php-%{pk_vendor}-%{pk_project}%{major}
-Version: 5.1.0
+Version: 5.1.1
Release: 1%{?dist}
Summary: Handle HHVM/PHP environments
License: BSD
URL: https://github.com/%{gh_owner}/%{gh_project}
-Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{name}-%{version}-%{gh_short}.tar.gz
+Source0: %{name}-%{version}-%{gh_short}.tgz
+Source1: makesrc.sh
+
BuildArch: noarch
BuildRequires: php(language) >= 7.3
@@ -109,6 +111,10 @@ exit $ret
%changelog
+* Tue Jun 16 2020 Remi Collet <remi@remirepo.net> - 5.1.1-1
+- update to 5.1.1
+- sources from git snapshot
+
* Tue Apr 14 2020 Remi Collet <remi@remirepo.net> - 5.1.0-1
- update to 5.1.0