summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-03-31 17:15:54 +0200
committerRemi Collet <remi@remirepo.net>2020-03-31 17:15:54 +0200
commita8b738436c0b1c944dc44a525c6bc42c3528e7d2 (patch)
treef505643d010f9dd06ddb6f6539771ea692ee90dd
parentd60d3d7fbfa1d3bddd504de2cacaf5dbd605823b (diff)
update to 5.0.2
switch to phpunit9
-rw-r--r--php-sebastian-environment5.spec13
1 files changed, 8 insertions, 5 deletions
diff --git a/php-sebastian-environment5.spec b/php-sebastian-environment5.spec
index 4fc9282..e25c854 100644
--- a/php-sebastian-environment5.spec
+++ b/php-sebastian-environment5.spec
@@ -8,7 +8,7 @@
#
%global bootstrap 0
# Sources
-%global gh_commit 9bffdefa7810031a165ddd6275da6a2c1f6f2dfb
+%global gh_commit c39c1db0a5cffc98173f3de5a17d489d1043fd7b
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project environment
@@ -27,7 +27,7 @@
%endif
Name: php-%{pk_vendor}-%{pk_project}%{major}
-Version: 5.0.1
+Version: 5.0.2
Release: 1%{?dist}
Summary: Handle HHVM/PHP environments
@@ -44,8 +44,7 @@ BuildRequires: php-fedora-autoloader-devel >= 1.0.0
%if %{with_tests}
# from composer.json, "require-dev": {
# "phpunit/phpunit": "^9.0"
-# TODO test suite passes with v8, switch to v9 when available
-BuildRequires: phpunit8
+BuildRequires: phpunit9
%endif
# from composer.json, "require": {
@@ -93,7 +92,7 @@ for cmd in php php73 php74; do
if which $cmd; then
$cmd -d auto_prepend_file=%{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}%{major}/autoload.php \
-d pcov.enabled=1 \
- %{_bindir}/phpunit8 --verbose || ret=1
+ %{_bindir}/phpunit9 --verbose || ret=1
fi
done
exit $ret
@@ -110,6 +109,10 @@ exit $ret
%changelog
+* Tue Mar 31 2020 Remi Collet <remi@remirepo.net> - 5.0.2-1
+- update to 5.0.2
+- switch to phpunit9
+
* Wed Feb 19 2020 Remi Collet <remi@remirepo.net> - 5.0.1-1
- update to 5.0.1