summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-09-28 10:17:25 +0200
committerRemi Collet <remi@remirepo.net>2020-09-28 10:17:25 +0200
commit9e2dee8c38d1442c62d194b4c030bf1e152ce13b (patch)
tree4bd12fed953b7d2698f71121ba8101da52f3d07d
parent1dccedbc5bbd08cda6ae19bfc1630ac692b2771d (diff)
update to 5.1.3 (no change)
-rw-r--r--composer.json6
-rw-r--r--php-sebastian-environment5.spec24
2 files changed, 15 insertions, 15 deletions
diff --git a/composer.json b/composer.json
index 1131e1d..d50dcfd 100644
--- a/composer.json
+++ b/composer.json
@@ -19,10 +19,10 @@
},
"prefer-stable": true,
"require": {
- "php": "^7.3 || ^8.0"
+ "php": ">=7.3"
},
"require-dev": {
- "phpunit/phpunit": "^9.0"
+ "phpunit/phpunit": "^9.3"
},
"suggest": {
"ext-posix": "*"
@@ -34,7 +34,7 @@
},
"extra": {
"branch-alias": {
- "dev-master": "5.0-dev"
+ "dev-master": "5.1-dev"
}
}
}
diff --git a/php-sebastian-environment5.spec b/php-sebastian-environment5.spec
index 9a27f73..032cd41 100644
--- a/php-sebastian-environment5.spec
+++ b/php-sebastian-environment5.spec
@@ -6,9 +6,11 @@
#
# Please, preserve the changelog entries
#
-%global bootstrap 0
+
+%bcond_without tests
+
# Sources
-%global gh_commit 0a757cab9d5b7ef49a619f1143e6c9c1bc0fe9d2
+%global gh_commit 388b6ced16caa751030f6a69e588299fa09200ac
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project environment
@@ -20,16 +22,11 @@
%global php_home %{_datadir}/php
%global ns_vendor SebastianBergmann
%global ns_project Environment
-%if %{bootstrap}
-%bcond_with tests
-%else
-%bcond_without tests
-%endif
Name: php-%{pk_vendor}-%{pk_project}%{major}
-Version: 5.1.2
+Version: 5.1.3
Release: 1%{?dist}
-Summary: Handle HHVM/PHP environments
+Summary: Handle HHVM/PHP environments version %{major}
License: BSD
URL: https://github.com/%{gh_owner}/%{gh_project}
@@ -45,12 +42,12 @@ BuildRequires: php-posix
BuildRequires: php-fedora-autoloader-devel >= 1.0.0
%if %{with tests}
# from composer.json, "require-dev": {
-# "phpunit/phpunit": "^9.0"
-BuildRequires: phpunit9
+# "phpunit/phpunit": "^9.3"
+BuildRequires: phpunit9 >= 9.3
%endif
# from composer.json, "require": {
-# "php": "^7.3 || ^8.0"
+# "php": ">=7.3"
Requires: php(language) >= 7.3
# From phpcompatinfo report for 4.0.1
Requires: php-pcre
@@ -111,6 +108,9 @@ exit $ret
%changelog
+* Mon Sep 28 2020 Remi Collet <remi@remirepo.net> - 5.1.3-1
+- update to 5.1.3 (no change)
+
* Mon Jun 29 2020 Remi Collet <remi@remirepo.net> - 5.1.2-1
- update to 5.1.2