summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json10
-rw-r--r--php-sebastian-diff7.spec44
2 files changed, 28 insertions, 26 deletions
diff --git a/composer.json b/composer.json
index 7e19a7d..124d8ed 100644
--- a/composer.json
+++ b/composer.json
@@ -21,17 +21,17 @@
"prefer-stable": true,
"config": {
"platform": {
- "php": "8.2.0"
+ "php": "8.3.0"
},
"optimize-autoloader": true,
"sort-packages": true
},
"require": {
- "php": ">=8.2"
+ "php": ">=8.3"
},
"require-dev": {
- "phpunit/phpunit": "^11.0",
- "symfony/process": "^4.2 || ^5"
+ "phpunit/phpunit": "^12.0",
+ "symfony/process": "^7.2"
},
"autoload": {
"classmap": [
@@ -45,7 +45,7 @@
},
"extra": {
"branch-alias": {
- "dev-main": "6.0-dev"
+ "dev-main": "7.0-dev"
}
}
}
diff --git a/php-sebastian-diff7.spec b/php-sebastian-diff7.spec
index 0eeba34..6630be7 100644
--- a/php-sebastian-diff7.spec
+++ b/php-sebastian-diff7.spec
@@ -1,4 +1,4 @@
-# remirepo/fedora spec file for php-sebastian-diff6
+# remirepo/fedora spec file for php-sebastian-diff7
#
# SPDX-FileCopyrightText: Copyright 2013-2025 Remi Collet
# SPDX-License-Identifier: CECILL-2.1
@@ -7,14 +7,14 @@
# Please, preserve the changelog entries
#
-# disabled until phpunit11 available
-%bcond_without tests
+# disabled until phpunit12 available
+%bcond_with tests
-%global gh_commit b4ccd857127db5d41a5b676f24b51371d76d8544
+%global gh_commit 7ab1ea946c012266ca32390913653d844ecd085f
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project diff
-%global gh_date 2024-07-03
+%global gh_date 2025-02-07
# Packagist
%global pk_vendor sebastian
%global pk_project %{gh_project}
@@ -22,12 +22,12 @@
%global ns_vendor SebastianBergmann
%global ns_project Diff
-%global major 6
+%global major 7
%global php_home %{_datadir}/php
Name: php-%{pk_vendor}-%{pk_project}%{major}
-Version: 6.0.2
-Release: 2%{?dist}
+Version: 7.0.0
+Release: 1%{?dist}
Summary: Diff implementation, version %{major}
License: BSD-3-Clause
@@ -36,27 +36,23 @@ URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: %{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
# php-symfony4 going to disapear, php-symfony5 not available, only used for tests
-%global symfony_version 5.4.35
+%global symfony_version 7.2.0
Source2: https://github.com/symfony/process/archive/v%{symfony_version}/php-symfony-process-%{symfony_version}.tar.gz
BuildArch: noarch
BuildRequires: php-fedora-autoloader-devel
%if %{with tests}
-BuildRequires: php(language) >= 8.2
-BuildRequires: php-pcre
-BuildRequires: php-spl
+BuildRequires: php(language) >= 8.3
# from composer.json, "require-dev": {
-# "phpunit/phpunit": "^11.0",
-# "symfony/process": "^4.2 || ^5"
-BuildRequires: phpunit11
+# "phpunit/phpunit": "^12.0",
+# "symfony/process": "^7.2"
+BuildRequires: phpunit12
%endif
# from composer.json
-# "php": ">=8.2"
-Requires: php(language) >= 8.2
+# "php": ">=8.3"
+Requires: php(language) >= 8.3
# from phpcompatinfo report for version 5.0.0
-Requires: php-pcre
-Requires: php-spl
# Autoloader
Requires: php-composer(fedora/autoloader)
@@ -92,10 +88,10 @@ mkdir vendor
: Run upstream test suite
ret=0
-for cmd in php php82 php83 php84; do
+for cmd in php php83 php84; do
if which $cmd; then
$cmd -d auto_prepend_file=%{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}%{major}/autoload.php \
- %{_bindir}/phpunit11 || ret=1
+ %{_bindir}/phpunit12 || ret=1
fi
done
exit $ret
@@ -113,6 +109,12 @@ exit $ret
%changelog
+* Fri Feb 7 2025 Remi Collet <remi@remirepo.net> - 7.0.0-1
+- update to 7.0.0
+- raise dependency on PHP 8.3
+- rename to php-sebastian-diff7
+- move to /usr/share/php/SebastianBergmann/Diff7
+
* Tue Feb 4 2025 Remi Collet <remi@remirepo.net> - 6.0.2-2
- enable test suite