summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--php-sebastian-diff5.spec10
1 files changed, 6 insertions, 4 deletions
diff --git a/php-sebastian-diff5.spec b/php-sebastian-diff5.spec
index 114ad25..ba76b9f 100644
--- a/php-sebastian-diff5.spec
+++ b/php-sebastian-diff5.spec
@@ -7,8 +7,7 @@
# Please, preserve the changelog entries
#
-# disabled until phpunit10 available
-%bcond_with tests
+%bcond_without tests
%global gh_commit 912dc2fbe3e3c1e7873313cc801b100b6c68c87b
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
@@ -26,7 +25,7 @@
Name: php-%{pk_vendor}-%{pk_project}%{major}
Version: 5.0.3
-Release: 1%{?dist}
+Release: 3%{?dist}
Summary: Diff implementation, version %{major}
License: BSD-3-Clause
@@ -97,7 +96,7 @@ rm tests/Utils/UnifiedDiffAssertTraitIntegrationTest.php
: Run upstream test suite
ret=0
-for cmd in php php81 php82; do
+for cmd in php php81 php82 php83; do
if which $cmd; then
$cmd -d auto_prepend_file=%{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}%{major}/autoload.php \
%{_bindir}/phpunit10 || ret=1
@@ -120,6 +119,9 @@ exit $ret
%changelog
+* Wed Aug 23 2023 Remi Collet <remi@remirepo.net> - 5.0.3-3
+- Enable test suite
+
* Tue May 2 2023 Remi Collet <remi@remirepo.net> - 5.0.3-1
- update to 5.0.3