summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-02-07 14:46:30 +0100
committerRemi Collet <remi@php.net>2023-02-07 14:46:30 +0100
commitaf2fcf5831421c8c39fd7214bcca298576ca04f2 (patch)
tree91932fb7f79c6aaced438740b6d39db28e7b3faa
parent48f8a761c67434ad4b37d02440c9cc14369555ad (diff)
cleanup
-rw-r--r--php-sebastian-diff5.spec19
1 files changed, 7 insertions, 12 deletions
diff --git a/php-sebastian-diff5.spec b/php-sebastian-diff5.spec
index e38f8be..c2acac4 100644
--- a/php-sebastian-diff5.spec
+++ b/php-sebastian-diff5.spec
@@ -33,6 +33,9 @@ License: BSD-3-Clause
URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: %{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
+# php-symfony4 going to disapear, php-symfony5 not available, only used for tests
+%global symfony_version 5.4.19
+Source2: https://github.com/symfony/process/archive/v%{symfony_version}/php-symfony-process-%{symfony_version}.tar.gz
BuildArch: noarch
BuildRequires: php-fedora-autoloader-devel
@@ -44,7 +47,6 @@ BuildRequires: php-spl
# "phpunit/phpunit": "^10.0",
# "symfony/process": "^4.2 || ^5"
BuildRequires: phpunit10
-BuildRequires: php-symfony4-process
%endif
# from composer.json
@@ -66,7 +68,7 @@ Autoloader: %{php_home}/%{ns_vendor}/%{ns_project}%{major}/autoload.php
%prep
-%setup -q -n %{gh_project}-%{gh_commit}
+%setup -q -n %{gh_project}-%{gh_commit} -a 2
%build
@@ -82,15 +84,7 @@ cp -pr src %{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}%{major}
%check
%if %{with tests}
mkdir vendor
-%{_bindir}/phpab --output vendor/autoload.php tests
-cat << 'EOF' | tee -a vendor/autoload.php
-\Fedora\Autoloader\Dependencies::required([
- [
- '%{php_home}/Symfony5/Component/Process/autoload.php',
- '%{php_home}/Symfony4/Component/Process/autoload.php',
- ]
-]);
-EOF
+%{_bindir}/phpab --output vendor/autoload.php tests process-%{symfony_version}
# remirepo:5
%if 0%{?rhel} == 6 || 0%{?rhel} == 7
@@ -104,7 +98,7 @@ ret=0
for cmd in php php81 php82; do
if which $cmd; then
$cmd -d auto_prepend_file=%{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}%{major}/autoload.php \
- %{_bindir}/phpunit10 --verbose || ret=1
+ %{_bindir}/phpunit10 || ret=1
fi
done
exit $ret
@@ -129,6 +123,7 @@ exit $ret
- raise dependency on PHP 8.1
- rename to php-sebastian-diff5
- move to /usr/share/php/SebastianBergmann/Diff5
+- use bundled symfony/process for test suite
* Mon Oct 26 2020 Remi Collet <remi@remirepo.net> - 4.0.4-1
- update to 4.0.4