summaryrefslogtreecommitdiffstats
path: root/php-sebastian-diff4.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-sebastian-diff4.spec')
-rw-r--r--php-sebastian-diff4.spec180
1 files changed, 180 insertions, 0 deletions
diff --git a/php-sebastian-diff4.spec b/php-sebastian-diff4.spec
new file mode 100644
index 0000000..0069ea1
--- /dev/null
+++ b/php-sebastian-diff4.spec
@@ -0,0 +1,180 @@
+# remirepo/fedora spec file for php-sebastian-diff3
+#
+# Copyright (c) 2013-2019 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+%global bootstrap 0
+%global gh_commit 720fcc7e9b5cf384ea68d9d930d480907a0c1a29
+%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
+%global gh_owner sebastianbergmann
+%global gh_project diff
+# Packagist
+%global pk_vendor sebastian
+%global pk_project %{gh_project}
+# Namespace
+%global ns_vendor SebastianBergmann
+%global ns_project Diff
+
+%global major 3
+%global php_home %{_datadir}/php
+%if %{bootstrap}
+%global with_tests 0%{?_with_tests:1}
+%else
+%global with_tests 0%{!?_without_tests:1}
+%endif
+
+Name: php-%{pk_vendor}-%{pk_project}%{major}
+Version: 3.0.2
+Release: 1%{?dist}
+Summary: Diff implementation
+
+License: BSD
+URL: https://github.com/%{gh_owner}/%{gh_project}
+Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{name}-%{version}-%{gh_short}.tar.gz
+
+BuildArch: noarch
+BuildRequires: php-fedora-autoloader-devel
+%if %{with_tests}
+BuildRequires: php(language) >= 7.1
+BuildRequires: php-pcre
+BuildRequires: php-spl
+# from composer.json, "require-dev": {
+# "phpunit/phpunit": "^7.5 || ^8.0",
+# "symfony/process": "^2 || ^3.3 || ^4"
+BuildRequires: phpunit7 >= 7.5
+BuildRequires: php-symfony4-process
+%endif
+
+# from composer.json
+# "php": "^7.1"
+Requires: php(language) >= 7.1
+# from phpcompatinfo report for version 3.0.0
+Requires: php-pcre
+Requires: php-spl
+# Autoloader
+Requires: php-composer(fedora/autoloader)
+
+Provides: php-composer(%{pk_vendor}/%{pk_project}) = %{version}
+
+
+%description
+Diff implementation.
+
+Autoloader: %{php_home}/%{ns_vendor}/%{ns_project}%{major}/autoload.php
+
+
+%prep
+%setup -q -n %{gh_project}-%{gh_commit}
+
+
+%build
+# Generate the Autoloader
+%{_bindir}/phpab --template fedora --output src/autoload.php src
+
+
+%install
+mkdir -p %{buildroot}%{php_home}/%{ns_vendor}
+cp -pr src %{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}%{major}
+
+
+%check
+%if %{with_tests}
+mkdir vendor
+%{_bindir}/phpab --output vendor/autoload.php tests
+cat << 'EOF' | tee -a vendor/autoload.php
+\Fedora\Autoloader\Autoload::addPsr4('Symfony\\Component\\Process', '%{php_home}/Symfony4/Component/Process');
+EOF
+
+# remirepo:4
+%if 0%{?rhel} == 6 || 0%{?rhel} == 7
+: Ignore tests using git command: unknown option 'unsafe-paths' with old git
+rm -r tests/Output/Integration
+%endif
+
+: Run upstream test suite
+ret=0
+for cmd in php php71 php72 php73; do
+ if which $cmd; then
+ $cmd -d auto_prepend_file=%{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}%{major}/autoload.php \
+ %{_bindir}/phpunit7 --verbose || ret=1
+ fi
+done
+exit $ret
+%else
+: bootstrap build with test suite disabled
+%endif
+
+
+%files
+# remirepo:1
+%{!?_licensedir:%global license %%doc}
+%license LICENSE
+%doc composer.json
+%doc *.md
+%dir %{php_home}/%{ns_vendor}
+ %{php_home}/%{ns_vendor}/%{ns_project}%{major}
+
+
+%changelog
+* Mon Feb 4 2019 Remi Collet <remi@remirepo.net> - 3.0.2-1
+- update to 3.0.2
+
+* Mon Jun 11 2018 Remi Collet <remi@remirepo.net> - 3.0.1-1
+- update to 3.0.1 (no change)
+- ignore integration tests with old git command
+
+* Wed Feb 7 2018 Remi Collet <remi@remirepo.net> - 3.0.0-1
+- normal build
+
+* Fri Feb 2 2018 Remi Collet <remi@remirepo.net> - 3.0.0-0
+- update to 3.0.0
+- renamed to php-sebastian-diff3
+- move to /usr/share/php/SebastianBergmann/Diff3
+- raise dependency on PHP 7.1
+- use phpunit7
+- boostrap build
+
+* Fri Aug 4 2017 Remi Collet <remi@remirepo.net> - 2.0.1-1
+- update to 2.0.1
+- renamed to php-sebastian-diff2
+- raise dependency on PHP 7.0
+
+* Mon May 22 2017 Remi Collet <remi@remirepo.net> - 1.4.3-1
+- Update to 1.4.3
+
+* Mon May 22 2017 Remi Collet <remi@remirepo.net> - 1.4.2-1
+- Update to 1.4.2
+- switch to fedora/autoloader
+- use PHPUnit 6 when available
+
+* Sun Dec 6 2015 Remi Collet <remi@fedoraproject.org> - 1.4.0-1
+- update to 1.4.1 (no change)
+- run test suite with both php 5 and 7 when available
+
+* Fri Apr 3 2015 Remi Collet <remi@fedoraproject.org> - 1.3.0-1
+- update to 1.3.0
+
+* Fri Oct 3 2014 Remi Collet <remi@fedoraproject.org> - 1.2.0-1
+- update to 1.2.0
+- run test suite during build
+- generate autoload.php for compatibility
+- fix license handling
+
+* Wed Jun 25 2014 Remi Collet <remi@fedoraproject.org> - 1.1.0-6
+- composer dependencies
+
+* Wed Apr 30 2014 Remi Collet <remi@fedoraproject.org> - 1.1.0-4
+- cleanup pear registry
+
+* Wed Apr 23 2014 Remi Collet <remi@fedoraproject.org> - 1.1.0-3
+- get sources from github
+- run test suite when build --with tests
+
+* Sun Oct 20 2013 Remi Collet <remi@fedoraproject.org> - 1.1.0-2
+- rename to lowercase
+
+* Thu Sep 12 2013 Remi Collet <remi@fedoraproject.org> - 1.1.0-1
+- initial package