summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2025-02-07 07:18:46 +0100
committerRemi Collet <remi@php.net>2025-02-07 07:18:46 +0100
commit5075b0a497135eb085291d19e9a44be995c2973b (patch)
tree5eefbb59e57efaad40b52355788ebb82369303b6
parent6cd429efad37a10e57f66b46dffcf3e4a5881c84 (diff)
update to 5.0.0
raise dependency on PHP 8.3 rename to php-sebastian-complexity5 move to /usr/share/php/SebastianBergmann/Complexity5
-rw-r--r--composer.json8
-rw-r--r--php-sebastian-complexity5.spec38
2 files changed, 26 insertions, 20 deletions
diff --git a/composer.json b/composer.json
index 55ebd47..994a5a3 100644
--- a/composer.json
+++ b/composer.json
@@ -17,15 +17,15 @@
},
"prefer-stable": true,
"require": {
- "php": ">=8.2",
+ "php": ">=8.3",
"nikic/php-parser": "^5.0"
},
"require-dev": {
- "phpunit/phpunit": "^11.0"
+ "phpunit/phpunit": "^12.0"
},
"config": {
"platform": {
- "php": "8.2.0"
+ "php": "8.3.0"
},
"optimize-autoloader": true,
"sort-packages": true
@@ -37,7 +37,7 @@
},
"extra": {
"branch-alias": {
- "dev-main": "4.0-dev"
+ "dev-main": "5.0-dev"
}
}
}
diff --git a/php-sebastian-complexity5.spec b/php-sebastian-complexity5.spec
index 47bbb3c..42bfab8 100644
--- a/php-sebastian-complexity5.spec
+++ b/php-sebastian-complexity5.spec
@@ -1,4 +1,4 @@
-# remirepo/fedora spec file for php-sebastian-complexity4
+# remirepo/fedora spec file for php-sebastian-complexity5
#
# SPDX-FileCopyrightText: Copyright 2020-2025 Remi Collet
# SPDX-License-Identifier: CECILL-2.1
@@ -7,27 +7,27 @@
# Please, preserve the changelog entries
#
-# disabled until phpunit11 available
-%bcond_without tests
+# disabled until phpunit12 available
+%bcond_with tests
# github
-%global gh_commit ee41d384ab1906c68852636b6de493846e13e5a0
+%global gh_commit bad4316aba5303d0221f43f8cee37eb58d384bbb
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project complexity
-%global gh_date 2024-07-03
+%global gh_date 2025-02-07
# packagist
%global pk_vendor sebastian
%global pk_project %{gh_project}
-%global major 4
+%global major 5
# namespace
%global php_home %{_datadir}/php
%global ns_vendor SebastianBergmann
%global ns_project Complexity
Name: php-%{pk_vendor}-%{pk_project}%{major}
-Version: 4.0.1
-Release: 2%{?dist}
+Version: 5.0.0
+Release: 1%{?dist}
Summary: Calculating the complexity of PHP code units, version %{major}
License: BSD-3-Clause
@@ -37,20 +37,20 @@ Source0: %{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
BuildArch: noarch
-BuildRequires: php(language) >= 8.2
+BuildRequires: php(language) >= 8.3
BuildRequires: (php-composer(nikic/php-parser) >= 5.0 with php-composer(nikic/php-parser) < 6)
# Autoloader
BuildRequires: php-fedora-autoloader-devel >= 1.0.0
%if %{with tests}
# from composer.json, "require-dev": {
-# "phpunit/phpunit": "^11.0"
-BuildRequires: phpunit11
+# "phpunit/phpunit": "^12.0"
+BuildRequires: phpunit12
%endif
# from composer.json, "require": {
-# "php": ">=8.2",
-# "nikic/php-parser": "^4.18 || ^5.0"
-Requires: php(language) >= 8.2
+# "php": ">=8.3",
+# "nikic/php-parser": "^5.0"
+Requires: php(language) >= 8.3
Requires: (php-composer(nikic/php-parser) >= 5.0 with php-composer(nikic/php-parser) < 6)
# from phpcompatinfo report for version 3.0.0
# none
@@ -95,10 +95,10 @@ touch vendor/autoload.php
: Run upstream test suite
ret=0
-for cmd in php php82 php83 php84; do
+for cmd in php php83 php84; do
if which $cmd; then
$cmd -d auto_prepend_file=%{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}%{major}/autoload.php \
- %{_bindir}/phpunit11 || ret=1
+ %{_bindir}/phpunit12 || ret=1
fi
done
exit $ret
@@ -116,6 +116,12 @@ exit $ret
%changelog
+* Fri Feb 7 2025 Remi Collet <remi@remirepo.net> - 5.0.0-1
+- update to 5.0.0
+- raise dependency on PHP 8.3
+- rename to php-sebastian-complexity5
+- move to /usr/share/php/SebastianBergmann/Complexity5
+
* Tue Feb 4 2025 Remi Collet <remi@remirepo.net> - 4.0.1-2
- enable test suite