summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-02-03 15:01:35 +0100
committerRemi Collet <remi@php.net>2023-02-03 15:01:35 +0100
commitac85af8b8b5c2e64d57a09f6a2a316e968e488aa (patch)
tree2171af1c4e6a2795a74ff48d4e74ea937184e44a
parente909aba1ca7007630f82c9b04eb342765a8cea67 (diff)
update to 3.0.0
raise dependency on PHP 8.1 raise dependency on nikic/php-parser 4.10 rename to php-sebastian-complexity3 move to /usr/share/php/SebastianBergmann/Complexity3
-rw-r--r--composer.json11
-rw-r--r--php-sebastian-complexity3.spec52
2 files changed, 36 insertions, 27 deletions
diff --git a/composer.json b/composer.json
index 7aa3831..5432125 100644
--- a/composer.json
+++ b/composer.json
@@ -14,16 +14,17 @@
"support": {
"issues": "https://github.com/sebastianbergmann/complexity/issues"
},
+ "prefer-stable": true,
"require": {
- "php": ">=7.3",
- "nikic/php-parser": "^4.7"
+ "php": ">=8.1",
+ "nikic/php-parser": "^4.10"
},
"require-dev": {
- "phpunit/phpunit": "^9.3"
+ "phpunit/phpunit": "^10.0"
},
"config": {
"platform": {
- "php": "7.3.0"
+ "php": "8.1.0"
},
"optimize-autoloader": true,
"sort-packages": true
@@ -35,7 +36,7 @@
},
"extra": {
"branch-alias": {
- "dev-master": "2.0-dev"
+ "dev-main": "3.0-dev"
}
}
}
diff --git a/php-sebastian-complexity3.spec b/php-sebastian-complexity3.spec
index 9f219b8..554ddc3 100644
--- a/php-sebastian-complexity3.spec
+++ b/php-sebastian-complexity3.spec
@@ -1,29 +1,31 @@
-# remirepo/fedora spec file for php-sebastian-complexity
+# remirepo/fedora spec file for php-sebastian-complexity3
#
-# Copyright (c) 2020 Remi Collet
-# License: CC-BY-SA
+# Copyright (c) 2020-2023 Remi Collet
+# License: CC-BY-SA-4.0
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
-%bcond_without tests
+
+# disabled until phpunit10 available
+%bcond_with tests
# github
-%global gh_commit 739b35e53379900cc9ac327b2147867b8b6efd88
+%global gh_commit e67d240970c9dc7ea7b2123a6d520e334dd61dc6
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project complexity
# packagist
%global pk_vendor sebastian
%global pk_project %{gh_project}
-%global major %nil
+%global major 3
# namespace
%global php_home %{_datadir}/php
%global ns_vendor SebastianBergmann
%global ns_project Complexity
Name: php-%{pk_vendor}-%{pk_project}%{major}
-Version: 2.0.2
+Version: 3.0.0
Release: 1%{?dist}
Summary: Calculating the complexity of PHP code units
@@ -34,36 +36,35 @@ Source0: %{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
BuildArch: noarch
-BuildRequires: php(language) >= 7.3
+BuildRequires: php(language) >= 8.1
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-BuildRequires: (php-composer(nikic/php-parser) >= 4.7 with php-composer(nikic/php-parser) < 5)
+BuildRequires: (php-composer(nikic/php-parser) >= 4.10 with php-composer(nikic/php-parser) < 5)
# remirepo:3
%else
-BuildRequires: php-nikic-php-parser4 >= 4.7
+BuildRequires: php-nikic-php-parser4 >= 4.10
%endif
-BuildRequires: php-spl
# Autoloader
BuildRequires: php-fedora-autoloader-devel >= 1.0.0
%if %{with tests}
# from composer.json, "require-dev": {
-# "phpunit/phpunit": "^9.3"
-BuildRequires: phpunit9 >= 9.3
+# "phpunit/phpunit": "^10.0"
+BuildRequires: phpunit10
%endif
# from composer.json, "require": {
-# "php": ">=7.3",
-# "nikic/php-parser": "^4.7"
-Requires: php(language) >= 7.3
+# "php": ">=8.1",
+# "nikic/php-parser": "^4.10"
+Requires: php(language) >= 8.1
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-Requires: (php-composer(nikic/php-parser) >= 4.7 with php-composer(nikic/php-parser) < 5)
+Requires: (php-composer(nikic/php-parser) >= 4.10 with php-composer(nikic/php-parser) < 5)
# remirepo:3
%else
-Requires: php-nikic-php-parser4 >= 4.7
+Requires: php-nikic-php-parser4 >= 4.10
%endif
-# from phpcompatinfo report for version 2.0.0
-Requires: php-spl
+# from phpcompatinfo report for version 3.0.0
+# none
# Autoloader
Requires: php-composer(fedora/autoloader)
@@ -101,10 +102,10 @@ touch vendor/autoload.php
: Run upstream test suite
ret=0
-for cmd in php php73 php74 php80; do
+for cmd in php php81 php82; do
if which $cmd; then
$cmd -d auto_prepend_file=%{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}%{major}/autoload.php \
- %{_bindir}/phpunit9 --verbose || ret=1
+ %{_bindir}/phpunit10 --verbose || ret=1
fi
done
exit $ret
@@ -124,6 +125,13 @@ exit $ret
%changelog
+* Fri Feb 3 2023 Remi Collet <remi@remirepo.net> - 3.0.0-1
+- update to 3.0.0
+- raise dependency on PHP 8.1
+- raise dependency on nikic/php-parser 4.10
+- rename to php-sebastian-complexity3
+- move to /usr/share/php/SebastianBergmann/Complexity3
+
* Tue Oct 27 2020 Remi Collet <remi@remirepo.net> - 2.0.2-1
- update to 2.0.2