summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json3
-rw-r--r--php-sebastian-complexity.spec25
2 files changed, 18 insertions, 10 deletions
diff --git a/composer.json b/composer.json
index 7aa3831..592e418 100644
--- a/composer.json
+++ b/composer.json
@@ -14,9 +14,10 @@
"support": {
"issues": "https://github.com/sebastianbergmann/complexity/issues"
},
+ "prefer-stable": true,
"require": {
"php": ">=7.3",
- "nikic/php-parser": "^4.7"
+ "nikic/php-parser": "^4.18 || ^5.0"
},
"require-dev": {
"phpunit/phpunit": "^9.3"
diff --git a/php-sebastian-complexity.spec b/php-sebastian-complexity.spec
index 0d32a58..7e5e77c 100644
--- a/php-sebastian-complexity.spec
+++ b/php-sebastian-complexity.spec
@@ -9,7 +9,7 @@
%bcond_without tests
# github
-%global gh_commit 739b35e53379900cc9ac327b2147867b8b6efd88
+%global gh_commit 25f207c40d62b8b7aa32f5ab026c53561964053a
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project complexity
@@ -23,8 +23,8 @@
%global ns_project Complexity
Name: php-%{pk_vendor}-%{pk_project}%{major}
-Version: 2.0.2
-Release: 7%{?dist}
+Version: 2.0.3
+Release: 1%{?dist}
Summary: Calculating the complexity of PHP code units, version 2
License: BSD-3-Clause
@@ -37,10 +37,10 @@ BuildArch: noarch
BuildRequires: php(language) >= 7.3
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-BuildRequires: (php-composer(nikic/php-parser) >= 4.7 with php-composer(nikic/php-parser) < 5)
+BuildRequires: (php-composer(nikic/php-parser) >= 4.18 with php-composer(nikic/php-parser) < 6)
# remirepo:3
%else
-BuildRequires: php-nikic-php-parser4 >= 4.7
+BuildRequires: php-nikic-php-parser4 >= 4.18
%endif
BuildRequires: php-spl
# Autoloader
@@ -53,14 +53,14 @@ BuildRequires: phpunit9 >= 9.3
# from composer.json, "require": {
# "php": ">=7.3",
-# "nikic/php-parser": "^4.7"
+# "nikic/php-parser": "^4.18 || ^5.0"
Requires: php(language) >= 7.3
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-Requires: (php-composer(nikic/php-parser) >= 4.7 with php-composer(nikic/php-parser) < 5)
+Requires: (php-composer(nikic/php-parser) >= 4.18 with php-composer(nikic/php-parser) < 6)
# remirepo:3
%else
-Requires: php-nikic-php-parser4 >= 4.7
+Requires: php-nikic-php-parser4 >= 4.18
%endif
# from phpcompatinfo report for version 2.0.0
Requires: php-spl
@@ -88,7 +88,10 @@ phpab --template fedora --output src/autoload.php src
cat <<EOF | tee -a src/autoload.php
\Fedora\Autoloader\Dependencies::required([
- '%{php_home}/PhpParser4/autoload.php',
+ [
+ '%{php_home}/PhpParser5/autoload.php',
+ '%{php_home}/PhpParser4/autoload.php',
+ ],
]);
EOF
@@ -128,6 +131,10 @@ exit $ret
%changelog
+* Fri Dec 22 2023 Remi Collet <remi@remirepo.net> - 2.0.3-1
+- update to 2.0.3
+- raise dependency on nikic/php-parser 4.18 and allow 5.0
+
* Fri Apr 21 2023 Remi Collet <remi@remirepo.net> - 2.0.2-7
- use SPDX License id