summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-09-28 10:09:53 +0200
committerRemi Collet <remi@remirepo.net>2020-09-28 10:09:53 +0200
commite72971c15aac8a3231f6f1a7a98665a9b9c553e7 (patch)
tree54d171a4aa13168feab259f3777c66724b49423e
parent1d7d3b55eb784d62ae5e7f75c69f057c26bcc934 (diff)
update to 2.0.1 (no change)
-rw-r--r--composer.json4
-rw-r--r--php-sebastian-complexity.spec19
2 files changed, 11 insertions, 12 deletions
diff --git a/composer.json b/composer.json
index 204f696..7aa3831 100644
--- a/composer.json
+++ b/composer.json
@@ -15,11 +15,11 @@
"issues": "https://github.com/sebastianbergmann/complexity/issues"
},
"require": {
- "php": "^7.3 || ^8.0",
+ "php": ">=7.3",
"nikic/php-parser": "^4.7"
},
"require-dev": {
- "phpunit/phpunit": "^9.2"
+ "phpunit/phpunit": "^9.3"
},
"config": {
"platform": {
diff --git a/php-sebastian-complexity.spec b/php-sebastian-complexity.spec
index 144a5a3..824a07c 100644
--- a/php-sebastian-complexity.spec
+++ b/php-sebastian-complexity.spec
@@ -6,14 +6,10 @@
#
# Please, preserve the changelog entries
#
-%bcond_with bootstrap
-%if %{with bootstrap}
-%bcond_with tests
-%else
%bcond_without tests
-%endif
+
# github
-%global gh_commit 33fcd6a26656c6546f70871244ecba4b4dced097
+%global gh_commit ba8cc2da0c0bfbc813d03b56406734030c7f1eff
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project complexity
@@ -27,7 +23,7 @@
%global ns_project Complexity
Name: php-%{pk_vendor}-%{pk_project}%{major}
-Version: 2.0.0
+Version: 2.0.1
Release: 1%{?dist}
Summary: Calculating the complexity of PHP code units
@@ -51,12 +47,12 @@ BuildRequires: php-spl
BuildRequires: php-fedora-autoloader-devel >= 1.0.0
%if %{with tests}
# from composer.json, "require-dev": {
-# "phpunit/phpunit": "^9.2"
-BuildRequires: phpunit9 >= 9.2
+# "phpunit/phpunit": "^9.3"
+BuildRequires: phpunit9 >= 9.3
%endif
# from composer.json, "require": {
-# "php": "^7.3 || ^8.0",
+# "php": ">=7.3",
# "nikic/php-parser": "^4.7"
Requires: php(language) >= 7.3
# remirepo:1
@@ -128,5 +124,8 @@ exit $ret
%changelog
+* Mon Sep 28 2020 Remi Collet <remi@remirepo.net> - 2.0.1-1
+- update to 2.0.1 (no change)
+
* Mon Aug 10 2020 Remi Collet <remi@remirepo.net> - 2.0.0-1
- initial package