summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json2
-rw-r--r--php-sebastian-comparator4.spec17
2 files changed, 11 insertions, 8 deletions
diff --git a/composer.json b/composer.json
index f77d2c8..965e64a 100644
--- a/composer.json
+++ b/composer.json
@@ -24,7 +24,7 @@
],
"prefer-stable": true,
"require": {
- "php": "^7.3",
+ "php": "^7.3 || ^8.0",
"sebastian/diff": "^4.0",
"sebastian/exporter": "^4.0"
},
diff --git a/php-sebastian-comparator4.spec b/php-sebastian-comparator4.spec
index a2eb141..61e7375 100644
--- a/php-sebastian-comparator4.spec
+++ b/php-sebastian-comparator4.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 266d85ef789da8c41f06af4093c43e9798af2784
+%global gh_commit dcc580eadfaa4e7f9d2cf9ae1922134ea962e14f
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project comparator
@@ -20,13 +20,13 @@
%global ns_vendor SebastianBergmann
%global ns_project Comparator
%if %{bootstrap}
-%global with_tests %{?_with_tests:1}%{!?_with_tests:0}
+%bcond_with tests
%else
-%global with_tests %{?_without_tests:0}%{!?_without_tests:1}
+%bcond_without tests
%endif
Name: php-%{pk_vendor}-%{pk_project}%{major}
-Version: 4.0.2
+Version: 4.0.3
Release: 1%{?dist}
Summary: Compare PHP values for equality
@@ -48,14 +48,14 @@ BuildRequires: php-sebastian-diff4
BuildRequires: php-sebastian-exporter4
%endif
BuildRequires: php-fedora-autoloader-devel
-%if %{with_tests}
+%if %{with tests}
# from composer.json, "require-dev": {
# "phpunit/phpunit": "^9.0"
BuildRequires: phpunit9
%endif
# from composer.json
-# "php": "^7.3",
+# "php": "^7.3 || ^8.0",
# "sebastian/diff": "^4.0",
# "sebastian/exporter": "^4.0"
Requires: php(language) >= 7.3
@@ -108,7 +108,7 @@ cp -pr src %{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}%{major}
%check
-%if %{with_tests}
+%if %{with tests}
mkdir vendor
%{_bindir}/phpab --template fedora --output vendor/autoload.php tests/_fixture
@@ -135,6 +135,9 @@ exit $ret
%changelog
+* Mon Jun 29 2020 Remi Collet <remi@remirepo.net> - 4.0.3-1
+- update to 4.0.3
+
* Tue Jun 16 2020 Remi Collet <remi@remirepo.net> - 4.0.2-1
- update to 4.0.2
- sources from git snapshot