summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--php-sebastian-code-unit2.spec14
1 files changed, 9 insertions, 5 deletions
diff --git a/php-sebastian-code-unit2.spec b/php-sebastian-code-unit2.spec
index 5bc8206..2e42a22 100644
--- a/php-sebastian-code-unit2.spec
+++ b/php-sebastian-code-unit2.spec
@@ -7,8 +7,7 @@
# Please, preserve the changelog entries
#
-# disabled until phpunit10 available
-%bcond_with tests
+%bcond_without tests
# Sources
%global gh_commit a81fee9eef0b7a76af11d121767abc44c104e503
@@ -26,8 +25,8 @@
Name: php-%{pk_vendor}-%{pk_project}%{major}
Version: 2.0.0
-Release: 1%{?dist}
-Summary: Collection of value objects that represent the PHP code units
+Release: 3%{?dist}
+Summary: Collection of value objects that represent the PHP code units, version %{major}
License: BSD-3-Clause
URL: https://github.com/%{gh_owner}/%{gh_project}
@@ -61,6 +60,8 @@ Provides: php-composer(%{pk_vendor}/%{pk_project}) = %{version}
%description
Collection of value objects that represent the PHP code units.
+This package provides version %{major} of %{pk_vendor}/%{pk_project} library.
+
Autoloader: %{php_home}/%{ns_vendor}/%{ns_project}%{major}/autoload.php
@@ -100,7 +101,7 @@ EOF
: Run tests
ret=0
-for cmd in php php81 php82; do
+for cmd in php php81 php82 php83; do
if which $cmd; then
$cmd -d auto_prepend_file=%{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}%{major}/autoload.php \
%{_bindir}/phpunit10 --bootstrap vendor/autoload.php || ret=1
@@ -120,6 +121,9 @@ exit $ret
%changelog
+* Wed Aug 23 2023 Remi Collet <remi@remirepo.net> - 2.0.0-3
+- Enable test suite
+
* Fri Feb 3 2023 Remi Collet <remi@remirepo.net> - 2.0.0-1
- update to 2.0.0
- raise dependency on PHP 8.1