summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-02-03 13:57:08 +0100
committerRemi Collet <remi@php.net>2023-02-03 13:57:08 +0100
commit4d0d77c71588c886f9f8d566b2fa4a110c8893e0 (patch)
treeb7cbe7e5d96a0038ec29cc6fb8a14fb94e1cce9b
parentbf119ad79cb72eeb53e2729856d35265689552e4 (diff)
update to 2.0.0
raise dependency on PHP 8.1 rename to php-sebastian-code-unit2 move to /usr/share/php/SebastianBergmann/CodeUnit2
-rw-r--r--composer.json8
-rw-r--r--php-sebastian-code-unit2.spec37
2 files changed, 26 insertions, 19 deletions
diff --git a/composer.json b/composer.json
index 5b86ec5..8cec528 100644
--- a/composer.json
+++ b/composer.json
@@ -16,14 +16,14 @@
},
"prefer-stable": true,
"require": {
- "php": ">=7.3"
+ "php": ">=8.1"
},
"require-dev": {
- "phpunit/phpunit": "^9.3"
+ "phpunit/phpunit": "^10.0"
},
"config": {
"platform": {
- "php": "7.3.0"
+ "php": "8.1.0"
},
"optimize-autoloader": true,
"sort-packages": true
@@ -44,7 +44,7 @@
},
"extra": {
"branch-alias": {
- "dev-master": "1.0-dev"
+ "dev-main": "2.0-dev"
}
}
}
diff --git a/php-sebastian-code-unit2.spec b/php-sebastian-code-unit2.spec
index 442b4c4..7fbd2a2 100644
--- a/php-sebastian-code-unit2.spec
+++ b/php-sebastian-code-unit2.spec
@@ -1,16 +1,17 @@
-# remirepo/fedora spec file for php-sebastian-code-unit
+# remirepo/fedora spec file for php-sebastian-code-unit2
#
-# Copyright (c) 2020 Remi Collet
-# License: CC-BY-SA
+# Copyright (c) 2020-2023 Remi Collet
+# License: CC-BY-SA-4.0
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
-%bcond_without tests
+# disabled until phpunit10 available
+%bcond_with tests
# Sources
-%global gh_commit 1fc9f64c0927627ef78ba436c9b17d967e68e120
+%global gh_commit a81fee9eef0b7a76af11d121767abc44c104e503
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project code-unit
@@ -18,13 +19,13 @@
%global pk_vendor sebastian
%global pk_project %{gh_project}
# Namespace
-%global major %nil
+%global major 2
%global php_home %{_datadir}/php
%global ns_vendor SebastianBergmann
%global ns_project CodeUnit
Name: php-%{pk_vendor}-%{pk_project}%{major}
-Version: 1.0.8
+Version: 2.0.0
Release: 1%{?dist}
Summary: Collection of value objects that represent the PHP code units
@@ -34,21 +35,21 @@ Source0: %{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
BuildArch: noarch
-BuildRequires: php(language) >= 7.3
+BuildRequires: php(language) >= 8.1
BuildRequires: php-reflection
BuildRequires: php-spl
# Autoloader
BuildRequires: php-fedora-autoloader-devel
%if %{with tests}
# from composer.json, "require-dev": {
-# "phpunit/phpunit": "^9.3"
-BuildRequires: phpunit9 >= 9.3
+# "phpunit/phpunit": "^10.0"
+BuildRequires: phpunit10
%endif
# from composer.json, "require": {
-# "php": ">=7.3"
-Requires: php(language) >= 7.3
-# From phpcompatinfo report for 1.0.0
+# "php": ">=8.1"
+Requires: php(language) >= 8.1
+# From phpcompatinfo report for 2.0.0
Requires: php-reflection
Requires: php-spl
# Autoloader
@@ -99,10 +100,10 @@ EOF
: Run tests
ret=0
-for cmd in php php73 php74 php80; do
+for cmd in php php81 php82; do
if which $cmd; then
$cmd -d auto_prepend_file=%{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}%{major}/autoload.php \
- %{_bindir}/phpunit9 --verbose || ret=1
+ %{_bindir}/phpunit10 --verbose || ret=1
fi
done
exit $ret
@@ -119,6 +120,12 @@ exit $ret
%changelog
+* Fri Feb 3 2023 Remi Collet <remi@remirepo.net> - 2.0.0-1
+- update to 2.0.0
+- raise dependency on PHP 8.1
+- rename to php-sebastian-code-unit2
+- move to /usr/share/php/SebastianBergmann/CodeUnit2
+
* Mon Oct 26 2020 Remi Collet <remi@remirepo.net> - 1.0.8-1
- update to 1.0.8