summaryrefslogtreecommitdiffstats
path: root/php-sebastian-code-unit-reverse-lookup2.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-sebastian-code-unit-reverse-lookup2.spec')
-rw-r--r--php-sebastian-code-unit-reverse-lookup2.spec18
1 files changed, 11 insertions, 7 deletions
diff --git a/php-sebastian-code-unit-reverse-lookup2.spec b/php-sebastian-code-unit-reverse-lookup2.spec
index 7cefb10..df77160 100644
--- a/php-sebastian-code-unit-reverse-lookup2.spec
+++ b/php-sebastian-code-unit-reverse-lookup2.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 5b5dbe0044085ac41df47e79d34911a15b96d82e
+%global gh_commit c771130f0e8669104a4320b7101a81c2cc2963ef
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project code-unit-reverse-lookup
@@ -26,13 +26,14 @@
%endif
Name: php-%{pk_vendor}-%{pk_project}%{major}
-Version: 2.0.0
+Version: 2.0.1
Release: 1%{?dist}
Summary: Looks up which function or method a line of code belongs to
License: BSD
URL: https://github.com/%{gh_owner}/%{gh_project}
-Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{name}-%{version}-%{gh_short}.tar.gz
+Source0: %{name}-%{version}-%{gh_short}.tgz
+Source1: makesrc.sh
BuildArch: noarch
BuildRequires: php(language) >= 7.3
@@ -40,8 +41,7 @@ BuildRequires: php-fedora-autoloader-devel
%if %{with_tests}
# from composer.json, "require-dev": {
# "phpunit/phpunit": "^9.0"
-# TODO test suite passes with v8, switch to v9 when available
-BuildRequires: phpunit8
+BuildRequires: phpunit9
%endif
# from composer.json, "require": {
@@ -82,10 +82,10 @@ touch vendor/autoload.php
: Run upstream test suite
ret=0
-for cmd in php php73 php74; do
+for cmd in php php73 php74 php80; do
if which $cmd; then
$cmd -d auto_prepend_file=%{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}%{major}/autoload.php \
- %{_bindir}/phpunit8 --verbose || ret=1
+ %{_bindir}/phpunit9 --verbose || ret=1
fi
done
exit $ret
@@ -105,6 +105,10 @@ exit $ret
%changelog
+* Tue Jun 16 2020 Remi Collet <remi@remirepo.net> - 2.0.1-1
+- update to 2.0.1
+- sources from git snapshot
+
* Fri Feb 7 2020 Remi Collet <remi@remirepo.net> - 2.0.0-1
- update to 2.0.0
- raise dependency on PHP 7.3