summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-02-13 08:32:02 +0100
committerRemi Collet <fedora@famillecollet.com>2016-02-13 08:32:02 +0100
commite2e944382dcaff0b8e92a67e042db4ce6447f00b (patch)
tree860ec282b07f34f54b1e4762c2ffddd6a2907776
php-sebastian-code-unit-reverse-lookup: 1.0.0, new package
-rw-r--r--Makefile4
-rw-r--r--php-sebastian-code-unit-reverse-lookup.spec107
2 files changed, 111 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/php-sebastian-code-unit-reverse-lookup.spec b/php-sebastian-code-unit-reverse-lookup.spec
new file mode 100644
index 0000000..55d1c90
--- /dev/null
+++ b/php-sebastian-code-unit-reverse-lookup.spec
@@ -0,0 +1,107 @@
+# remirepo/fedora spec file for php-sebastian-code-unit-reverse-lookup
+#
+# Copyright (c) 2016 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+%global bootstrap 0
+%global gh_commit c36f5e7cfce482fde5bf8d10d41a53591e0198fe
+%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
+%global gh_owner sebastianbergmann
+%global gh_project code-unit-reverse-lookup
+%global php_home %{_datadir}/php/SebastianBergmann
+%global ns_name CodeUnitReverseLookup
+%if %{bootstrap}
+%global with_tests %{?_with_tests:1}%{!?_with_tests:0}
+%else
+%global with_tests %{?_without_tests:0}%{!?_without_tests:1}
+%endif
+
+Name: php-%{gh_owner}-%{gh_project}
+Version: 1.0.0
+Release: 1%{?dist}
+Summary: Looks up which function or method a line of code belongs to
+
+Group: Development/Libraries
+License: BSD
+URL: https://github.com/%{gh_owner}/%{gh_project}
+Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{gh_short}.tar.gz
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+BuildArch: noarch
+BuildRequires: php(language) >= 5.6
+BuildRequires: %{_bindir}/phpab
+%if %{with_tests}
+# from composer.json, "require-dev": {
+# "phpunit/phpunit": "~5"
+# Ignore min version on purpose, avoid bootstrap (tested with 4.8)
+BuildRequires: php-composer(phpunit/phpunit)
+%endif
+
+# from composer.json, "require": {
+# "php": ">=5.6"
+Requires: php(language) >= 5.6
+# From phpcompatinfo report for version 1.0.0
+Requires: php-reflection
+
+Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
+
+
+%description
+Looks up which function or method a line of code belongs to.
+
+
+%prep
+%setup -q -n %{gh_project}-%{gh_commit}
+
+
+%build
+# Generate the Autoloader
+phpab --output src/autoload.php src
+
+
+%install
+rm -rf %{buildroot}
+mkdir -p %{buildroot}%{php_home}
+cp -pr src %{buildroot}%{php_home}/%{ns_name}
+
+
+%check
+%if %{with_tests}
+mkdir vendor
+cat << 'EOF' | tee vendor/autoload.php
+<?php
+require 'SebastianBergmann/%{ns_name}/autoload.php';
+EOF
+
+%{_bindir}/php -d include_path=.:%{buildroot}%{_datadir}/php:%{_datadir}/php \
+%{_bindir}/phpunit --verbose
+
+if which php70; then
+ php70 -d include_path=.:%{buildroot}%{_datadir}/php:%{_datadir}/php \
+ %{_bindir}/phpunit --verbose
+fi
+%else
+: bootstrap build with test suite disabled
+%endif
+
+
+%clean
+rm -rf %{buildroot}
+
+
+%files
+%defattr(-,root,root,-)
+%{!?_licensedir:%global license %%doc}
+%license LICENSE
+%doc *.md
+%doc composer.json
+%dir %{php_home}
+%{php_home}/%{ns_name}
+
+
+%changelog
+* Sat Feb 13 2016 Remi Collet <remi@fedoraproject.org> - 1.0.0-1
+- initial package \ No newline at end of file