summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2017-03-04 10:10:10 +0100
committerRemi Collet <fedora@famillecollet.com>2017-03-04 10:10:10 +0100
commit7383ebccbdb93c2c5dfae091b56799823f63c4c9 (patch)
treecf5f0e893b5840c7298f886ee72a962514ed1f25
parentad0177f6868aec947961ca9295263ba96e8c9172 (diff)
php-sebastian-code-unit-reverse-lookup: 1.0.1
-rw-r--r--composer.json4
-rw-r--r--php-sebastian-code-unit-reverse-lookup.spec15
2 files changed, 11 insertions, 8 deletions
diff --git a/composer.json b/composer.json
index a23bbef..b9a2419 100644
--- a/composer.json
+++ b/composer.json
@@ -10,10 +10,10 @@
}
],
"require": {
- "php": ">=5.6"
+ "php": "^5.6 || ^7.0"
},
"require-dev": {
- "phpunit/phpunit": "~5"
+ "phpunit/phpunit": "^5.7 || ^6.0"
},
"autoload": {
"classmap": [
diff --git a/php-sebastian-code-unit-reverse-lookup.spec b/php-sebastian-code-unit-reverse-lookup.spec
index 7bb3c16..a4c3297 100644
--- a/php-sebastian-code-unit-reverse-lookup.spec
+++ b/php-sebastian-code-unit-reverse-lookup.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit c36f5e7cfce482fde5bf8d10d41a53591e0198fe
+%global gh_commit 4419fcdb5eabb9caa61a27c7a1db532a6b55dd18
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project code-unit-reverse-lookup
@@ -20,8 +20,8 @@
%endif
Name: php-sebastian-%{gh_project}
-Version: 1.0.0
-Release: 2%{?dist}
+Version: 1.0.1
+Release: 1%{?dist}
Summary: Looks up which function or method a line of code belongs to
Group: Development/Libraries
@@ -35,13 +35,13 @@ BuildRequires: php(language) >= 5.6
BuildRequires: php-fedora-autoloader-devel
%if %{with_tests}
# from composer.json, "require-dev": {
-# "phpunit/phpunit": "~5"
+# "phpunit/phpunit": "^5.7 || ^6.0"
# Ignore min version on purpose, avoid bootstrap (tested with 4.8)
BuildRequires: php-composer(phpunit/phpunit)
%endif
# from composer.json, "require": {
-# "php": ">=5.6"
+# "php": "^5.6 || ^7.0"
Requires: php(language) >= 5.6
# From phpcompatinfo report for version 1.0.0
Requires: php-reflection
@@ -91,7 +91,7 @@ if which php56; then
fi
if which php71; then
php71 -d include_path=.:%{buildroot}%{_datadir}/php:%{_datadir}/php \
- %{_bindir}/phpunit --verbose || ret=1
+ %{_bindir}/phpunit6 --verbose || ret=1
run=1
fi
if [ $run -eq 0 ]; then
@@ -120,6 +120,9 @@ rm -rf %{buildroot}
%changelog
+* Sat Mar 4 2017 Remi Collet <remi@remirepo.net> - 1.0.1-1
+- Update to 1.0.1 (no change)
+
* Mon Oct 31 2016 Remi Collet <remi@fedoraproject.org> - 1.0.0-2
- switch to fedora/autoloader