summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-02-03 15:14:35 +0100
committerRemi Collet <remi@php.net>2023-02-03 15:14:35 +0100
commit0fe556c3e36068febc47e6ba976d9a0d212186f3 (patch)
tree80a2fcf1b8b1b818d83d759cef6df4f1e5bc2954
parentecfbd06a58ab84f5c25945d612bb65c325d37a7b (diff)
update to 6.0.0
drop patch merged upstream raise dependency on PHP 8.1 rename to php-phpunit-php-timer6 move to /usr/share/php/SebastianBergmann/Timer6
-rw-r--r--composer.json8
-rw-r--r--php-phpunit-php-timer6.spec43
2 files changed, 29 insertions, 22 deletions
diff --git a/composer.json b/composer.json
index 001701c..6f5880b 100644
--- a/composer.json
+++ b/composer.json
@@ -19,14 +19,14 @@
},
"prefer-stable": true,
"require": {
- "php": ">=7.3"
+ "php": ">=8.1"
},
"require-dev": {
- "phpunit/phpunit": "^9.3"
+ "phpunit/phpunit": "^10.0"
},
"config": {
"platform": {
- "php": "7.3.0"
+ "php": "8.1.0"
},
"optimize-autoloader": true,
"sort-packages": true
@@ -38,7 +38,7 @@
},
"extra": {
"branch-alias": {
- "dev-master": "5.0-dev"
+ "dev-main": "6.0-dev"
}
}
}
diff --git a/php-phpunit-php-timer6.spec b/php-phpunit-php-timer6.spec
index 4ef85c3..0f37627 100644
--- a/php-phpunit-php-timer6.spec
+++ b/php-phpunit-php-timer6.spec
@@ -1,15 +1,17 @@
-# remirepo/fedora spec file for php-phpunit-php-timer4
+# remirepo/fedora spec file for php-phpunit-php-timer6
#
-# Copyright (c) 2010-2020 Christof Damian, Remi Collet
+# Copyright (c) 2010-2023 Christof Damian, Remi Collet
#
# License: MIT
# http://opensource.org/licenses/MIT
#
# Please, preserve the changelog entries
#
-%bcond_without tests
-%global gh_commit 5a63ce20ed1b5bf577850e2c4e87f4aa902afbd2
+# disabled until phpunit10 available
+%bcond_with tests
+
+%global gh_commit e2a2d67966e740530f4a3343fe2e030ffdc1161d
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project php-timer
@@ -20,12 +22,12 @@
%global ns_vendor SebastianBergmann
%global ns_project Timer
-%global major 5
+%global major 6
%global php_home %{_datadir}/php
Name: php-%{pk_vendor}-%{pk_project}%{major}
-Version: 5.0.3
-Release: 2%{?dist}
+Version: 6.0.0
+Release: 1%{?dist}
Summary: PHP Utility class for timing, version %{major}
License: BSD-3-Clause
@@ -33,21 +35,20 @@ URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: %{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
-Patch0: https://patch-diff.githubusercontent.com/raw/sebastianbergmann/php-timer/pull/36.patch
-
BuildArch: noarch
-BuildRequires: php(language) >= 7.3
+BuildRequires: php(language) >= 8.1
+BuildRequires: php-spl
BuildRequires: php-fedora-autoloader-devel
%if %{with tests}
# From composer.json"require-dev": {
-# "phpunit/phpunit": "^9.3"
-BuildRequires: phpunit9 >= 9.3
+# "phpunit/phpunit": "^10.0"
+BuildRequires: phpunit10
%endif
# From composer.json
-# "php": ">=7.3"
-Requires: php(language) >= 7.3
-# From phpcompatinfo report for version 4.0.0
+# "php": ">=8.1"
+Requires: php(language) >= 8.1
+# From phpcompatinfo report for version 6.0.0
Requires: php-spl
# Autoloader
Requires: php-composer(fedora/autoloader)
@@ -62,7 +63,6 @@ component.
%prep
%setup -q -n %{gh_project}-%{gh_commit}
-%patch0 -p1
%build
@@ -84,10 +84,10 @@ touch vendor/autoload.php
: Run upstream test suite
ret=0
-for cmd in php php73 php74 php80; do
+for cmd in php php81 php82; do
if which $cmd; then
$cmd -d auto_prepend_file=%{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}%{major}/autoload.php \
- %{_bindir}/phpunit9 \
+ %{_bindir}/phpunit10 \
--verbose || ret=1
fi
done
@@ -106,6 +106,13 @@ exit $ret
%changelog
+* Fri Feb 3 2023 Remi Collet <remi@remirepo.net> - 6.0.0-1
+- update to 6.0.0
+- drop patch merged upstream
+- raise dependency on PHP 8.1
+- rename to php-phpunit-php-timer6
+- move to /usr/share/php/SebastianBergmann/Timer6
+
* Tue Oct 27 2020 Remi Collet <remi@remirepo.net> - 5.0.3-2
- add patch for test suite on 32-bit from
https://github.com/sebastianbergmann/php-timer/pull/36