summaryrefslogtreecommitdiffstats
path: root/composer.json
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-09-16 14:10:46 +0200
committerRemi Collet <remi@remirepo.net>2019-09-16 14:10:46 +0200
commited118e254bde4c6321c41fb1f5ad574f75b815e7 (patch)
treee9073b0a76f85fafcb0b42c3701f10885f159525 /composer.json
new package
Diffstat (limited to 'composer.json')
-rw-r--r--composer.json51
1 files changed, 51 insertions, 0 deletions
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..884ddb6
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,51 @@
+{
+ "name": "scssphp/scssphp",
+ "type": "library",
+ "description": "scssphp is a compiler for SCSS written in PHP.",
+ "keywords": ["css", "stylesheet", "scss", "sass", "less"],
+ "homepage": "http://scssphp.github.io/scssphp/",
+ "license": [
+ "MIT"
+ ],
+ "authors": [
+ {
+ "name": "Anthon Pang",
+ "email": "apang@softwaredevelopment.ca",
+ "homepage": "https://github.com/robocoder"
+ },
+ {
+ "name": "Cédric Morin",
+ "email": "cedric@yterium.com",
+ "homepage": "https://github.com/Cerdic"
+ }
+ ],
+ "autoload": {
+ "psr-4": { "ScssPhp\\ScssPhp\\": "src/" }
+ },
+ "autoload-dev": {
+ "psr-4": { "ScssPhp\\ScssPhp\\Tests\\": "tests/" }
+ },
+ "require": {
+ "php": ">=5.6.0",
+ "ext-json": "*",
+ "ext-ctype": "*"
+ },
+ "require-dev": {
+ "squizlabs/php_codesniffer": "~2.5",
+ "phpunit/phpunit": ">=4.8.36",
+ "twbs/bootstrap": "~4.3",
+ "zurb/foundation": "~6.5"
+ },
+ "minimum-stability": "dev",
+ "bin": ["bin/pscss"],
+ "archive": {
+ "exclude": [
+ "/Makefile",
+ "/.gitattributes",
+ "/.gitignore",
+ "/.travis.yml",
+ "/phpunit.xml.dist",
+ "/tests"
+ ]
+ }
+}