summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json4
-rw-r--r--php-sanmai-phpunit-legacy-adapter.spec34
2 files changed, 24 insertions, 14 deletions
diff --git a/composer.json b/composer.json
index 80676db..ae7a5c5 100644
--- a/composer.json
+++ b/composer.json
@@ -10,10 +10,10 @@
}
],
"require": {
- "phpunit/phpunit": "^7 || ^8 || ^9"
+ "phpunit/phpunit": "^7 || ^8 || ^9 || ^10"
},
"require-dev": {
- "phpunit/phpunit": "^7.5.20 || ^8.5.9 || ^9.4.3",
+ "phpunit/phpunit": "^7.5.20 || ^8.5.29 || ^9.5.24 || ^10.1.2",
"friendsofphp/php-cs-fixer": "^2.16"
},
"config": {
diff --git a/php-sanmai-phpunit-legacy-adapter.spec b/php-sanmai-phpunit-legacy-adapter.spec
index 385cbe0..7a7f911 100644
--- a/php-sanmai-phpunit-legacy-adapter.spec
+++ b/php-sanmai-phpunit-legacy-adapter.spec
@@ -1,7 +1,7 @@
# remirepo/fedora spec file for php-sanmai-phpunit-legacy-adapter
#
-# Copyright (c) 2020 Remi Collet
-# License: CC-BY-SA
+# Copyright (c) 2020-2023 Remi Collet
+# License: CC-BY-SA-4.0
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
@@ -9,7 +9,7 @@
%bcond_without tests
-%global gh_commit 3db58a31847d803f76cab3da14e334a2d090c067
+%global gh_commit aa08b49eac291a49f50e9a094f23b267cc5a9bec
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_date 20150618
%global gh_owner sanmai
@@ -17,12 +17,11 @@
%global ns_project LegacyPHPUnit
Name: php-%{gh_owner}-%{gh_project}
-Version: 8.2.1
+Version: 8.2.2
Release: 1%{?dist}
Summary: PHPUnit Legacy Versions Adapter
-Group: Development/Libraries
-License: ASL 2.0
+License: Apache-2.0
URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{gh_short}.tar.gz
@@ -30,8 +29,10 @@ BuildArch: noarch
%if %{with tests}
BuildRequires: phpunit7
BuildRequires: phpunit8
-%if 0%{?fedora} >= 32 || 0%{?rhel} >= 9
BuildRequires: phpunit9
+# remirepo:3
+%if 0%{?fedora} >= 36 || 0%{?rhel} >= 10
+BuildRequires: phpunit10
%endif
%endif
BuildRequires: php-fedora-autoloader-devel
@@ -50,7 +51,7 @@ Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
%description
PHPUnit Legacy Versions Adapter.
-This version is compatible with phpunit version 7, 8 and 9.
+This version is compatible with phpunit version 7, 8, 9 and 10.
Autoloader: %{_datadir}/php/%{ns_project}/autoload.php
@@ -84,20 +85,26 @@ EOF
: run upstream test suite with all php and phpunit versions
ret=0
-for cmd in php php71 php72 php73 php74 php80
+for cmd in php80 php81 php82
do
if which $cmd; then
$cmd %{_bindir}/phpunit7 --verbose || ret=1
fi
done
-for cmd in php php72 php73 php74 php80
+for cmd in php80 php81 php82
do
if which $cmd; then
$cmd %{_bindir}/phpunit8 --verbose || ret=1
fi
done
-if [ -x %{_bindir}/phpunit9 ]; then
- for cmd in php php73 php74 php80
+for cmd in php80 php81 php82
+do
+ if which $cmd; then
+ $cmd %{_bindir}/phpunit9 --verbose || ret=1
+ fi
+done
+if [ -x %{_bindir}/phpunit10 ]; then
+ for cmd in php80 php81 php82
do
if which $cmd; then
$cmd %{_bindir}/phpunit9 --verbose || ret=1
@@ -120,5 +127,8 @@ exit $ret
%changelog
+* Tue May 30 2023 Remi Collet <remi@remirepo.net> - 8.2.2-1
+- update to 8.2.2 (no change)
+
* Tue Dec 22 2020 Remi Collet <remi@fedoraproject.org> - 8.2.1-1
- initial package