summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-12-22 11:29:11 +0100
committerRemi Collet <remi@remirepo.net>2020-12-22 11:29:11 +0100
commit03b9f804928ef09cd47a9e05a05a4e9998ccd4f5 (patch)
treed7198850ee7725577ae88d559450d2a06fb519a4
New package
-rw-r--r--.gitignore9
-rw-r--r--Makefile4
-rw-r--r--composer.json38
-rw-r--r--php-sanmai-phpunit-legacy-adapter.spec121
4 files changed, 172 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..01f0400
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,9 @@
+clog
+package-*.xml
+*.tgz
+*.tar.bz2
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..91b0fd5
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../common/Makefile
+
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..80676db
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,38 @@
+{
+ "name": "sanmai/phpunit-legacy-adapter",
+ "type": "library",
+ "description": "PHPUnit Legacy Versions Adapter",
+ "license": "Apache-2.0",
+ "authors": [
+ {
+ "name": "Alexey Kopytko",
+ "email": "alexey@kopytko.com"
+ }
+ ],
+ "require": {
+ "phpunit/phpunit": "^7 || ^8 || ^9"
+ },
+ "require-dev": {
+ "phpunit/phpunit": "^7.5.20 || ^8.5.9 || ^9.4.3",
+ "friendsofphp/php-cs-fixer": "^2.16"
+ },
+ "config": {
+ "sort-packages": true
+ },
+ "extra": {
+ "branch-alias": {
+ "dev-master": "8.x-dev",
+ "dev-legacy": "6.x-dev"
+ }
+ },
+ "autoload": {
+ "psr-4": {
+ "LegacyPHPUnit\\": "src/"
+ }
+ },
+ "autoload-dev": {
+ "psr-4": {
+ "Tests\\LegacyPHPUnit\\": "tests/"
+ }
+ }
+}
diff --git a/php-sanmai-phpunit-legacy-adapter.spec b/php-sanmai-phpunit-legacy-adapter.spec
new file mode 100644
index 0000000..58c23b0
--- /dev/null
+++ b/php-sanmai-phpunit-legacy-adapter.spec
@@ -0,0 +1,121 @@
+# remirepo/fedora spec file for php-sanmai-phpunit-legacy-adapter
+#
+# Copyright (c) 2020 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+
+%bcond_without tests
+
+%global gh_commit 3db58a31847d803f76cab3da14e334a2d090c067
+%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
+%global gh_date 20150618
+%global gh_owner sanmai
+%global gh_project phpunit-legacy-adapter
+%global ns_project LegacyPHPUnit
+
+Name: php-%{gh_owner}-%{gh_project}
+Version: 8.2.1
+Release: 1%{?dist}
+Summary: PHPUnit Legacy Versions Adapter
+
+Group: Development/Libraries
+License: ASL 2.0
+URL: https://github.com/%{gh_owner}/%{gh_project}
+Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{gh_short}.tar.gz
+
+BuildArch: noarch
+BuildRequires: php(language) > 7.1
+%if %{with tests}
+BuildRequires: phpunit7
+BuildRequires: phpunit8
+BuildRequires: phpunit9
+%endif
+BuildRequires: php-fedora-autoloader-devel
+
+Requires: php(language) >= 7.1
+# From composer.json
+# ignore phpunit dependency
+# From phpcompatinfo
+# Only Core and standard
+# Autoloader
+Requires: php-composer(fedora/autoloader)
+
+Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
+
+
+%description
+PHPUnit Legacy Versions Adapter.
+
+This version is compatible with phpunit version 7, 8 and 9.
+
+Autoloader: %{_datadir}/php/%{ns_project}/autoload.php
+
+
+
+%prep
+%setup -q -n %{gh_project}-%{gh_commit}
+
+
+%build
+# Generate a simple classmap autoloader
+%{_bindir}/phpab \
+ --template fedora \
+ --output src/autoload.php \
+ src
+
+
+%install
+mkdir -p %{buildroot}%{_datadir}/php/
+cp -pr src %{buildroot}%{_datadir}/php/%{ns_project}
+
+
+%check
+%if %{with tests}
+mkdir vendor
+cat << 'EOF' | tee vendor/autoload.php
+<?php
+require '%{buildroot}%{_datadir}/php/%{ns_project}/autoload.php';
+\Fedora\Autoloader\Autoload::addPsr4('Tests\\%{ns_project}\\', dirname(__DIR__) .'/tests');
+EOF
+
+: run upstream test suite with all php and phpunit versions
+ret=0
+for cmd in php php71 php72 php73 php74 php80
+do
+ if which $cmd; then
+ $cmd %{_bindir}/phpunit7 --verbose || ret=1
+ fi
+done
+for cmd in php php72 php73 php74 php80
+do
+ if which $cmd; then
+ $cmd %{_bindir}/phpunit8 --verbose || ret=1
+ fi
+done
+for cmd in php php73 php74 php80
+do
+ if which $cmd; then
+ $cmd %{_bindir}/phpunit9 --verbose || ret=1
+ fi
+done
+exit $ret
+%else
+: Test suite disabled
+%endif
+
+
+%files
+# remirepo:1
+%{!?_licensedir:%global license %%doc}
+%license LICENSE
+%doc *.md
+%doc composer.json
+%{_datadir}/php/%{ns_project}
+
+
+%changelog
+* Tue Dec 22 2020 Remi Collet <remi@fedoraproject.org> - 8.2.1-1
+- initial package