summaryrefslogtreecommitdiffstats
path: root/php-sabredav-Sabre_VObject.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-sabredav-Sabre_VObject.spec')
-rw-r--r--php-sabredav-Sabre_VObject.spec20
1 files changed, 14 insertions, 6 deletions
diff --git a/php-sabredav-Sabre_VObject.spec b/php-sabredav-Sabre_VObject.spec
index 3059722..fa3c0ed 100644
--- a/php-sabredav-Sabre_VObject.spec
+++ b/php-sabredav-Sabre_VObject.spec
@@ -1,12 +1,12 @@
%{!?__pear: %{expand: %%global __pear %{_bindir}/pear}}
%global pear_name Sabre_VObject
%global channelname pear.sabredav.org
-%global mainver 1.8.7
-%global reldate 2013-10-02
+%global mainver 1.7.10
+%global reldate 2014-02-09
Name: php-sabredav-Sabre_VObject
Version: 2.1.3
-Release: 1%{?dist}
+Release: 2%{?dist}
Summary: An intuitive reader for iCalendar and vCard objects
Group: Development/Libraries
@@ -28,7 +28,7 @@ Requires(postun): %{__pear}
Requires: php-mbstring
Requires: php-pear(PEAR)
Requires: php-channel(%{channelname})
-Requires: php-pear(%{channelname}/Sabre) >= 1.0.1
+Requires: php-pear(%{channelname}/Sabre) >= 1.0.2
Provides: php-pear(%{pear_name}) = %{version}
Provides: php-pear(%{channelname}/%{pear_name}) = %{version}
@@ -57,11 +57,16 @@ fi
touch error.lst
for fic in $(find Sabre/VObject -type f)
do
- grep $fic %{name}.xml || echo $fic >> error.lst
+ grep $fic %{name}.xml || echo -$fic >> error.lst
+done
+
+for fic in $(grep '<file' %{name}.xml | sed -e 's/.*name="//' -e 's/".*//')
+do
+ [ -f $fic ] || echo +$fic >> error.lst
done
if [ -s error.lst ]; then
- : Missing in %{name}.xml
+ : Error in %{name}.xml
cat error.lst
exit 1
fi
@@ -101,6 +106,9 @@ fi
%changelog
+* Thu Feb 20 2014 Remi Collet <RPMS@FamilleCollet.com> 2.1.3-2
+- rebuild from SabreDAV-1.7.10 sources
+
* Sat Oct 5 2013 Remi Collet <RPMS@FamilleCollet.com> 2.1.3-1
- update to 2.1.3