summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-02-20 10:15:24 +0100
committerRemi Collet <fedora@famillecollet.com>2014-02-20 10:15:24 +0100
commit359332fdc52a5f19fb722b004ab2e4c3e275dbc3 (patch)
tree90d30c33080e9d9f72e3b3bfca45c63dbe97e57a
parent4c2a5e8be6669282194369b0be6342307066fd2b (diff)
php-sabredav-Sabre*: revert to 1.7.x (no namespace)
-rw-r--r--php-sabredav-Sabre_HTTP.spec28
-rw-r--r--php-sabredav-Sabre_HTTP.xml9
2 files changed, 25 insertions, 12 deletions
diff --git a/php-sabredav-Sabre_HTTP.spec b/php-sabredav-Sabre_HTTP.spec
index ffefd26..bcb5056 100644
--- a/php-sabredav-Sabre_HTTP.spec
+++ b/php-sabredav-Sabre_HTTP.spec
@@ -1,10 +1,12 @@
%{!?__pear: %{expand: %%global __pear %{_bindir}/pear}}
%global pear_name Sabre_HTTP
%global channelname pear.sabredav.org
-%global mainver 1.8.5
+%global mainver 1.7.10
+%global reldate 2014-02-09
Name: php-sabredav-Sabre_HTTP
-Version: 1.8.1
+Epoch: 1
+Version: 1.7.10
Release: 1%{?dist}
Summary: HTTP component for the SabreDAV WebDAV framework for PHP
@@ -25,7 +27,7 @@ Requires(post): %{__pear}
Requires(postun): %{__pear}
Requires: php-pear(PEAR)
Requires: php-channel(%{channelname})
-Requires: php-pear(%{channelname}/Sabre) >= 1.0.1
+Requires: php-pear(%{channelname}/Sabre) >= 1.0.2
Provides: php-pear(%{pear_name}) = %{version}
Provides: php-pear(%{channelname}/%{pear_name}) = %{version}
@@ -36,7 +38,9 @@ Sabre_HTTP allows for a central interface to deal with Sabre.
%prep
%setup -q -n SabreDAV
-cp %{SOURCE1} .
+sed -e 's/@VERSION@/%{version}/' \
+ -e 's/@RELDATE@/%{reldate}/' \
+ %{SOURCE1} >%{name}.xml
mv lib/Sabre Sabre
# Check version
@@ -50,11 +54,16 @@ fi
touch error.lst
for fic in $(find Sabre/HTTP -type f)
do
- grep $fic %{name}.xml || echo $fic >> error.lst
+ grep $fic %{name}.xml || echo -$fic >> error.lst
+done
+
+for fic in $(grep '<file' %{name}.xml | sed -e 's/.*name="//' -e 's/".*//')
+do
+ [ -f $fic ] || echo +$fic >> error.lst
done
if [ -s error.lst ]; then
- : Missing in %{name}.xml
+ : Error in %{name}.xml
cat error.lst
exit 1
fi
@@ -93,6 +102,9 @@ fi
%changelog
+* Thu Feb 20 2014 Remi Collet <RPMS@FamilleCollet.com> 1:1.7.10-1
+- revert to 1.7
+
* Tue May 7 2013 Remi Collet <RPMS@FamilleCollet.com> 1.8.5-1
- update to 1.8.1
use our own package.xml as upstream doesn't use pear anymore
@@ -102,9 +114,9 @@ fi
* Wed Oct 31 2012 Joseph Marrero <jmarrero@fedoraproject.org> - 1.6.4-3
- specified php required version pointed out by phpci
-* Sun Oct 12 2012 Joseph Marrero <jmarrero@fedoraproject.org> - 1.6.4-2
+* Fri Oct 12 2012 Joseph Marrero <jmarrero@fedoraproject.org> - 1.6.4-2
- Fixed Description
-* Sun Oct 12 2012 Joseph Marrero <jmarrero@fedoraproject.org> - 1.6.4-1
+* Fri Oct 12 2012 Joseph Marrero <jmarrero@fedoraproject.org> - 1.6.4-1
- Version Bump to 1.6.4
- Add necesary deps and Clean up
- Fix documentation path
diff --git a/php-sabredav-Sabre_HTTP.xml b/php-sabredav-Sabre_HTTP.xml
index 6dcf020..02f8c52 100644
--- a/php-sabredav-Sabre_HTTP.xml
+++ b/php-sabredav-Sabre_HTTP.xml
@@ -13,11 +13,11 @@ In addition Sabre_HTTP provides classes for Basic, Digest and Amazon AWS authent
<email>evert@rooftopsolutions.nl</email>
<active>true</active>
</lead>
- <date>2012-08-02</date>
+ <date>@RELDATE@</date>
<time>17:13:32</time>
<version>
- <release>1.8.1</release>
- <api>1.8.1</api>
+ <release>@VERSION@</release>
+ <api>@VERSION@</api>
</version>
<stability>
<release>stable</release>
@@ -37,8 +37,9 @@ New release. Read the ChangeLog and announcement for more details
<file name="Sabre/HTTP/Response.php" role="php" />
<file name="Sabre/HTTP/Util.php" role="php" />
<file name="Sabre/HTTP/Version.php" role="php" />
+ <file name="Sabre/HTTP/Version.php" role="php" />
<file name="examples/basicauth.php" role="doc" />
- <file name="examples/digestauth.php" role="doc" />
+ <file name="Sabre/HTTP/includes.php" role="doc" />
<file name="ChangeLog" role="doc" />
<file name="LICENSE" role="doc" />
</dir>