summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--php-sabredav-Sabre_DAV.spec15
-rw-r--r--php-sabredav-Sabre_DAV.xml10
2 files changed, 14 insertions, 11 deletions
diff --git a/php-sabredav-Sabre_DAV.spec b/php-sabredav-Sabre_DAV.spec
index 28c82f3..a14ba3a 100644
--- a/php-sabredav-Sabre_DAV.spec
+++ b/php-sabredav-Sabre_DAV.spec
@@ -1,21 +1,19 @@
%{!?__pear: %{expand: %%global __pear %{_bindir}/pear}}
%global pear_name Sabre_DAV
%global channelname pear.sabredav.org
-%global mainver 1.7.10
-%global reldate 2014-02-09
+%global mainver 1.7.13
+%global reldate 2014-07-28
Name: php-sabredav-Sabre_DAV
Epoch: 1
-Version: 1.7.10
+Version: 1.7.13
Release: 1%{?dist}
Summary: Sabre_DAV is a WebDAV framework for PHP
Group: Development/Libraries
License: BSD
-URL: http://code.google.com/p/sabredav
-# https://github.com/fruux/sabre-dav/issues/336
-# Please update PEAR channel
-Source0: http://sabredav.googlecode.com/files/SabreDAV-%{mainver}.zip
+URL: http://sabre.io
+Source0: https://github.com/fruux/sabre-dav/releases/download/%{mainver}/sabredav-%{mainver}.zip
Source1: %{name}.xml
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
@@ -111,6 +109,9 @@ fi
%changelog
+* Tue Oct 28 2014 Adam Williamson <awilliam@redhat.com> - 1.7.13-1
+- new release 1.7.13 (EOL)
+
* Thu Feb 20 2014 Remi Collet <RPMS@FamilleCollet.com> 1:1.7.10-1
- revert to 1.7
diff --git a/php-sabredav-Sabre_DAV.xml b/php-sabredav-Sabre_DAV.xml
index 520c85b..1bdb3d0 100644
--- a/php-sabredav-Sabre_DAV.xml
+++ b/php-sabredav-Sabre_DAV.xml
@@ -58,6 +58,7 @@ New release. Read the ChangeLog and announcement for more details
<file name="Sabre/DAV/Exception/Forbidden.php" role="php" />
<file name="Sabre/DAV/Exception/InsufficientStorage.php" role="php" />
<file name="Sabre/DAV/Exception/InvalidResourceType.php" role="php" />
+ <file name="Sabre/DAV/Exception/LengthRequired.php" role="php" />
<file name="Sabre/DAV/Exception/LockTokenMatchesRequestUri.php" role="php" />
<file name="Sabre/DAV/Exception/Locked.php" role="php" />
<file name="Sabre/DAV/Exception/MethodNotAllowed.php" role="php" />
@@ -80,6 +81,7 @@ New release. Read the ChangeLog and announcement for more details
<file name="Sabre/DAV/Locks/LockInfo.php" role="php" />
<file name="Sabre/DAV/Locks/Plugin.php" role="php" />
<file name="Sabre/DAV/Mount/Plugin.php" role="php" />
+ <file name="Sabre/DAV/PartialUpdate/IPatchSupport.php" role="php" />
<file name="Sabre/DAV/Property/GetLastModified.php" role="php" />
<file name="Sabre/DAV/Property/Href.php" role="php" />
<file name="Sabre/DAV/Property/HrefList.php" role="php" />
@@ -115,11 +117,14 @@ New release. Read the ChangeLog and announcement for more details
<file name="Sabre/DAV/UUIDUtil.php" role="php" />
<file name="Sabre/DAV/Version.php" role="php" />
<file name="Sabre/DAV/XMLUtil.php" role="php" />
+ <file name="Sabre/DAV/includes.php" role="php" />
<file name="Sabre/DAV/PropertyInterface.php" role="php" />
<file name="Sabre/DAV/PartialUpdate/Plugin.php" role="php" />
<file name="Sabre/DAV/PartialUpdate/IFile.php" role="php" />
+ <file name="Sabre/DAV/Locks/Backend/Abstract.php" role="php" />
<file name="Sabre/DAV/Exception/ServiceUnavailable.php" role="php" />
<file name="Sabre/DAV/Exception/ReportNotSupported.php" role="php" />
+ <file name="Sabre/DAV/Auth/IBackend.php" role="php" />
<file name="examples/sql/mysql.locks.sql" role="doc" />
<file name="examples/sql/mysql.users.sql" role="doc" />
<file name="examples/sql/pgsql.locks.sql" role="doc" />
@@ -133,9 +138,6 @@ New release. Read the ChangeLog and announcement for more details
<file name="examples/simplefsserver.php" role="doc" />
<file name="ChangeLog" role="doc" />
<file name="LICENSE" role="doc" />
- <file name="Sabre/DAV/includes.php" role="php" />
- <file name="Sabre/DAV/Locks/Backend/Abstract.php" role="php" />
- <file name="Sabre/DAV/Auth/IBackend.php" role="php" />
</dir>
</contents>
<dependencies>
@@ -154,7 +156,7 @@ New release. Read the ChangeLog and announcement for more details
<package>
<name>Sabre_HTTP</name>
<channel>pear.sabredav.org</channel>
- <min>1.7.0</min>
+ <min>1.6.0</min>
</package>
</required>
</dependencies>