summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2012-11-12 10:29:31 +0100
committerRemi Collet <fedora@famillecollet.com>2012-11-12 10:29:31 +0100
commit4d0e493aa7e556ecca5d2122583b940794f1b214 (patch)
tree726f7686e1cfe4c2be69a6bb81824a1add270e6e
php-sabredav-Sabre_DAV: import from rawhide
-rw-r--r--php-sabredav-Sabre_DAV.spec93
1 files changed, 93 insertions, 0 deletions
diff --git a/php-sabredav-Sabre_DAV.spec b/php-sabredav-Sabre_DAV.spec
new file mode 100644
index 0000000..9ad1c82
--- /dev/null
+++ b/php-sabredav-Sabre_DAV.spec
@@ -0,0 +1,93 @@
+%{!?__pear: %{expand: %%global __pear %{_bindir}/pear}}
+%global pear_name %(echo %{name} | sed -e 's/^php-sabredav-//' -e 's/-/_/g')
+%global channelname pear.sabredav.org
+
+Name: php-sabredav-Sabre_DAV
+Version: 1.6.5
+Release: 1%{?dist}
+Summary: Sabre_DAV is a WebDAV framework for PHP
+
+License: BSD
+URL: http://code.google.com/p/sabredav
+Source0: http://pear.sabredav.org/get/%{pear_name}-%{version}.tgz
+
+BuildArch: noarch
+BuildRequires: php-pear(PEAR)
+BuildRequires: php-channel(%{channelname})
+
+Requires(post): %{__pear}
+Requires(postun): %{__pear}
+
+Requires: php-common >= 5.1
+Requires: php-pear(PEAR)
+Requires: php-channel(%{channelname})
+Requires: php-xml
+Requires: php-mbstring
+Requires: php-pdo
+Requires: php-pear(%{channelname}/Sabre)
+Requires: php-pear(%{channelname}/Sabre_HTTP)
+
+Provides: php-pear(%{pear_name}) = %{version}
+Provides: php-pear(%{channelname}/%{pear_name}) = %{version}
+
+%description
+SabreDAV allows you to easily add WebDAV support to a PHP application. SabreDAV
+is meant to cover the entire standard.
+
+
+%prep
+%setup -q -c
+[ -f package2.xml ] || mv package.xml package2.xml
+mv package2.xml %{pear_name}-%{version}/%{pear_name}.xml
+
+
+%build
+# Empty build section, most likely nothing required.
+
+
+%install
+cd %{pear_name}-%{version}
+%{__pear} install --nodeps --packagingroot $RPM_BUILD_ROOT %{pear_name}.xml
+
+# Clean up unnecessary files
+rm -rf $RPM_BUILD_ROOT%{pear_phpdir}/.??*
+
+# Install XML package description
+mkdir -p $RPM_BUILD_ROOT%{pear_xmldir}
+install -pm 644 %{pear_name}.xml $RPM_BUILD_ROOT%{pear_xmldir}
+
+
+%post
+%{__pear} install --nodeps --soft --force --register-only \
+ %{pear_xmldir}/%{pear_name}.xml >/dev/null || :
+
+%postun
+if [ $1 -eq 0 ] ; then
+ %{__pear} uninstall --nodeps --ignore-errors --register-only \
+ %{pear_name} >/dev/null || :
+fi
+
+
+%files
+%doc %doc %{pear_docdir}/%{pear_name}
+%{pear_xmldir}/%{pear_name}.xml
+%{pear_phpdir}/Sabre/DAV
+
+
+%changelog
+* Wed Oct 31 2012 Joseph Marrero <jmarrero@fedoraproject.org> - 1.6.5-1
+- updated to 1.6.5
+- Added the required deps pointed by phpci
+* Sun Oct 14 2012 Joseph Marrero <jmarrero@fedoraproject.org> - 1.6.4-4
+- fixed documentation path
+- fixed wrong versions on the changelog
+- cleaned up dependencies
+- added php-common dependency
+* Wed Oct 03 2012 Joseph Marrero <jmarrero@fedoraproject.org> - 1.6.4-3
+- removed unneeded %%BUILDROOT
+- removed extra changes of directory
+- replaced %%define with global
+* Wed Oct 03 2012 Joseph Marrero <jmarrero@fedoraproject.org> - 1.6.4-2
+- update to latest upstream version
+* Fri Apr 06 2012 Felix Kaechele <heffer@fedoraproject.org> - 1.6.1-1
+- initial package