summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-02-20 10:15:24 +0100
committerRemi Collet <fedora@famillecollet.com>2014-02-20 10:15:24 +0100
commit316a2c74e366ccb3ccdd876d0a0b3d8da0058834 (patch)
tree5960833582fac5c4ad0eec09b39e28e9a8e6ee50
parent3494b7dc1ea505025429b8de4cd182ba3907e89b (diff)
php-sabredav-Sabre*: revert to 1.7.x (no namespace)
-rw-r--r--php-sabredav-Sabre_CalDAV.spec27
-rw-r--r--php-sabredav-Sabre_CalDAV.xml13
2 files changed, 24 insertions, 16 deletions
diff --git a/php-sabredav-Sabre_CalDAV.spec b/php-sabredav-Sabre_CalDAV.spec
index dd99efc..114a86a 100644
--- a/php-sabredav-Sabre_CalDAV.spec
+++ b/php-sabredav-Sabre_CalDAV.spec
@@ -1,11 +1,12 @@
%{!?__pear: %{expand: %%global __pear %{_bindir}/pear}}
%global pear_name Sabre_CalDAV
%global channelname pear.sabredav.org
-%global mainver 1.8.7
-%global reldate 2013-10-02
+%global mainver 1.7.10
+%global reldate 2014-02-09
Name: php-sabredav-Sabre_CalDAV
-Version: 1.8.7
+Epoch: 1
+Version: 1.7.9
Release: 1%{?dist}
Summary: Provides RFC4791 (CalDAV) support to Sabre_DAV
@@ -14,7 +15,7 @@ License: BSD
URL: http://code.google.com/p/sabredav
# https://github.com/fruux/sabre-dav/issues/336
# Please update PEAR channel
-Source0: http://sabredav.googlecode.com/files/SabreDAV-%{mainver}.zip
+Source0: https://github.com/fruux/sabre-dav/releases/download/%{mainver}/SabreDAV-%{mainver}.zip
Source1: %{name}.xml
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
@@ -29,9 +30,9 @@ Requires: php-pdo
Requires: php-xml
Requires: php-pear(PEAR)
Requires: php-channel(%{channelname})
-Requires: php-pear(%{channelname}/Sabre) >= 1.0.1
-Requires: php-pear(%{channelname}/Sabre_DAV) >= 1.8.7
-Requires: php-pear(%{channelname}/Sabre_DAVACL) >= 1.8.7
+Requires: php-pear(%{channelname}/Sabre) >= 1.0.2
+Requires: php-pear(%{channelname}/Sabre_DAV) >= 1.7.10
+Requires: php-pear(%{channelname}/Sabre_DAVACL) >= 1.7.9
Requires: php-pear(%{channelname}/Sabre_VObject) >= 2.1.3
Provides: php-pear(%{pear_name}) = %{version}
@@ -59,11 +60,16 @@ fi
touch error.lst
for fic in $(find Sabre/CalDAV -type f)
do
- grep $fic %{name}.xml || echo $fic >> error.lst
+ grep $fic %{name}.xml || echo -$fic >> error.lst
+done
+
+for fic in $(grep '<file' %{name}.xml | sed -e 's/.*name="//' -e 's/".*//')
+do
+ [ -f $fic ] || echo +$fic >> error.lst
done
if [ -s error.lst ]; then
- : Missing in %{name}.xml
+ : Error in %{name}.xml
cat error.lst
exit 1
fi
@@ -103,6 +109,9 @@ fi
%changelog
+* Thu Feb 20 2014 Remi Collet <RPMS@FamilleCollet.com> 1:1.7.9-1
+- revert to 1.7
+
* Sat Oct 5 2013 Remi Collet <RPMS@FamilleCollet.com> 1.8.7-1
- update to 1.8.7
diff --git a/php-sabredav-Sabre_CalDAV.xml b/php-sabredav-Sabre_CalDAV.xml
index f5c76c3..bd7d846 100644
--- a/php-sabredav-Sabre_CalDAV.xml
+++ b/php-sabredav-Sabre_CalDAV.xml
@@ -64,8 +64,6 @@ New release. Read the ChangeLog and announcement for more details
<file name="Sabre/CalDAV/Property/ScheduleCalendarTransp.php" role="php" />
<file name="Sabre/CalDAV/Property/Invite.php" role="php" />
<file name="Sabre/CalDAV/Property/AllowedSharingModes.php" role="php" />
- <file name="Sabre/CalDAV/Principal/IProxyWrite.php" role="php" />
- <file name="Sabre/CalDAV/Principal/IProxyRead.php" role="php" />
<file name="Sabre/CalDAV/Notifications/Notification/SystemStatus.php" role="php" />
<file name="Sabre/CalDAV/Notifications/Notification/InviteReply.php" role="php" />
<file name="Sabre/CalDAV/Notifications/Notification/Invite.php" role="php" />
@@ -80,7 +78,8 @@ New release. Read the ChangeLog and announcement for more details
<file name="Sabre/CalDAV/Backend/SharingSupport.php" role="php" />
<file name="Sabre/CalDAV/Backend/NotificationSupport.php" role="php" />
<file name="Sabre/CalDAV/Backend/BackendInterface.php" role="php" />
- <file name="Sabre/CalDAV/Backend/AbstractBackend.php" role="php" />
+ <file name="Sabre/CalDAV/includes.php" role="php" />
+ <file name="Sabre/CalDAV/Backend/Abstract.php" role="php" />
</dir>
</contents>
<dependencies>
@@ -99,22 +98,22 @@ New release. Read the ChangeLog and announcement for more details
<package>
<name>Sabre_HTTP</name>
<channel>pear.sabredav.org</channel>
- <min>1.6.0</min>
+ <min>1.7.0</min>
</package>
<package>
<name>Sabre_DAV</name>
<channel>pear.sabredav.org</channel>
- <min>1.6.0</min>
+ <min>1.7.0</min>
</package>
<package>
<name>Sabre_DAVACL</name>
<channel>pear.sabredav.org</channel>
- <min>1.6.0</min>
+ <min>1.7.0</min>
</package>
<package>
<name>Sabre_VObject</name>
<channel>pear.sabredav.org</channel>
- <min>1.3.0</min>
+ <min>2.1.0</min>
</package>
</required>
</dependencies>