summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-05-20 09:59:29 +0200
committerRemi Collet <fedora@famillecollet.com>2016-05-20 09:59:29 +0200
commitbecefa6524a66ebd4a2345a22ad642a5527854fe (patch)
tree6412d9f080a00452017df94393726fe03a4a2080
parent97685409ae7e93a72077a72df0abc7dec4210041 (diff)
php-sabre-xml: 1.42.
-rw-r--r--composer.json50
-rw-r--r--php-sabre-xml.spec7
2 files changed, 55 insertions, 2 deletions
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..2b8097f
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,50 @@
+{
+ "name": "sabre/xml",
+ "description" : "sabre/xml is an XML library that you may not hate.",
+ "keywords" : [ "XML", "XMLReader", "XMLWriter", "DOM" ],
+ "homepage" : "https://sabre.io/xml/",
+ "license" : "BSD-3-Clause",
+ "require" : {
+ "php" : ">=5.4.1",
+ "ext-xmlwriter" : "*",
+ "ext-xmlreader" : "*",
+ "ext-dom" : "*",
+ "lib-libxml" : ">=2.6.20",
+ "sabre/uri" : "~1.0"
+ },
+ "authors" : [
+ {
+ "name" : "Evert Pot",
+ "email" : "me@evertpot.com",
+ "homepage" : "http://evertpot.com/",
+ "role" : "Developer"
+ },
+ {
+ "name": "Markus Staab",
+ "email": "markus.staab@redaxo.de",
+ "role" : "Developer"
+ }
+ ],
+ "support" : {
+ "forum" : "https://groups.google.com/group/sabredav-discuss",
+ "source" : "https://github.com/fruux/sabre-xml"
+ },
+ "autoload" : {
+ "psr-4" : {
+ "Sabre\\Xml\\" : "lib/"
+ },
+ "files": [
+ "lib/Deserializer/functions.php",
+ "lib/Serializer/functions.php"
+ ]
+ },
+ "bin" : [
+ ],
+ "require-dev": {
+ "sabre/cs": "~0.0.2",
+ "phpunit/phpunit" : "*"
+ },
+ "config" : {
+ "bin-dir" : "bin/"
+ }
+}
diff --git a/php-sabre-xml.spec b/php-sabre-xml.spec
index 3ac7c3c..b4563cd 100644
--- a/php-sabre-xml.spec
+++ b/php-sabre-xml.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 59998046db252634259a878baf1af18159f508f3
+%global gh_commit f48d98c22a4a4bef76cabb5968ffaddbb2bb593e
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner fruux
%global gh_project sabre-xml
@@ -19,7 +19,7 @@
Name: php-%{gh_project}
Summary: XML library that you may not hate
-Version: 1.4.1
+Version: 1.4.2
Release: 1%{?dist}
URL: https://github.com/%{gh_owner}/%{gh_project}
@@ -128,6 +128,9 @@ rm -rf %{buildroot}
%changelog
+* Fri May 20 2016 Remi Collet <remi@fedoraproject.org> - 1.4.2-1
+- update to 1.4.2
+
* Tue Mar 29 2016 Remi Collet <remi@fedoraproject.org> - 1.4.1-1
- update to 1.4.1