summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-01-09 15:43:16 +0100
committerRemi Collet <remi@remirepo.net>2019-01-09 15:43:16 +0100
commit27c1915876c39eb8660398e4a25b5257fd10e531 (patch)
treea3cec334d72c1834c2cc760f8cb1fc2f4ef7a7eb
parentb09e5760968633c5ea208969003a669a59551aee (diff)
v1.5.1
-rw-r--r--composer.json2
-rw-r--r--php-sabre-xml.spec37
2 files changed, 14 insertions, 25 deletions
diff --git a/composer.json b/composer.json
index 386f821..1b57603 100644
--- a/composer.json
+++ b/composer.json
@@ -45,7 +45,7 @@
},
"require-dev": {
"sabre/cs": "~1.0.0",
- "phpunit/phpunit" : "*"
+ "phpunit/phpunit" : "~4.8|~5.7"
},
"config" : {
"bin-dir" : "bin/"
diff --git a/php-sabre-xml.spec b/php-sabre-xml.spec
index f6521ee..1bd190b 100644
--- a/php-sabre-xml.spec
+++ b/php-sabre-xml.spec
@@ -1,26 +1,21 @@
# remirepo/fedora spec file for php-sabre-xml
#
-# Copyright (c) 2016-2018 Remi Collet
+# Copyright (c) 2016-2019 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
-%global gh_commit 59b20e5bbace9912607481634f97d05a776ffca7
+%global gh_commit a367665f1df614c3b8fefc30a54de7cd295e444e
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sabre-io
%global gh_project xml
-%if 0%{?rhel} == 5
-# Libxml seems too old
-%global with_tests 0%{?_with_tests:1}
-%else
%global with_tests 0%{!?_without_tests:1}
-%endif
Name: php-sabre-%{gh_project}
Summary: XML library that you may not hate
-Version: 1.5.0
-Release: 6%{?dist}
+Version: 1.5.1
+Release: 1%{?dist}
URL: https://github.com/%{gh_owner}/%{gh_project}
License: BSD
@@ -38,7 +33,7 @@ BuildRequires: php-pcre
BuildRequires: php-spl
# From composer.json, "require-dev": {
# "sabre/cs": "~1.0.0",
-# "phpunit/phpunit" : "*"
+# "phpunit/phpunit" : "~4.8|~5.7"
BuildRequires: php-composer(phpunit/phpunit)
# Autoloader
BuildRequires: php-composer(fedora/autoloader)
@@ -101,21 +96,12 @@ EOF
cd tests
: Run upstream test suite against installed library
-# remirepo:11
ret=0
-run=0
-if which php71; then
- php71 %{_bindir}/phpunit || ret=1
- run=1
-fi
-if which php56; then
- php56 %{_bindir}/phpunit || ret=1
- run=1
-fi
-if [ $run -eq 0 ]; then
-%{_bindir}/phpunit --verbose
-# remirepo:2
-fi
+for cmd in php php56 php70 php71 php72 php73; do
+ if which $cmd; then
+ $cmd %{_bindir}/phpunit || ret=1
+ fi
+done
exit $ret
%else
: Skip upstream test suite
@@ -131,6 +117,9 @@ exit $ret
%changelog
+* Wed Jan 9 2019 Remi Collet <remi@remirepo.net> - 1.5.1-1
+- update to 1.5.1
+
* Tue Jun 5 2018 Remi Collet <remi@remirepo.net> - 1.5.0-6
- fix project URL