summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json4
-rw-r--r--php-sabre-vobject4.spec26
2 files changed, 19 insertions, 11 deletions
diff --git a/composer.json b/composer.json
index b08684b..9d1b426 100644
--- a/composer.json
+++ b/composer.json
@@ -38,9 +38,9 @@
},
"require-dev" : {
"friendsofphp/php-cs-fixer": "~2.17.1",
- "phpunit/phpunit" : "^7.5 || ^8.5 || ^9.0",
+ "phpunit/phpunit" : "^7.5 || ^8.5 || ^9.6",
"phpunit/php-invoker" : "^2.0 || ^3.1",
- "phpstan/phpstan": "^0.12"
+ "phpstan/phpstan": "^0.12 || ^1.12 || ^2.0"
},
"suggest" : {
"hoa/bench" : "If you would like to run the benchmark scripts"
diff --git a/php-sabre-vobject4.spec b/php-sabre-vobject4.spec
index 0bd114d..91ee5ab 100644
--- a/php-sabre-vobject4.spec
+++ b/php-sabre-vobject4.spec
@@ -1,18 +1,19 @@
# remirepo/fedora spec file for php-sabre-vobject4
#
-# Copyright (c) 2013-2024 Remi Collet
-# License: CC-BY-SA-4.0
-# http://creativecommons.org/licenses/by-sa/4.0/
+# SPDX-FileCopyrightText: Copyright 2013-2025 Remi Collet
+# SPDX-License-Identifier: CECILL-2.1
+# http://www.cecill.info/licences/Licence_CeCILL_V2-en.txt
#
# Please, preserve the changelog entries
#
%bcond_without tests
+# remirepo:2
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit 7148cf57d25aaba0a49f6656d37c35e8175b3087
+%global gh_commit ff22611a53782e90c97be0d0bc4a5f98a5c0a12c
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sabre-io
%global gh_project vobject
@@ -20,7 +21,7 @@
Name: php-sabre-vobject4
Summary: Library to parse and manipulate iCalendar and vCard objects
-Version: 4.5.5
+Version: 4.5.7
Release: 1%{?dist}
URL: http://sabre.io/vobject/
@@ -43,10 +44,10 @@ BuildRequires: php-spl
BuildRequires: php-xml
# From composer.json, "require-dev"
# "friendsofphp/php-cs-fixer": "^2.17.1",
-# "phpunit/phpunit" : "^7.5 || ^8.5 || ^9.0",
+# "phpunit/phpunit" : "^7.5 || ^8.5 || ^9.6",
# "phpunit/php-invoker" : "^2.0 || ^3.1",
-# "phpstan/phpstan": "^0.12"
-BuildRequires: phpunit9
+# "phpstan/phpstan": "^0.12 || ^1.12 || ^2.0"
+BuildRequires: phpunit9 >= 9.6
%global phpunit %{_bindir}/phpunit9
%endif
# Autoloader
@@ -145,7 +146,7 @@ fi
: Run upstream test suite against installed library
ret=0
-for cmdarg in "php %{phpunit}" php81 php82 php83; do
+for cmdarg in "php %{phpunit}" php81 php82 php83 php84; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit9} $opt || ret=1
@@ -168,6 +169,13 @@ exit $ret
%endif
%changelog
+* Fri Apr 18 2025 Remi Collet <remi@remirepo.net> - 4.5.7-1
+- update to 4.5.7
+- re-license spec file to CECILL-2.1
+
+* Tue Oct 15 2024 Remi Collet <remi@remirepo.net> - 4.5.6-1
+- update to 4.5.6
+
* Wed Jul 3 2024 Remi Collet <remi@remirepo.net> - 4.5.5-1
- update to 4.5.5