summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-02-20 07:28:37 +0100
committerRemi Collet <remi@remirepo.net>2019-02-20 07:28:37 +0100
commit9cb1dfe6e01462ca2d6b674a75f601f1714e06c5 (patch)
tree7f2038fcefa7e280cb82068b656dd2e2c5e2d2d0
parentbc1d3f42149958852b93cb4b3119d44c4d8e1f14 (diff)
v4.2.0
-rw-r--r--composer.json4
-rw-r--r--php-sabre-vobject4-bin.patch20
-rw-r--r--php-sabre-vobject4.spec18
3 files changed, 22 insertions, 20 deletions
diff --git a/composer.json b/composer.json
index 2407cab..ad02687 100644
--- a/composer.json
+++ b/composer.json
@@ -37,9 +37,7 @@
"sabre/xml" : ">=1.5 <3.0"
},
"require-dev" : {
- "phpunit/phpunit" : "> 4.8.35, <6.0.0",
- "sabre/cs" : "^1.0.0"
-
+ "phpunit/phpunit" : "> 4.8.35, <6.0.0"
},
"suggest" : {
"hoa/bench" : "If you would like to run the benchmark scripts"
diff --git a/php-sabre-vobject4-bin.patch b/php-sabre-vobject4-bin.patch
index 79ed1a5..e37bd2a 100644
--- a/php-sabre-vobject4-bin.patch
+++ b/php-sabre-vobject4-bin.patch
@@ -1,6 +1,6 @@
diff -up ./bin/generate_vcards.rpm ./bin/generate_vcards
---- ./bin/generate_vcards.rpm 2017-01-17 14:09:13.368837753 +0100
-+++ ./bin/generate_vcards 2017-01-17 14:12:49.417890498 +0100
+--- ./bin/generate_vcards.rpm 2019-02-19 14:05:37.000000000 +0100
++++ ./bin/generate_vcards 2019-02-20 07:21:38.282053251 +0100
@@ -6,8 +6,7 @@ namespace Sabre\VObject;
// This sucks.. we have to try to find the composer autoloader. But chances
// are, we can't find it this way. So we'll do our bestest
@@ -21,8 +21,8 @@ diff -up ./bin/generate_vcards.rpm ./bin/generate_vcards
}
diff -up ./bin/vobject.rpm ./bin/vobject
---- ./bin/vobject.rpm 2017-01-17 14:12:09.586696412 +0100
-+++ ./bin/vobject 2017-01-17 14:12:40.301846078 +0100
+--- ./bin/vobject.rpm 2019-02-19 14:05:37.000000000 +0100
++++ ./bin/vobject 2019-02-20 07:21:38.282053251 +0100
@@ -6,8 +6,7 @@ namespace Sabre\VObject;
// This sucks.. we have to try to find the composer autoloader. But chances
// are, we can't find it this way. So we'll do our bestest
@@ -43,14 +43,14 @@ diff -up ./bin/vobject.rpm ./bin/vobject
}
diff -up ./tests/bootstrap.php.rpm ./tests/bootstrap.php
---- ./tests/bootstrap.php.rpm 2016-12-06 05:14:09.000000000 +0100
-+++ ./tests/bootstrap.php 2017-01-17 14:14:50.960482740 +0100
+--- ./tests/bootstrap.php.rpm 2019-02-20 07:21:38.282053251 +0100
++++ ./tests/bootstrap.php 2019-02-20 07:22:58.069649015 +0100
@@ -3,8 +3,7 @@
date_default_timezone_set('UTC');
$try = [
-- __DIR__ . '/../vendor/autoload.php',
-- __DIR__ . '/../../../autoload.php',
+- __DIR__.'/../vendor/autoload.php',
+- __DIR__.'/../../../autoload.php',
+ '@BUILDROOT@/usr/share/php/Sabre/VObject4/autoload.php', // RPM installation
];
@@ -59,8 +59,8 @@ diff -up ./tests/bootstrap.php.rpm ./tests/bootstrap.php
}
}
--$autoLoader->addPsr4('Sabre\\VObject\\', __DIR__ . '/VObject');
+-$autoLoader->addPsr4('Sabre\\VObject\\', __DIR__.'/VObject');
+\Fedora\Autoloader\Autoload::addPsr4('Sabre\\VObject\\', __DIR__ . '/VObject');
if (!defined('SABRE_TEMPDIR')) {
- define('SABRE_TEMPDIR', __DIR__ . '/temp/');
+ define('SABRE_TEMPDIR', __DIR__.'/temp/');
diff --git a/php-sabre-vobject4.spec b/php-sabre-vobject4.spec
index bb62273..4ed5505 100644
--- a/php-sabre-vobject4.spec
+++ b/php-sabre-vobject4.spec
@@ -1,6 +1,6 @@
# remirepo/fedora spec file for php-sabre-vobject4
#
-# Copyright (c) 2013-2018 Remi Collet
+# Copyright (c) 2013-2019 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -10,7 +10,7 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit 122cacbdea2c6133ac04db86ec05854beef75adf
+%global gh_commit bd500019764e434ff65872d426f523e7882a0739
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sabre-io
%global gh_project vobject
@@ -24,7 +24,7 @@
Name: php-sabre-vobject4
Summary: Library to parse and manipulate iCalendar and vCard objects
-Version: 4.1.6
+Version: 4.2.0
Release: 1%{?dist}
URL: http://sabre.io/vobject/
@@ -51,9 +51,7 @@ BuildRequires: php-pcre
BuildRequires: php-spl
BuildRequires: php-xml
# From composer.json, "require-dev"
-# "phpunit/phpunit" : "> 4.8.35, <6.0.0",
-# "squizlabs/php_codesniffer": "*"
-# "sabre/cs" : "^1.0.0"
+# "phpunit/phpunit" : "> 4.8.35, <6.0.0"
BuildRequires: php-composer(phpunit/phpunit) > 4.8.35
# Autoloader
BuildRequires: php-composer(fedora/autoloader)
@@ -131,7 +129,7 @@ sed -e 's:@BUILDROOT@:%{buildroot}:' -i bootstrap.php
: Run upstream test suite against installed library
ret=0
-for cmd in php php70 php71 php72; do
+for cmd in php php70 php71 php72 php73; do
if which $cmd; then
$cmd %{_bindir}/phpunit --verbose || ret=1
fi
@@ -154,6 +152,12 @@ exit $ret
%endif
%changelog
+* Wed Feb 20 2019 Remi Collet <remi@remirepo.net> - 4.2.0-1
+- update to 4.2.0
+
+* Mon Oct 15 2018 Remi Collet <remi@remirepo.net> - 4.1.6-3
+- add upstream patch for PHP 7.3
+
* Fri Apr 20 2018 Remi Collet <remi@remirepo.net> - 4.1.6-1
- update to 4.1.6
- undefine __brp_mangle_shebangs