summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-11-04 08:01:47 +0100
committerRemi Collet <remi@php.net>2021-11-04 08:01:47 +0100
commit91686022effeeaf060d93ec1ea9b72f708f30df2 (patch)
tree59d85e992f192936b30feefa670ed07bdbbf54c7
parent37d0f4df86fa8d0be66d95c46f4c68b54d999577 (diff)
update to 4.3.6
-rwxr-xr-xmakesrc.sh32
-rw-r--r--php-sabre-vobject4.spec11
2 files changed, 39 insertions, 4 deletions
diff --git a/makesrc.sh b/makesrc.sh
new file mode 100755
index 0000000..f9982c6
--- /dev/null
+++ b/makesrc.sh
@@ -0,0 +1,32 @@
+#!/bin/bash
+
+NAME=$(basename $PWD)
+OWNER=$(sed -n '/^%global gh_owner/{s/.* //;p}' $NAME.spec)
+PROJECT=$(sed -n '/^%global gh_project/{s/.* //;p}' $NAME.spec)
+VERSION=$(sed -n '/^Version:/{s/.* //;p}' $NAME.spec)
+COMMIT=$(sed -n '/^%global gh_commit/{s/.* //;p}' $NAME.spec)
+SHORT=${COMMIT:0:7}
+
+if [ -f $NAME-$VERSION-$SHORT.tgz ]; then
+ echo "Already there."
+else
+ echo -e "\nCreate git snapshot\nName=$NAME, Owner=$OWNER, Project=$PROJECT, Version=$VERSION\n"
+
+ echo "Cloning..."
+ rm -rf $PROJECT-$COMMIT
+ git clone https://github.com/$OWNER/$PROJECT.git $PROJECT-$COMMIT
+
+ echo "Getting commit..."
+ pushd $PROJECT-$COMMIT
+ git checkout $COMMIT || exit 1
+ cp composer.json ../composer.json
+ popd
+
+ echo "Archiving..."
+ tar czf $NAME-$VERSION-$SHORT.tgz --exclude-vcs $PROJECT-$COMMIT
+
+ echo "Cleaning..."
+ rm -rf $PROJECT-$COMMIT
+
+ echo "Done."
+fi
diff --git a/php-sabre-vobject4.spec b/php-sabre-vobject4.spec
index a788a4c..f7ea9a9 100644
--- a/php-sabre-vobject4.spec
+++ b/php-sabre-vobject4.spec
@@ -12,7 +12,7 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit d8a0a9ae215a8acfb51afc29101c7344670b9c83
+%global gh_commit 0bd8c87779d38cc867eea5977fe52c618e6f926b
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sabre-io
%global gh_project vobject
@@ -25,8 +25,8 @@
Name: php-sabre-vobject4
Summary: Library to parse and manipulate iCalendar and vCard objects
-Version: 4.3.5
-Release: 3%{?dist}
+Version: 4.3.6
+Release: 1%{?dist}
URL: http://sabre.io/vobject/
License: BSD
@@ -143,7 +143,7 @@ fi
: Run upstream test suite against installed library
ret=0
-for cmdarg in "php %{phpunit}" php73 php74 php80; do
+for cmdarg in "php %{phpunit}" php73 php74 php80 php81; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit9} $opt || ret=1
@@ -167,6 +167,9 @@ exit $ret
%endif
%changelog
+* Thu Nov 4 2021 Remi Collet <remi@remirepo.net> - 4.3.6-1
+- update to 4.3.6
+
* Mon Jul 26 2021 Remi Collet <remi@remirepo.net> - 4.3.5-3
- ignore 1 more test failing on 32-bit