summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-10-27 11:55:01 +0200
committerRemi Collet <fedora@famillecollet.com>2016-10-27 11:55:01 +0200
commite305aee31a13a4a69b5ecdeaf01b3f17a22275ea (patch)
tree98a350c372b5cd9005a231c905f0088f80b49003
parent27bc75c63fc75b745c0d574b3478c8f0567976f0 (diff)
php-sabre-uri: 1.1.1
-rw-r--r--composer.json41
-rw-r--r--php-sabre-uri.spec28
2 files changed, 61 insertions, 8 deletions
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..efa5a69
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,41 @@
+{
+ "name": "sabre/uri",
+ "description": "Functions for making sense out of URIs.",
+ "keywords": [
+ "URI",
+ "URL",
+ "rfc3986"
+ ],
+ "homepage": "http://sabre.io/uri/",
+ "license": "BSD-3-Clause",
+ "require": {
+ "php": ">=5.4.7"
+ },
+ "authors": [
+ {
+ "name": "Evert Pot",
+ "email": "me@evertpot.com",
+ "homepage": "http://evertpot.com/",
+ "role": "Developer"
+ }
+ ],
+ "support": {
+ "forum": "https://groups.google.com/group/sabredav-discuss",
+ "source": "https://github.com/fruux/sabre-uri"
+ },
+ "autoload": {
+ "files" : [
+ "lib/functions.php"
+ ],
+ "psr-4" : {
+ "Sabre\\Uri\\" : "lib/"
+ }
+ },
+ "require-dev": {
+ "sabre/cs": "~1.0.0",
+ "phpunit/phpunit" : "*"
+ },
+ "config" : {
+ "bin-dir" : "bin/"
+ }
+}
diff --git a/php-sabre-uri.spec b/php-sabre-uri.spec
index b1ddbfc..8a0156c 100644
--- a/php-sabre-uri.spec
+++ b/php-sabre-uri.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 9012116434d84ef6e5e37a89dfdbfbe2204a8704
+%global gh_commit 258b72540fe3f2c0bb395cb40e56f9ae409f93b5
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner fruux
%global gh_project sabre-uri
@@ -14,7 +14,7 @@
Name: php-%{gh_project}
Summary: Functions for making sense out of URIs
-Version: 1.1.0
+Version: 1.1.1
Release: 1%{?dist}
URL: https://github.com/%{gh_owner}/%{gh_project}
@@ -28,7 +28,7 @@ BuildArch: noarch
%if %{with_tests}
BuildRequires: php(language) > 5.4.7
# From composer.json, "require-dev": {
-# "sabre/cs": "~0.0.1",
+# "sabre/cs": "~1.0.0",
# "phpunit/phpunit" : "*"
BuildRequires: php-pcre
BuildRequires: php-composer(phpunit/phpunit)
@@ -88,15 +88,24 @@ cp -pr lib %{buildroot}%{_datadir}/php/Sabre/Uri
%if %{with_tests}
: Run upstream test suite against installed library
cd tests
+# remirepo:11
+run=0
+ret=0
+if which php56; then
+ php56 %{_bindir}/phpunit --bootstrap=%{buildroot}%{_datadir}/php/Sabre/Uri/autoload.php || ret=1
+ run=1
+fi
+if which php71; then
+ php71 %{_bindir}/phpunit --bootstrap=%{buildroot}%{_datadir}/php/Sabre/Uri/autoload.php || ret=1
+ run=1
+fi
+if [ $run -eq 0 ]; then
%{_bindir}/phpunit \
--bootstrap=%{buildroot}%{_datadir}/php/Sabre/Uri/autoload.php \
--verbose
-
-if which php70; then
- php70 %{_bindir}/phpunit \
- --bootstrap=%{buildroot}%{_datadir}/php/Sabre/Uri/autoload.php \
- --verbose
+# remirepo:2
fi
+exit $ret
%else
: Skip upstream test suite
%endif
@@ -117,6 +126,9 @@ rm -rf %{buildroot}
%changelog
+* Thu Oct 27 2016 Remi Collet <remi@fedoraproject.org> - 1.1.1-1
+- update to 1.1.1
+
* Fri Mar 11 2016 Remi Collet <remi@fedoraproject.org> - 1.1.0-1
- Initial packaging