summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--php-sabre-http-autoload.php7
-rw-r--r--php-sabre-http.spec2
2 files changed, 6 insertions, 3 deletions
diff --git a/php-sabre-http-autoload.php b/php-sabre-http-autoload.php
index 985f366..f305e1a 100644
--- a/php-sabre-http-autoload.php
+++ b/php-sabre-http-autoload.php
@@ -8,7 +8,8 @@ require_once '/usr/share/php/Fedora/Autoloader/autoload.php';
// Functions
require_once __DIR__ . '/functions.php';
-// dependencies
-require_once '/usr/share/php/Sabre/Event/autoload.php';
-require_once '/usr/share/php/Sabre/Uri/autoload.php';
+\Fedora\Autoloader\Dependencies::required(array(
+ '/usr/share/php/Sabre/Event/autoload.php',
+ '/usr/share/php/Sabre/Uri/autoload.php',
+));
diff --git a/php-sabre-http.spec b/php-sabre-http.spec
index 6154029..29b8ba7 100644
--- a/php-sabre-http.spec
+++ b/php-sabre-http.spec
@@ -98,6 +98,8 @@ For output:
What this library provides, is a Request object, and a Response object.
The objects are extendable and easily mockable.
+Autoloader: %{_datadir}/php/Sabre/HTTP/autoload.php
+
%prep
%setup -q -n %{gh_project}-%{gh_commit}