summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-10-29 15:35:33 +0200
committerRemi Collet <fedora@famillecollet.com>2016-10-29 15:35:33 +0200
commitadc9d8f6395c2fe776d142a69a5725cfc4b59bc2 (patch)
tree96b27f0d16cd3721f5e046b6d10bb563e82b1078
parentc534709aeb1081105537aaa2a142bfde09ebf7f1 (diff)
php-sabre-dav: switch from symfony/class-loader to fedora/autoloader
-rw-r--r--php-sabre-http-autoload.php7
-rw-r--r--php-sabre-http.spec2
2 files changed, 6 insertions, 3 deletions
diff --git a/php-sabre-http-autoload.php b/php-sabre-http-autoload.php
index 985f366..f305e1a 100644
--- a/php-sabre-http-autoload.php
+++ b/php-sabre-http-autoload.php
@@ -8,7 +8,8 @@ require_once '/usr/share/php/Fedora/Autoloader/autoload.php';
// Functions
require_once __DIR__ . '/functions.php';
-// dependencies
-require_once '/usr/share/php/Sabre/Event/autoload.php';
-require_once '/usr/share/php/Sabre/Uri/autoload.php';
+\Fedora\Autoloader\Dependencies::required(array(
+ '/usr/share/php/Sabre/Event/autoload.php',
+ '/usr/share/php/Sabre/Uri/autoload.php',
+));
diff --git a/php-sabre-http.spec b/php-sabre-http.spec
index 6154029..29b8ba7 100644
--- a/php-sabre-http.spec
+++ b/php-sabre-http.spec
@@ -98,6 +98,8 @@ For output:
What this library provides, is a Request object, and a Response object.
The objects are extendable and easily mockable.
+Autoloader: %{_datadir}/php/Sabre/HTTP/autoload.php
+
%prep
%setup -q -n %{gh_project}-%{gh_commit}