summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-05-31 13:39:34 +0200
committerRemi Collet <fedora@famillecollet.com>2016-05-31 13:39:34 +0200
commitf757a8e07e034f3b574270ca53047f2f5b269dd3 (patch)
tree8efeaa6a7b950400f6d4b0d646dab8a459bae5db
parentc5e495a4a9dd2a745bdb9c53ee04c26377537879 (diff)
php-sabre-http: dup the spec
-rw-r--r--php-sabre-http-autoload-dev.php21
-rw-r--r--php-sabre-http-dev.spec165
2 files changed, 186 insertions, 0 deletions
diff --git a/php-sabre-http-autoload-dev.php b/php-sabre-http-autoload-dev.php
new file mode 100644
index 0000000..bd755f0
--- /dev/null
+++ b/php-sabre-http-autoload-dev.php
@@ -0,0 +1,21 @@
+<?php
+/**
+ * Autoloader for sabre/http and its dependencies
+ */
+
+$vendorDir = '/usr/share/php';
+
+// Use Symfony autoloader
+if (!isset($fedoraClassLoader) || !($fedoraClassLoader instanceof \Symfony\Component\ClassLoader\ClassLoader)) {
+ if (!class_exists('Symfony\\Component\\ClassLoader\\ClassLoader', false)) {
+ require_once $vendorDir . '/Symfony/Component/ClassLoader/ClassLoader.php';
+ }
+
+ $fedoraClassLoader = new \Symfony\Component\ClassLoader\ClassLoader();
+ $fedoraClassLoader->register();
+}
+
+$fedoraClassLoader->addPrefix('Sabre\\HTTP\\', dirname(dirname(__DIR__)));
+
+// dependencies
+require_once $vendorDir . '/Sabre/Event/autoload.php';
diff --git a/php-sabre-http-dev.spec b/php-sabre-http-dev.spec
new file mode 100644
index 0000000..dd379f7
--- /dev/null
+++ b/php-sabre-http-dev.spec
@@ -0,0 +1,165 @@
+# remirepo/fedora spec file for php-sabre-http
+#
+# Copyright (c) 2013-2016 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+%global gh_commit 6b06c03376219b3d608e1f878514ec105ed1b577
+%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
+%global gh_owner fruux
+%global gh_project sabre-http
+#global prever alpha6
+%global with_tests %{?_without_tests:0}%{!?_without_tests:1}
+
+Name: php-%{gh_project}
+Summary: Library for dealing with http requests and responses
+Version: 3.0.5
+Release: 1%{?dist}
+
+URL: https://github.com/%{gh_owner}/%{gh_project}
+License: BSD
+Group: Development/Libraries
+Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{gh_short}.tar.gz
+Source1: %{name}-autoload.php
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+BuildArch: noarch
+%if %{with_tests}
+BuildRequires: php(language) > 5.4
+BuildRequires: php-mbstring
+BuildRequires: php-composer(phpunit/phpunit)
+BuildRequires: php-composer(sabre/event) >= 1.0.0
+BuildRequires: php-composer(sabre/event) < 3
+BuildRequires: php-ctype
+BuildRequires: php-curl
+BuildRequires: php-date
+BuildRequires: php-hash
+BuildRequires: php-pcre
+BuildRequires: php-spl
+BuildRequires: php-xml
+# Autoloader
+BuildRequires: php-composer(symfony/class-loader)
+BuildRequires: php-composer(sabre/event) >= 2.0.2
+%endif
+
+# From composer.json, "require" : {
+# "php" : ">=5.4",
+# "ext-mbstring" : "*",
+# "sabre/event" : ">=1.0.0,<3.0.0"
+Requires: php(language) > 5.4
+Requires: php-mbstring
+Requires: php-composer(sabre/event) >= 1.0.0
+Requires: php-composer(sabre/event) < 3
+# From composer.json, "suggest" : {
+# "ext-curl" : " to make http requests with the Client class"
+Requires: php-curl
+# From phpcompatinfo report for version 3.0.5
+Requires: php-ctype
+Requires: php-date
+Requires: php-hash
+Requires: php-pcre
+Requires: php-spl
+Requires: php-xml
+# Autoloader
+Requires: php-composer(symfony/class-loader)
+Requires: php-composer(sabre/event) >= 2.0.2
+
+# Was split from php-sabre-dav in version 1.9
+Conflicts: php-sabre-dav < 1.9
+
+Provides: php-composer(sabre/http) = %{version}
+
+
+%description
+This library provides a toolkit to make working with the HTTP protocol easier.
+
+Most PHP scripts run within a HTTP request but accessing information about
+the HTTP request is cumbersome at least, mainly do to superglobals and the
+CGI standard.
+
+There's bad practices, inconsistencies and confusion.
+This library is effectively a wrapper around the following PHP constructs:
+
+For Input:
+ $_GET
+ $_POST
+ $_SERVER
+ php://input or $HTTP_RAW_POST_DATA.
+
+For output:
+ php://output or echo.
+ header()
+
+What this library provides, is a Request object, and a Response object.
+The objects are extendable and easily mockable.
+
+
+%prep
+%setup -q -n %{gh_project}-%{gh_commit}
+
+cp %{SOURCE1} lib/autoload.php
+
+
+%build
+# nothing to build
+
+
+%install
+rm -rf %{buildroot}
+
+# Install as a PSR-0 library
+mkdir -p %{buildroot}%{_datadir}/php/Sabre
+cp -pr lib %{buildroot}%{_datadir}/php/Sabre/HTTP
+
+
+%check
+%if %{with_tests}
+: Run upstream test suite against installed library
+cd tests
+phpunit \
+ --bootstrap=%{buildroot}%{_datadir}/php/Sabre/HTTP/autoload.php \
+ --verbose
+%else
+: Skip upstream test suite
+%endif
+
+
+%clean
+rm -rf %{buildroot}
+
+
+%files
+%defattr(-,root,root,-)
+%{!?_licensedir:%global license %%doc}
+%license LICENSE
+%doc *md
+%doc composer.json
+%{_datadir}/php/Sabre/HTTP
+
+
+%changelog
+* Mon Jul 20 2015 Remi Collet <remi@fedoraproject.org> - 3.0.5-1
+- update to 3.0.5
+- add autoloader
+
+* Wed Jul 16 2014 Remi Collet <remi@fedoraproject.org> - 2.0.4-1
+- update to 2.0.4
+- composer dependencies
+
+* Tue May 6 2014 Remi Collet <remi@fedoraproject.org> - 2.0.3-1
+- update to 2.0.3
+
+* Tue Feb 11 2014 Remi Collet <remi@fedoraproject.org> - 2.0.2-1
+- update to 2.0.2
+
+* Sat Jan 11 2014 Remi Collet <remi@fedoraproject.org> - 2.0.1-1
+- update to 2.0.1
+
+* Tue Jan 7 2014 Remi Collet <remi@fedoraproject.org> - 2.0.0-0.2.alpha6
+- update to 2.0.0alpha6
+- add explicit conflicts with php-sabre-dav < 1.9
+
+* Tue Dec 31 2013 Remi Collet <remi@fedoraproject.org> - 2.0.0-0.1.alpha5
+- Initial packaging \ No newline at end of file