summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-06-12 11:12:13 +0200
committerRemi Collet <remi@remirepo.net>2017-06-12 11:12:13 +0200
commita771831534f34e2bb5f7ab481f4a8a7550a843d2 (patch)
tree515277d606c040d28eda41c2c8eb5fe8588d702f
parent1400559c49496de7a3667bcc92bdb205ff204fbe (diff)
v4.2.3
-rw-r--r--.gitignore7
-rw-r--r--php-sabre-http.spec37
2 files changed, 18 insertions, 26 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..1ab5c4f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/php-sabre-http.spec b/php-sabre-http.spec
index 7450fa7..06102d6 100644
--- a/php-sabre-http.spec
+++ b/php-sabre-http.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit dd50e7260356f4599d40270826f9548b23efa204
+%global gh_commit 0295f9a3ee39be97e0898592fc19e42421e0cd93
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner fruux
%global gh_project sabre-http
@@ -15,7 +15,7 @@
Name: php-%{gh_project}
Summary: Library for dealing with http requests and responses
-Version: 4.2.2
+Version: 4.2.3
Release: 1%{?dist}
URL: https://github.com/%{gh_owner}/%{gh_project}
@@ -24,7 +24,6 @@ Group: Development/Libraries
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{gh_short}.tar.gz
Source1: %{name}-autoload.php
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
%if %{with_tests}
BuildRequires: php(language) > 5.4
@@ -113,8 +112,6 @@ cp %{SOURCE1} lib/autoload.php
%install
-rm -rf %{buildroot}
-
# Install as a PSR-0 library
mkdir -p %{buildroot}%{_datadir}/php/Sabre
cp -pr lib %{buildroot}%{_datadir}/php/Sabre/HTTP
@@ -123,36 +120,21 @@ cp -pr lib %{buildroot}%{_datadir}/php/Sabre/HTTP
%check
%if %{with_tests}
cd tests
+
: Run upstream test suite against installed library
-# remirepo:11
ret=0
-run=0
-if which php71; then
- php71 %{_bindir}/phpunit --bootstrap=%{buildroot}%{_datadir}/php/Sabre/HTTP/autoload.php || ret=1
- run=1
-fi
-if which php56; then
- php56 %{_bindir}/phpunit --bootstrap=%{buildroot}%{_datadir}/php/Sabre/HTTP/autoload.php || ret=1
- run=1
-fi
-if [ $run -eq 0 ]; then
-%{_bindir}/phpunit \
- --bootstrap=%{buildroot}%{_datadir}/php/Sabre/HTTP/autoload.php \
- --verbose
-# remirepo:2
-fi
+for cmd in php php56 php70 php71 php72; do
+ if which php71; then
+ $cmd %{_bindir}/phpunit --bootstrap=%{buildroot}%{_datadir}/php/Sabre/HTTP/autoload.php --verbose || ret=1
+ fi
+done
exit $ret
%else
: Skip upstream test suite
%endif
-%clean
-rm -rf %{buildroot}
-
-
%files
-%defattr(-,root,root,-)
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc *md
@@ -161,6 +143,9 @@ rm -rf %{buildroot}
%changelog
+* Mon Jun 12 2017 Remi Collet <remi@remirepo.net> - 4.2.3-1
+- Update to 4.2.3
+
* Wed Jan 4 2017 Remi Collet <remi@fedoraproject.org> - 4.2.2-1
- update to 4.2.2