summaryrefslogtreecommitdiffstats
path: root/php-sabre-event.spec
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2013-12-31 15:18:05 +0100
committerRemi Collet <fedora@famillecollet.com>2013-12-31 15:18:05 +0100
commit4187342a13fd1618a72bb8c8bf8f4345cc87df3c (patch)
tree8faa24a0b75c9fccdbb05092f9c5d04c0ee5db07 /php-sabre-event.spec
php-sabre-event: 1.0.0 - New package
Diffstat (limited to 'php-sabre-event.spec')
-rw-r--r--php-sabre-event.spec86
1 files changed, 86 insertions, 0 deletions
diff --git a/php-sabre-event.spec b/php-sabre-event.spec
new file mode 100644
index 0000000..5406ec4
--- /dev/null
+++ b/php-sabre-event.spec
@@ -0,0 +1,86 @@
+# Spec file for php-sabre-event
+#
+# Copyright (c) 2013 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/3.0/
+#
+# Please, preserve the changelog entries
+#
+%global gh_commit 14f284eede050859e72ac41064df0eac25327190
+%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
+%global gh_owner fruux
+%global gh_project sabre-event
+%global with_tests %{?_without_tests:0}%{!?_without_tests:1}
+
+Name: php-sabre-event
+Summary: Lightweight library for event-based programming
+Version: 1.0.0
+Release: 1%{?dist}
+
+URL: https://github.com/fruux/sabre-event
+Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}.tar.gz
+License: BSD
+Group: Development/Libraries
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+BuildArch: noarch
+%if %{with_tests}
+BuildRequires: php(language) >= 5.4.1
+BuildRequires: php-pear(pear.phpunit.de/PHPUnit)
+%endif
+
+# From composer.json
+Requires: php(language) >= 5.4.1
+# From phpcompatinfo report: nothing else
+
+
+%description
+A lightweight library for event management in PHP.
+It's design is inspired by Node.js's EventEmitter. sabre/event requires PHP 5.4.
+
+
+%prep
+%setup -q -n %{gh_project}-%{gh_commit}
+
+: Create trivial PSR0 autoloader
+cat <<EOF | tee psr0.php
+<?php
+spl_autoload_register(function (\$class) {
+ \$file = str_replace('\\\\', '/', \$class).'.php';
+ @include \$file;
+});
+EOF
+
+
+%build
+# nothing to build
+
+
+%install
+# Install as a PSR-0 library
+mkdir -p %{buildroot}%{_datadir}/php
+cp -pr lib/Sabre %{buildroot}%{_datadir}/php/Sabre
+
+
+%check
+%if %{with_tests}
+: Run upstream test suite against installed library
+cd tests
+phpunit \
+ --bootstrap=../psr0.php \
+ --include-path=%{buildroot}%{_datadir}/php \
+ -d date.timezone=UTC
+%else
+: Skip upstream test suite
+%endif
+
+
+%files
+%defattr(-,root,root,-)
+%doc ChangeLog composer.json LICENSE README.md
+%{_datadir}/php/Sabre
+
+
+%changelog
+* Tue Dec 31 2013 Remi Collet <remi@fedoraproject.org> - 1.0.0-1
+- Initial packaging \ No newline at end of file