summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--php-sabre-dav-autoload-dev.patch32
-rw-r--r--php-sabre-dav-autoload-dev.php31
-rw-r--r--php-sabre-dav-autoload.patch17
-rw-r--r--php-sabre-dav-autoload.php2
-rw-r--r--php-sabre-dav-dev.spec216
-rw-r--r--php-sabre-dav.spec49
6 files changed, 44 insertions, 303 deletions
diff --git a/php-sabre-dav-autoload-dev.patch b/php-sabre-dav-autoload-dev.patch
deleted file mode 100644
index 8097050..0000000
--- a/php-sabre-dav-autoload-dev.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-diff -up tests/bootstrap.php.orig tests/bootstrap.php
---- tests/bootstrap.php.orig 2016-03-11 17:23:07.419944832 +0100
-+++ tests/bootstrap.php 2016-03-11 17:25:57.205599320 +0100
-@@ -1,21 +1,20 @@
- <?php
-
--set_include_path(__DIR__ . '/../lib/' . PATH_SEPARATOR . __DIR__ . PATH_SEPARATOR . get_include_path());
--
--$autoLoader = include __DIR__ . '/../vendor/autoload.php';
-+require '@BUILDROOT@/usr/share/php/Sabre/DAV/autoload.php';
-
- // SabreDAV tests auto loading
--$autoLoader->add('Sabre\\', __DIR__);
-+$fedoraClassLoader->addPrefix('Sabre\\', __DIR__);
-+
- // VObject tests auto loading
--$autoLoader->addPsr4('Sabre\\VObject\\',__DIR__ . '/../vendor/sabre/vobject/tests/VObject');
--$autoLoader->addPsr4('Sabre\\Xml\\',__DIR__ . '/../vendor/sabre/xml/tests/Sabre/Xml');
-+//$autoLoader->addPsr4('Sabre\\VObject\\',__DIR__ . '/../vendor/sabre/vobject/tests/VObject');
-+//$autoLoader->addPsr4('Sabre\\Xml\\',__DIR__ . '/../vendor/sabre/xml/tests/Sabre/Xml');
-
- date_default_timezone_set('UTC');
-
- $config = [
- 'SABRE_TEMPDIR' => dirname(__FILE__) . '/temp/',
-- 'SABRE_HASSQLITE' => in_array('sqlite',PDO::getAvailableDrivers()),
-- 'SABRE_HASMYSQL' => in_array('mysql',PDO::getAvailableDrivers()),
-+ 'SABRE_HASSQLITE' => 1,
-+ 'SABRE_HASMYSQL' => 0,
- 'SABRE_MYSQLDSN' => 'mysql:host=127.0.0.1;dbname=sabredav',
- 'SABRE_MYSQLUSER' => 'root',
- 'SABRE_MYSQLPASS' => '',
diff --git a/php-sabre-dav-autoload-dev.php b/php-sabre-dav-autoload-dev.php
deleted file mode 100644
index 93a3196..0000000
--- a/php-sabre-dav-autoload-dev.php
+++ /dev/null
@@ -1,31 +0,0 @@
-<?php
-/**
- * Autoloader for sabre/dav and its dependencies
- */
-
-$vendorDir = '/usr/share/php';
-
-// Use Symfony autoloader
-if (!isset($fedoraClassLoader) || !($fedoraClassLoader instanceof \Symfony\Component\ClassLoader\ClassLoader)) {
- if (!class_exists('Symfony\\Component\\ClassLoader\\ClassLoader', false)) {
- require_once $vendorDir . '/Symfony/Component/ClassLoader/ClassLoader.php';
- }
-
- $fedoraClassLoader = new \Symfony\Component\ClassLoader\ClassLoader();
- $fedoraClassLoader->register();
-}
-
-$thisdir = dirname(dirname(__DIR__));
-$fedoraClassLoader->addPrefixes(array(
- 'Sabre\\DAV\\' => $thisdir,
- 'Sabre\\DAVACL\\' => $thisdir,
- 'Sabre\\CalDAV\\' => $thisdir,
- 'Sabre\\CardDAV\\' => $thisdir,
-));
-
-// dependencies
-require_once $vendorDir . '/Sabre/Event/autoload.php';
-require_once $vendorDir . '/Sabre/HTTP/autoload.php';
-require_once $vendorDir . '/Sabre/VObject/autoload.php';
-require_once $vendorDir . '/Sabre/Xml/autoload.php';
-require_once $vendorDir . '/Sabre/Uri/autoload.php';
diff --git a/php-sabre-dav-autoload.patch b/php-sabre-dav-autoload.patch
index 76e947b..8097050 100644
--- a/php-sabre-dav-autoload.patch
+++ b/php-sabre-dav-autoload.patch
@@ -1,7 +1,7 @@
-diff -up tests/bootstrap.php.rpm tests/bootstrap.php
---- tests/bootstrap.php.rpm 2015-07-20 16:23:38.849592222 +0200
-+++ tests/bootstrap.php 2015-07-20 16:23:46.101628015 +0200
-@@ -1,21 +1,17 @@
+diff -up tests/bootstrap.php.orig tests/bootstrap.php
+--- tests/bootstrap.php.orig 2016-03-11 17:23:07.419944832 +0100
++++ tests/bootstrap.php 2016-03-11 17:25:57.205599320 +0100
+@@ -1,21 +1,20 @@
<?php
-set_include_path(__DIR__ . '/../lib/' . PATH_SEPARATOR . __DIR__ . PATH_SEPARATOR . get_include_path());
@@ -11,10 +11,13 @@ diff -up tests/bootstrap.php.rpm tests/bootstrap.php
// SabreDAV tests auto loading
-$autoLoader->add('Sabre\\', __DIR__);
--// VObject tests auto loadiong
--$autoLoader->addPsr4('Sabre\\VObject\\',__DIR__ . '/../vendor/sabre/vobject/tests/VObject');
+$fedoraClassLoader->addPrefix('Sabre\\', __DIR__);
-
++
+ // VObject tests auto loading
+-$autoLoader->addPsr4('Sabre\\VObject\\',__DIR__ . '/../vendor/sabre/vobject/tests/VObject');
+-$autoLoader->addPsr4('Sabre\\Xml\\',__DIR__ . '/../vendor/sabre/xml/tests/Sabre/Xml');
++//$autoLoader->addPsr4('Sabre\\VObject\\',__DIR__ . '/../vendor/sabre/vobject/tests/VObject');
++//$autoLoader->addPsr4('Sabre\\Xml\\',__DIR__ . '/../vendor/sabre/xml/tests/Sabre/Xml');
date_default_timezone_set('UTC');
diff --git a/php-sabre-dav-autoload.php b/php-sabre-dav-autoload.php
index 938d523..93a3196 100644
--- a/php-sabre-dav-autoload.php
+++ b/php-sabre-dav-autoload.php
@@ -27,3 +27,5 @@ $fedoraClassLoader->addPrefixes(array(
require_once $vendorDir . '/Sabre/Event/autoload.php';
require_once $vendorDir . '/Sabre/HTTP/autoload.php';
require_once $vendorDir . '/Sabre/VObject/autoload.php';
+require_once $vendorDir . '/Sabre/Xml/autoload.php';
+require_once $vendorDir . '/Sabre/Uri/autoload.php';
diff --git a/php-sabre-dav-dev.spec b/php-sabre-dav-dev.spec
deleted file mode 100644
index d57596f..0000000
--- a/php-sabre-dav-dev.spec
+++ /dev/null
@@ -1,216 +0,0 @@
-# remirepo/fedora spec file for php-sabre-dav
-#
-# Copyright (c) 2013-2016 Remi Collet
-# License: CC-BY-SA
-# http://creativecommons.org/licenses/by-sa/4.0/
-#
-# Please, preserve the changelog entries
-#
-%global gh_commit b42593965211de1ce99f73bd3aede99c41258e08
-%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
-%global gh_owner fruux
-%global gh_project sabre-dav
-%if 0%{?rhel} == 5
-%global with_tests 0%{?_with_tests:1}
-%else
-%global with_tests 0%{!?_without_tests:1}
-%endif
-
-Name: php-%{gh_project}
-Summary: WebDAV Framework for PHP
-Version: 3.0.9
-Release: 1%{?dist}
-
-URL: https://github.com/%{gh_owner}/%{gh_project}
-License: BSD
-Group: Development/Libraries
-Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{gh_short}.tar.gz
-Source1: %{name}-autoload-dev.php
-
-# replace composer autoloader
-Patch0: %{name}-autoload-dev.patch
-
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
-BuildArch: noarch
-%if %{with_tests}
-BuildRequires: php(language) >= 5.4.1
-BuildRequires: php-composer(phpunit/phpunit)
-BuildRequires: php-composer(sabre/vobject) >= 3.3.4
-BuildRequires: php-composer(sabre/event) >= 2.0
-BuildRequires: php-composer(sabre/xml) >= 1.0
-BuildRequires: php-composer(sabre/http) >= 4.0
-BuildRequires: php-composer(sabre/uri) >= 1.0
-BuildRequires: php-dom
-BuildRequires: php-pcre
-BuildRequires: php-spl
-BuildRequires: php-simplexml
-BuildRequires: php-mbstring
-BuildRequires: php-ctype
-BuildRequires: php-date
-BuildRequires: php-iconv
-BuildRequires: php-libxml
-BuildRequires: php-curl
-BuildRequires: php-pdo
-# Autoloader
-BuildRequires: php-composer(symfony/class-loader)
-BuildRequires: php-pdo_sqlite
-%endif
-
-# From composer.json, "require": {
-# "php": ">=5.4.1",
-# "sabre/vobject": "^3.3.4",
-# "sabre/event" : "~2.0",
-# "sabre/xml" : "~1.0",
-# "sabre/http" : "~4.0",
-# "sabre/uri" : "~1.0",
-# "ext-dom": "*",
-# "ext-pcre": "*",
-# "ext-spl": "*",
-# "ext-simplexml": "*",
-# "ext-mbstring" : "*",
-# "ext-ctype" : "*",
-# "ext-date" : "*",
-# "ext-iconv" : "*",
-# "ext-libxml" : "*"
-Requires: php(language) >= 5.4.1
-Requires: php-composer(sabre/vobject) >= 3.3.4
-Requires: php-composer(sabre/vobject) < 4
-Requires: php-composer(sabre/event) >= 2.0
-Requires: php-composer(sabre/event) < 3
-Requires: php-composer(sabre/xml) >= 1.0
-Requires: php-composer(sabre/xml) < 2
-Requires: php-composer(sabre/http) >= 4.0
-Requires: php-composer(sabre/http) < 5
-Requires: php-composer(sabre/uri) >= 1.0
-Requires: php-composer(sabre/uri) < 2
-Requires: php-dom
-Requires: php-pcre
-Requires: php-spl
-Requires: php-simplexml
-Requires: php-mbstring
-Requires: php-ctype
-Requires: php-date
-Requires: php-iconv
-Requires: php-libxml
-# From composer.json, "suggest" : {
-# "ext-curl" : "*",
-# "ext-pdo" : "*"
-Requires: php-curl
-Requires: php-pdo
-# Autoloader
-Requires: php-composer(symfony/class-loader)
-
-Provides: php-composer(sabre/dav) = %{version}
-
-
-%description
-What is SabreDAV
-
-SabreDAV allows you to easily add WebDAV support to a PHP application.
-SabreDAV is meant to cover the entire standard, and attempts to allow
-integration using an easy to understand API.
-
-Feature list:
-* Fully WebDAV compliant
-* Supports Windows XP, Windows Vista, Mac OS/X, DavFSv2, Cadaver, Netdrive,
- Open Office, and probably more.
-* Passing all Litmus tests.
-* Supporting class 1, 2 and 3 Webdav servers.
-* Locking support.
-* Custom property support.
-* CalDAV (tested with Evolution, iCal, iPhone and Lightning).
-* CardDAV (tested with OS/X addressbook, the iOS addressbook and Evolution).
-* Over 97% unittest code coverage.
-
-
-%prep
-%setup -q -n %{gh_project}-%{gh_commit}
-
-%patch0 -p0
-cp %{SOURCE1} lib/DAV/autoload.php
-
-# drop executable as only provided as doc
-chmod -x bin/*
-
-
-%build
-# nothing to build
-
-
-%install
-# Install as a PSR-0 library
-mkdir -p %{buildroot}%{_datadir}/php
-cp -pr lib %{buildroot}%{_datadir}/php/Sabre
-
-
-%check
-%if %{with_tests}
-%if 0%{?rhel} == 5
-sed -e 's/testMove/SKIP_testMove/' \
- -i tests/Sabre/DAV/PropertyStorage/Backend/AbstractPDOTest.php
-%endif
-
-: Fix bootstrap
-cd tests
-sed -e 's:@BUILDROOT@:%{buildroot}:' -i bootstrap.php
-
-: Run upstream test suite against installed library
-%{_bindir}/phpunit --verbose
-
-if which php70; then
- php70 %{_bindir}/phpunit --verbose
-fi
-%else
-: Skip upstream test suite
-%endif
-
-
-%files
-%defattr(-,root,root,-)
-%{!?_licensedir:%global license %%doc}
-%license LICENSE
-%doc *md
-%doc composer.json
-%doc examples bin
-%{_datadir}/php/Sabre/DAV
-%{_datadir}/php/Sabre/DAVACL
-%{_datadir}/php/Sabre/CalDAV
-%{_datadir}/php/Sabre/CardDAV
-
-
-%changelog
-* Thu Apr 7 2016 Remi Collet <remi@fedoraproject.org> - 3.0.9-1
-- update to 3.0.9
-- add dependency on sabre/xml
-- add dependency on sabre/uri
-- raise dependency on sabre/http >= 4
-
-* Tue Mar 22 2016 Remi Collet <remi@fedoraproject.org> - 2.1.10-1
-- update to 2.1.10
-
-* Mon Mar 21 2016 Remi Collet <remi@fedoraproject.org> - 2.1.6-2
-- provide missing php-composer(sabre/dav)
-
-* Wed Feb 24 2016 James Hogarth <james.hogarth@gmail.com> - 2.1.6-1
-- update to 2.1.6
-
-* Wed Feb 24 2016 Remi Collet <remi@fedoraproject.org> - 2.1.5-1
-- update to 2.1.5
-
-* Fri Mar 06 2015 Adam Williamson <awilliam@redhat.com> - 1.8.12-1
-- update to 1.8.12 (bugfix release, no bc breaks)
-
-* Thu May 22 2014 Remi Collet <remi@fedoraproject.org> - 1.8.10-1
-- update to 1.8.10
-
-* Sun Mar 2 2014 Remi Collet <remi@fedoraproject.org> - 1.8.9-1
-- update to 1.8.9
-
-* Thu Feb 20 2014 Remi Collet <remi@fedoraproject.org> - 1.8.8-2
-- drop max version for VObject
-
-* Tue Feb 11 2014 Remi Collet <remi@fedoraproject.org> - 1.8.8-1
-- update to 1.8.8
-
-* Tue Dec 31 2013 Remi Collet <remi@fedoraproject.org> - 1.8.7-1
-- Initial packaging
diff --git a/php-sabre-dav.spec b/php-sabre-dav.spec
index a1fddfd..d57596f 100644
--- a/php-sabre-dav.spec
+++ b/php-sabre-dav.spec
@@ -6,25 +6,29 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 9f8c1939a3f66eb7170489fc48579ffd1461af62
+%global gh_commit b42593965211de1ce99f73bd3aede99c41258e08
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner fruux
%global gh_project sabre-dav
-%global with_tests %{?_without_tests:0}%{!?_without_tests:1}
+%if 0%{?rhel} == 5
+%global with_tests 0%{?_with_tests:1}
+%else
+%global with_tests 0%{!?_without_tests:1}
+%endif
Name: php-%{gh_project}
Summary: WebDAV Framework for PHP
-Version: 2.1.10
+Version: 3.0.9
Release: 1%{?dist}
URL: https://github.com/%{gh_owner}/%{gh_project}
License: BSD
Group: Development/Libraries
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{gh_short}.tar.gz
-Source1: %{name}-autoload.php
+Source1: %{name}-autoload-dev.php
# replace composer autoloader
-Patch0: %{name}-autoload.patch
+Patch0: %{name}-autoload-dev.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
@@ -32,8 +36,10 @@ BuildArch: noarch
BuildRequires: php(language) >= 5.4.1
BuildRequires: php-composer(phpunit/phpunit)
BuildRequires: php-composer(sabre/vobject) >= 3.3.4
-BuildRequires: php-composer(sabre/event) >= 2.0.0
-BuildRequires: php-composer(sabre/http) >= 3.0.0
+BuildRequires: php-composer(sabre/event) >= 2.0
+BuildRequires: php-composer(sabre/xml) >= 1.0
+BuildRequires: php-composer(sabre/http) >= 4.0
+BuildRequires: php-composer(sabre/uri) >= 1.0
BuildRequires: php-dom
BuildRequires: php-pcre
BuildRequires: php-spl
@@ -53,8 +59,10 @@ BuildRequires: php-pdo_sqlite
# From composer.json, "require": {
# "php": ">=5.4.1",
# "sabre/vobject": "^3.3.4",
-# "sabre/event" : "^2.0.0",
-# "sabre/http" : "^3.0.0",
+# "sabre/event" : "~2.0",
+# "sabre/xml" : "~1.0",
+# "sabre/http" : "~4.0",
+# "sabre/uri" : "~1.0",
# "ext-dom": "*",
# "ext-pcre": "*",
# "ext-spl": "*",
@@ -67,10 +75,14 @@ BuildRequires: php-pdo_sqlite
Requires: php(language) >= 5.4.1
Requires: php-composer(sabre/vobject) >= 3.3.4
Requires: php-composer(sabre/vobject) < 4
-Requires: php-composer(sabre/event) >= 2.0.0
-Requires: php-composer(sabre/event) < 2.1
-Requires: php-composer(sabre/http) >= 3.0.0
-Requires: php-composer(sabre/http) < 3.1
+Requires: php-composer(sabre/event) >= 2.0
+Requires: php-composer(sabre/event) < 3
+Requires: php-composer(sabre/xml) >= 1.0
+Requires: php-composer(sabre/xml) < 2
+Requires: php-composer(sabre/http) >= 4.0
+Requires: php-composer(sabre/http) < 5
+Requires: php-composer(sabre/uri) >= 1.0
+Requires: php-composer(sabre/uri) < 2
Requires: php-dom
Requires: php-pcre
Requires: php-spl
@@ -131,14 +143,11 @@ mkdir -p %{buildroot}%{_datadir}/php
cp -pr lib %{buildroot}%{_datadir}/php/Sabre
-
%check
%if %{with_tests}
%if 0%{?rhel} == 5
sed -e 's/testMove/SKIP_testMove/' \
-i tests/Sabre/DAV/PropertyStorage/Backend/AbstractPDOTest.php
-sed -e 's/testCalendarQueryReportWindowsPhone/SKIP_testCalendarQueryReportWindowsPhone/' \
- -i tests/Sabre/CalDAV/PluginTest.php
%endif
: Fix bootstrap
@@ -149,7 +158,7 @@ sed -e 's:@BUILDROOT@:%{buildroot}:' -i bootstrap.php
%{_bindir}/phpunit --verbose
if which php70; then
- php70 %{_bindir}/phpunit --verbose || : ignore test results
+ php70 %{_bindir}/phpunit --verbose
fi
%else
: Skip upstream test suite
@@ -170,6 +179,12 @@ fi
%changelog
+* Thu Apr 7 2016 Remi Collet <remi@fedoraproject.org> - 3.0.9-1
+- update to 3.0.9
+- add dependency on sabre/xml
+- add dependency on sabre/uri
+- raise dependency on sabre/http >= 4
+
* Tue Mar 22 2016 Remi Collet <remi@fedoraproject.org> - 2.1.10-1
- update to 2.1.10