summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2017-01-29 06:13:20 +0100
committerRemi Collet <fedora@famillecollet.com>2017-01-29 06:13:20 +0100
commit39a2a5b435b0d81b37da708ba58c270250319250 (patch)
treedcfd219274ff115266df317eb4c8287f03fcea78
parent82168f473ef55918dd99a31fc87700510bdc6748 (diff)
php-sabre-dav: 3.2.1
-rw-r--r--composer.json2
-rw-r--r--php-sabre-dav-php71.patch23
-rw-r--r--php-sabre-dav.spec12
3 files changed, 7 insertions, 30 deletions
diff --git a/composer.json b/composer.json
index f85d965..c561ffe 100644
--- a/composer.json
+++ b/composer.json
@@ -34,7 +34,7 @@
"require-dev" : {
"phpunit/phpunit" : "> 4.8, <=6.0.0",
"evert/phpdoc-md" : "~0.1.0",
- "sabre/cs" : "~0.0.5",
+ "sabre/cs" : "^1.0.0",
"monolog/monolog": "^1.18"
},
"suggest" : {
diff --git a/php-sabre-dav-php71.patch b/php-sabre-dav-php71.patch
deleted file mode 100644
index 8bbe179..0000000
--- a/php-sabre-dav-php71.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-From 072589cd5dbce0f3e3a28b29ee778a1183c6d45d Mon Sep 17 00:00:00 2001
-From: Evert Pot <me@evertpot.com>
-Date: Fri, 7 Oct 2016 17:23:14 -0400
-Subject: [PATCH] PHP 7.1 tweak
-
----
- tests/Sabre/DAV/ServerEventsTest.php | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/tests/Sabre/DAV/ServerEventsTest.php b/tests/Sabre/DAV/ServerEventsTest.php
-index 7f995c6..e41b827 100644
---- a/tests/Sabre/DAV/ServerEventsTest.php
-+++ b/tests/Sabre/DAV/ServerEventsTest.php
-@@ -118,7 +118,8 @@ class ServerEventsTest extends AbstractS
- );
- } catch (Exception $e) {}
-
-- $this->assertEquals(2, $k);
-+ // Fun fact, PHP 7.1 changes the order when sorting-by-callback.
-+ $this->assertTrue($k>=2 && $k <=3);
-
-
- }
diff --git a/php-sabre-dav.spec b/php-sabre-dav.spec
index 6ee0080..503f5d5 100644
--- a/php-sabre-dav.spec
+++ b/php-sabre-dav.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 5b9737cc2f0182e368d14c80df7f6b2d77dc1457
+%global gh_commit 11ba8e9400d9c3aad8541c6dc19f5f888d9f0804
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner fruux
%global gh_project sabre-dav
@@ -18,7 +18,7 @@
Name: php-%{gh_project}
Summary: WebDAV Framework for PHP
-Version: 3.2.0
+Version: 3.2.1
Release: 1%{?dist}
URL: https://github.com/%{gh_owner}/%{gh_project}
@@ -29,8 +29,6 @@ Source1: %{name}-autoload.php
# replace composer autoloader
Patch0: %{name}-autoload.patch
-# upstream patch for 7.1
-Patch1: %{name}-php71.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
@@ -57,7 +55,7 @@ BuildRequires: php-pdo
# "phpunit/phpunit" : "> 4.8, <=6.0.0",
# "evert/phpdoc-md" : "~0.1.0",
# "squizlabs/php_codesniffer": "~1.5.3"
-# "sabre/cs" : "~0.0.5",
+# "sabre/cs" : "^1.0.0",
# "monolog/monolog": "^1.18"
BuildRequires: php-composer(phpunit/phpunit) >= 4.8
BuildRequires: php-composer(monolog/monolog) >= 1.18
@@ -143,7 +141,6 @@ Autoloader: %{_datadir}/php/Sabre/DAV/autoload.php
%setup -q -n %{gh_project}-%{gh_commit}
%patch0 -p1 -b .rpm
-%patch1 -p1 -b .php71
cp %{SOURCE1} lib/DAV/autoload.php
@@ -208,6 +205,9 @@ exit $ret
%changelog
+* Sun Jan 29 2017 Remi Collet <remi@fedoraproject.org> - 3.2.1-1
+- update to 3.2.1
+
* Tue Jan 17 2017 Remi Collet <remi@fedoraproject.org> - 3.2.0-1
- update to 3.2.0
- raise dependency on PHP version 5.5