summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json6
-rw-r--r--php-sabre-xml4.spec17
2 files changed, 13 insertions, 10 deletions
diff --git a/composer.json b/composer.json
index 9996cec..1c59805 100644
--- a/composer.json
+++ b/composer.json
@@ -44,9 +44,9 @@
}
},
"require-dev": {
- "friendsofphp/php-cs-fixer": "^3.9",
- "phpstan/phpstan": "^1.8",
- "phpunit/phpunit" : "^9.0"
+ "friendsofphp/php-cs-fixer": "^3.20",
+ "phpstan/phpstan": "^1.10",
+ "phpunit/phpunit" : "^9.6"
},
"scripts": {
"phpstan": [
diff --git a/php-sabre-xml4.spec b/php-sabre-xml4.spec
index 4747c29..2850ffa 100644
--- a/php-sabre-xml4.spec
+++ b/php-sabre-xml4.spec
@@ -10,7 +10,7 @@
%bcond_without tests
# Github
-%global gh_commit 5051b30416b60f52395007c7069acbd010edd2a7
+%global gh_commit c4cec174c4bf78a3bbe667873346800db8b73173
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sabre-io
%global gh_project xml
@@ -24,7 +24,7 @@
Name: php-%{pk_vendor}-%{pk_project}%{major}
Summary: XML library that you may not hate
-Version: 4.0.0
+Version: 4.0.1
Release: 1%{?dist}
URL: https://github.com/%{gh_owner}/%{gh_project}
@@ -50,10 +50,10 @@ BuildRequires: php-libxml
BuildRequires: php-pcre
BuildRequires: php-spl
# From composer.json, "require-dev": {
-# "friendsofphp/php-cs-fixer": "^3.9",
-# "phpstan/phpstan": "^1.8",
-# "phpunit/phpunit" : "^9.0"
-BuildRequires: phpunit9
+# "friendsofphp/php-cs-fixer": "^3.20",
+# "phpstan/phpstan": "^1.10",
+# "phpunit/phpunit" : "^9.6"
+BuildRequires: phpunit9 >= 9.6
%global phpunit %{_bindir}/phpunit9
%endif
# Autoloader
@@ -145,7 +145,7 @@ cd tests
: Run upstream test suite against installed library
ret=0
-for cmdarg in "php %{phpunit}" php80 php81 php82; do
+for cmdarg in "php %{phpunit}" php80 php81 php82 php83; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit9} || ret=1
@@ -167,6 +167,9 @@ exit $ret
%changelog
+* Wed Jun 28 2023 Remi Collet <remi@remirepo.net> - 4.0.1-1
+- update to 4.0.1
+
* Fri Jan 20 2023 Remi Collet <remi@remirepo.net> - 4.0.0-1
- update to 4.0.0
- raise dependency on PHP 7.4