summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-06-12 08:01:34 +0200
committerRemi Collet <remi@php.net>2023-06-12 08:01:34 +0200
commit8b9b0c0be6b37c4cd9117adbaf4db65ed730ac4c (patch)
treed93db72055f943f2328e5c2bd06327f02284f729
parent4ee27eadf8902fdfeda0816dd2e3f2e18f78813b (diff)
update to 3.0.1HEADmaster
-rw-r--r--composer.json14
-rw-r--r--php-sabre-uri3.spec20
2 files changed, 24 insertions, 10 deletions
diff --git a/composer.json b/composer.json
index 0e0cf2d..03c3387 100644
--- a/composer.json
+++ b/composer.json
@@ -37,9 +37,12 @@
}
},
"require-dev": {
- "friendsofphp/php-cs-fixer": "^3.9",
- "phpstan/phpstan": "^1.8",
- "phpunit/phpunit" : "^9.0"
+ "friendsofphp/php-cs-fixer": "^3.17",
+ "phpstan/phpstan": "^1.10",
+ "phpstan/phpstan-phpunit": "^1.3",
+ "phpstan/phpstan-strict-rules": "^1.5",
+ "phpstan/extension-installer": "^1.3",
+ "phpunit/phpunit" : "^9.6"
},
"scripts": {
"phpstan": [
@@ -56,5 +59,10 @@
"composer cs-fixer",
"composer phpunit"
]
+ },
+ "config": {
+ "allow-plugins": {
+ "phpstan/extension-installer": true
+ }
}
}
diff --git a/php-sabre-uri3.spec b/php-sabre-uri3.spec
index 9bb6b78..083cd41 100644
--- a/php-sabre-uri3.spec
+++ b/php-sabre-uri3.spec
@@ -10,7 +10,7 @@
%bcond_without tests
# Github
-%global gh_commit 0ab547f34cf15a735e976a285ffc0cfcc27a3f82
+%global gh_commit 1774043c843f1db7654ecc93368a98be29b07544
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sabre-io
%global gh_project uri
@@ -24,7 +24,7 @@
Name: php-%{pk_vendor}-%{pk_project}%{major}
Summary: Functions for making sense out of URIs
-Version: 3.0.0
+Version: 3.0.1
Release: 1%{?dist}
URL: https://github.com/%{gh_owner}/%{gh_project}
@@ -37,11 +37,14 @@ BuildArch: noarch
%if %{with tests}
BuildRequires: php(language) >= 7.4
# From composer.json, "require-dev": {
-# "friendsofphp/php-cs-fixer": "^3.9",
-# "phpstan/phpstan": "^1.8",
-# "phpunit/phpunit" : "^9.0"
+# "friendsofphp/php-cs-fixer": "^3.17",
+# "phpstan/phpstan": "^1.10",
+# "phpstan/phpstan-phpunit": "^1.3",
+# "phpstan/phpstan-strict-rules": "^1.5",
+# "phpstan/extension-installer": "^1.3",
+# "phpunit/phpunit" : "^9.6"
BuildRequires: php-pcre
-BuildRequires: phpunit9
+BuildRequires: phpunit9 >= 9.6
%global phpunit %{_bindir}/phpunit9
%endif
# Autoloader
@@ -113,7 +116,7 @@ mkdir vendor
ln -s %{buildroot}%{_datadir}/php/%{ns_vendor}/%{ns_project}%{major}/autoload.php vendor/autoload.php
cd tests
-for cmdarg in "php %{phpunit}" php74 php80 php81 php82; do
+for cmdarg in "php %{phpunit}" php80 php81 php82 php83; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit9} --verbose || ret=1
@@ -136,6 +139,9 @@ exit $ret
%changelog
+* Mon Jun 12 2023 Remi Collet <remi@remirepo.net> - 3.0.1-1
+- update to 3.0.1
+
* Fri Jan 20 2023 Remi Collet <remi@remirepo.net> - 3.0.0-1
- update to 3.0.0
- rename to php-sabre-uri3