summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-11-04 12:35:30 +0100
committerRemi Collet <remi@php.net>2021-11-04 12:35:30 +0100
commit9210a0eb8ab50f6ae0b8eac694351cd5c6a8c98e (patch)
treec0b58988b0d44ca424cb14d50e620cc6ba414d16
parent6f791aadc86c7be8fec85573c517cf0e5ed07ea0 (diff)
update to 2.2.2
-rw-r--r--composer.json2
-rw-r--r--php-sabre-uri2.spec26
2 files changed, 16 insertions, 12 deletions
diff --git a/composer.json b/composer.json
index 4a68797..d58fd51 100644
--- a/composer.json
+++ b/composer.json
@@ -37,7 +37,7 @@
}
},
"require-dev": {
- "friendsofphp/php-cs-fixer": "~2.16.1",
+ "friendsofphp/php-cs-fixer": "~2.17.1",
"phpstan/phpstan": "^0.12",
"phpunit/phpunit" : "^7.5 || ^8.5 || ^9.0"
},
diff --git a/php-sabre-uri2.spec b/php-sabre-uri2.spec
index 5f5a1ed..94eba91 100644
--- a/php-sabre-uri2.spec
+++ b/php-sabre-uri2.spec
@@ -1,6 +1,6 @@
# remirepo/fedora spec file for php-sabre-uri2
#
-# Copyright (c) 2016-2020 Remi Collet
+# Copyright (c) 2016-2021 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -10,7 +10,7 @@
%bcond_without tests
# Github
-%global gh_commit f502edffafea8d746825bd5f0b923a60fd2715ff
+%global gh_commit 7cb0f489578afad5006e85cd60f18ff33f2d440d
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sabre-io
%global gh_project uri
@@ -24,7 +24,7 @@
Name: php-%{pk_vendor}-%{pk_project}%{major}
Summary: Functions for making sense out of URIs
-Version: 2.2.1
+Version: 2.2.2
Release: 1%{?dist}
URL: https://github.com/%{gh_owner}/%{gh_project}
@@ -37,17 +37,12 @@ BuildArch: noarch
%if %{with tests}
BuildRequires: php(language) >= 7.1
# From composer.json, "require-dev": {
-# "friendsofphp/php-cs-fixer": "~2.16.1",
+# "friendsofphp/php-cs-fixer": "~2.17.1",
# "phpstan/phpstan": "^0.12",
# "phpunit/phpunit" : "^7.5 || ^8.5 || ^9.0"
BuildRequires: php-pcre
-%if 0%{?fedora} >= 31 || 0%{?rhel} >= 9
BuildRequires: phpunit9
%global phpunit %{_bindir}/phpunit9
-%else
-BuildRequires: phpunit8 >= 8.5
-%global phpunit %{_bindir}/phpunit8
-%endif
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
@@ -105,14 +100,20 @@ cp -pr lib %{buildroot}%{_datadir}/php/%{ns_vendor}/%{ns_project}%{major}
%check
+: Check version
+php -r '
+require "%{buildroot}%{_datadir}/php/%{ns_vendor}/%{ns_project}%{major}/autoload.php";
+echo Sabre\Uri\Version::VERSION . "\n";
+exit (Sabre\Uri\Version::VERSION === "%{version}" ? 0 : 1);
+'
+
%if %{with tests}
: Run upstream test suite against installed library
mkdir vendor
ln -s %{buildroot}%{_datadir}/php/%{ns_vendor}/%{ns_project}%{major}/autoload.php vendor/autoload.php
cd tests
-for cmdarg in "php %{phpunit}" "php72 %{_bindir}/phpunit8" php73 php74 php80
-do
+for cmdarg in "php %{phpunit}" php73 php74 php80 php81; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit9} --verbose || ret=1
@@ -135,6 +136,9 @@ exit $ret
%changelog
+* Thu Nov 4 2021 Remi Collet <remi@remirepo.net> - 2.2.2-1
+- update to 2.2.2
+
* Mon Oct 5 2020 Remi Collet <remi@remirepo.net> - 2.2.1-1
- update to 2.2.1
- switch to phpunit9