summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-07-05 15:43:45 +0200
committerRemi Collet <remi@remirepo.net>2019-07-05 15:43:45 +0200
commit2f8f40db92a48c9062dd7c33152cbf005dc03ccb (patch)
tree34678b2053d77323c780c975239246fee33019b7
parentdaa414f488bf9ed75c9539d33513a08128d38c0e (diff)
fix autoloader
-rw-r--r--php-sabre-uri2.spec9
1 files changed, 7 insertions, 2 deletions
diff --git a/php-sabre-uri2.spec b/php-sabre-uri2.spec
index a8daaa9..879bb00 100644
--- a/php-sabre-uri2.spec
+++ b/php-sabre-uri2.spec
@@ -23,7 +23,7 @@
Name: php-%{pk_vendor}-%{pk_project}%{major}
Summary: Functions for making sense out of URIs
Version: 2.1.2
-Release: 1%{?dist}
+Release: 2%{?dist}
URL: https://github.com/%{gh_owner}/%{gh_project}
License: BSD
@@ -79,7 +79,9 @@ phpab -t fedora -o lib/autoload.php lib
cat << 'EOF' | tee -a lib/autoload.php
// Functions
-require_once __DIR__ . '/functions.php';
+if (!function_exists('Sabre\\Uri\\resolve')) {
+ require_once __DIR__ . '/functions.php';
+}
EOF
%build
@@ -122,6 +124,9 @@ exit $ret
%changelog
+* Fri Jul 5 2019 Remi Collet <remi@remirepo.net> - 2.1.2-2
+- fix autoloader
+
* Mon Jul 1 2019 Remi Collet <remi@remirepo.net> - 2.1.2-1
- update to 2.1.2
- rename to php-sabre-uri2