summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-07-05 14:04:11 +0200
committerRemi Collet <remi@remirepo.net>2019-07-05 14:04:11 +0200
commite99ebeda517e6ba207176a84bad2bab0dc28cb33 (patch)
treeec012a4387adfecb20a4723455af6961b23416fb
duplicate spec
-rw-r--r--.gitignore7
-rw-r--r--Makefile4
-rw-r--r--php-sabre-http5.spec192
3 files changed, 203 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..1ab5c4f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/php-sabre-http5.spec b/php-sabre-http5.spec
new file mode 100644
index 0000000..ee84176
--- /dev/null
+++ b/php-sabre-http5.spec
@@ -0,0 +1,192 @@
+# remirepo/fedora spec file for php-sabre-http
+#
+# Copyright (c) 2013-2017 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+%global gh_commit acccec4ba863959b2d10c1fa0fb902736c5c8956
+%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
+%global gh_owner sabre-io
+%global gh_project http
+#global prever alpha6
+%global with_tests %{?_without_tests:0}%{!?_without_tests:1}
+
+Name: php-sabre-%{gh_project}
+Summary: Library for dealing with http requests and responses
+Version: 4.2.4
+Release: 1%{?dist}
+
+URL: https://github.com/%{gh_owner}/%{gh_project}
+License: BSD
+Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{name}-%{version}-%{gh_short}.tar.gz
+Source1: %{name}-autoload.php
+
+BuildArch: noarch
+%if %{with_tests}
+BuildRequires: php(language) > 5.4
+BuildRequires: php-mbstring
+BuildRequires: php-ctype
+BuildRequires: php-composer(phpunit/phpunit)
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+BuildRequires: (php-composer(sabre/event) >= 2.0.2 with php-composer(sabre/event) < 4)
+BuildRequires: (php-composer(sabre/uri) >= 1.0 with php-composer(sabre/uri) < 2)
+%else
+BuildRequires: php-sabre-event >= 2.0.2
+BuildRequires: php-sabre-uri
+%endif
+BuildRequires: php-curl
+BuildRequires: php-date
+BuildRequires: php-hash
+BuildRequires: php-pcre
+BuildRequires: php-spl
+BuildRequires: php-xml
+# Autoloader
+BuildRequires: php-composer(fedora/autoloader)
+%endif
+
+# From composer.json, "require" : {
+# "php" : ">=5.4",
+# "ext-mbstring" : "*",
+# "ext-ctype" : "*",
+# "sabre/event" : ">=1.0.0,<4.0.0",
+# => use 2.0.2 for autoloader
+# "sabre/uri" : "~1.0"
+Requires: php(language) > 5.4
+Requires: php-mbstring
+Requires: php-ctype
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+Requires: (php-composer(sabre/event) >= 2.0.2 with php-composer(sabre/event) < 4)
+Requires: (php-composer(sabre/uri) >= 1.0 with php-composer(sabre/uri) < 2)
+%else
+Requires: php-sabre-event >= 2.0.2
+Requires: php-sabre-uri
+%endif
+# From composer.json, "suggest" : {
+# "ext-curl" : " to make http requests with the Client class"
+Requires: php-curl
+# From phpcompatinfo report for version 3.0.5
+Requires: php-date
+Requires: php-hash
+Requires: php-pcre
+Requires: php-spl
+Requires: php-xml
+# Autoloader
+Requires: php-composer(fedora/autoloader)
+
+# Was split from php-sabre-dav in version 1.9
+Conflicts: php-sabre-dav < 1.9
+
+Provides: php-composer(sabre/http) = %{version}
+
+
+%description
+This library provides a toolkit to make working with the HTTP protocol easier.
+
+Most PHP scripts run within a HTTP request but accessing information about
+the HTTP request is cumbersome at least, mainly do to superglobals and the
+CGI standard.
+
+There's bad practices, inconsistencies and confusion.
+This library is effectively a wrapper around the following PHP constructs:
+
+For Input:
+ $_GET
+ $_POST
+ $_SERVER
+ php://input or $HTTP_RAW_POST_DATA.
+
+For output:
+ php://output or echo.
+ header()
+
+What this library provides, is a Request object, and a Response object.
+The objects are extendable and easily mockable.
+
+Autoloader: %{_datadir}/php/Sabre/HTTP/autoload.php
+
+
+%prep
+%setup -q -n %{gh_project}-%{gh_commit}
+
+cp %{SOURCE1} lib/autoload.php
+
+
+%build
+# nothing to build
+
+
+%install
+# Install as a PSR-0 library
+mkdir -p %{buildroot}%{_datadir}/php/Sabre
+cp -pr lib %{buildroot}%{_datadir}/php/Sabre/HTTP
+
+
+%check
+%if %{with_tests}
+cd tests
+
+: Run upstream test suite against installed library
+ret=0
+for cmd in php php70 php71 php72; do
+ if which $cmd; then
+ $cmd %{_bindir}/phpunit --bootstrap=%{buildroot}%{_datadir}/php/Sabre/HTTP/autoload.php --verbose || ret=1
+ fi
+done
+exit $ret
+%else
+: Skip upstream test suite
+%endif
+
+
+%files
+%{!?_licensedir:%global license %%doc}
+%license LICENSE
+%doc *md
+%doc composer.json
+%{_datadir}/php/Sabre/HTTP
+
+
+%changelog
+* Tue Jun 5 2018 Remi Collet <remi@remirepo.net> - 4.2.4-1
+- update to 4.2.4
+- use range dependencies on F27+
+
+* Mon Jun 12 2017 Remi Collet <remi@remirepo.net> - 4.2.3-1
+- Update to 4.2.3
+
+* Wed Jan 4 2017 Remi Collet <remi@fedoraproject.org> - 4.2.2-1
+- update to 4.2.2
+
+* Sat Oct 29 2016 Remi Collet <remi@fedoraproject.org> - 4.2.1-2
+- switch from symfony/class-loader to fedora/autoloader
+
+* Fri Mar 11 2016 Remi Collet <remi@fedoraproject.org> - 4.2.1-1
+- update to 4.2.1
+- add dependency on sabre/uri
+- run test suite with both PHP 5 and 7 when available
+
+* Mon Jul 20 2015 Remi Collet <remi@fedoraproject.org> - 3.0.5-1
+- update to 3.0.5
+- add autoloader
+
+* Wed Jul 16 2014 Remi Collet <remi@fedoraproject.org> - 2.0.4-1
+- update to 2.0.4
+- composer dependencies
+
+* Tue May 6 2014 Remi Collet <remi@fedoraproject.org> - 2.0.3-1
+- update to 2.0.3
+
+* Tue Feb 11 2014 Remi Collet <remi@fedoraproject.org> - 2.0.2-1
+- update to 2.0.2
+
+* Sat Jan 11 2014 Remi Collet <remi@fedoraproject.org> - 2.0.1-1
+- update to 2.0.1
+
+* Tue Jan 7 2014 Remi Collet <remi@fedoraproject.org> - 2.0.0-0.2.alpha6
+- update to 2.0.0alpha6
+- add explicit conflicts with php-sabre-dav < 1.9
+
+* Tue Dec 31 2013 Remi Collet <remi@fedoraproject.org> - 2.0.0-0.1.alpha5
+- Initial packaging