summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-11-04 08:33:22 +0100
committerRemi Collet <remi@php.net>2021-11-04 08:33:22 +0100
commit6010f44703556a0d29864aafb046d08516bedaed (patch)
tree3b030daead4b105a1904e70f8ed26afbe4bef544
parent36595c6581667c9aa216ad6cff6a67a758d5b57f (diff)
update to 5.1.3
-rw-r--r--.gitignore2
-rw-r--r--composer.json2
-rw-r--r--php-sabre-http5.spec28
3 files changed, 21 insertions, 11 deletions
diff --git a/.gitignore b/.gitignore
index 1ab5c4f..01f0400 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,5 +1,7 @@
+clog
package-*.xml
*.tgz
+*.tar.bz2
*.tar.gz
*.tar.xz
*.tar.xz.asc
diff --git a/composer.json b/composer.json
index 7f54df6..353646a 100644
--- a/composer.json
+++ b/composer.json
@@ -13,7 +13,7 @@
"sabre/uri" : "^2.0"
},
"require-dev" : {
- "friendsofphp/php-cs-fixer": "~2.16.1",
+ "friendsofphp/php-cs-fixer": "~2.17.1",
"phpstan/phpstan": "^0.12",
"phpunit/phpunit" : "^7.5 || ^8.5 || ^9.0"
},
diff --git a/php-sabre-http5.spec b/php-sabre-http5.spec
index a11c7c6..413df38 100644
--- a/php-sabre-http5.spec
+++ b/php-sabre-http5.spec
@@ -10,7 +10,7 @@
%bcond_without tests
# Github
-%global gh_commit d0aafede6961df6195ce7a8dad49296b0aaee22e
+%global gh_commit 315f592adfcba8aeb73c2fd64285205747acbbd7
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sabre-io
%global gh_project http
@@ -24,7 +24,7 @@
Name: php-%{pk_vendor}-%{pk_project}%{major}
Summary: Library for dealing with http requests and responses
-Version: 5.1.1
+Version: 5.1.3
Release: 1%{?dist}
URL: https://github.com/%{gh_owner}/%{gh_project}
@@ -41,7 +41,7 @@ BuildRequires: php-ctype
BuildRequires: (php-composer(sabre/event) >= 4.0 with php-composer(sabre/event) < 6)
BuildRequires: (php-composer(sabre/uri) >= 2.0 with php-composer(sabre/uri) < 3)
# From composer.json, "require-dev" : {
-# "friendsofphp/php-cs-fixer": "~2.16.1",
+# "friendsofphp/php-cs-fixer": "~2.17.1",
# "phpstan/phpstan": "^0.12",
# "phpunit/phpunit" : "^7.5 || ^8.5 || ^9.0"
# remirepo:4
@@ -49,13 +49,8 @@ BuildRequires: (php-composer(sabre/uri) >= 2.0 with php-composer(sabre/uri)
BuildRequires: php-sabre-event5
BuildRequires: php-sabre-uri2
%endif
-%if 0%{?fedora} >= 31 || 0%{?rhel} >= 9
BuildRequires: phpunit9
%global phpunit %{_bindir}/phpunit9
-%else
-BuildRequires: phpunit8
-%global phpunit %{_bindir}/phpunit8
-%endif
BuildRequires: php-curl
BuildRequires: php-date
BuildRequires: php-hash
@@ -157,6 +152,13 @@ cp -pr lib %{buildroot}%{_datadir}/php/%{ns_vendor}/%{ns_project}%{major}
%check
+: Check version
+php -r '
+require "%{buildroot}%{_datadir}/php/%{ns_vendor}/%{ns_project}%{major}/autoload.php";
+echo Sabre\HTTP\Version::VERSION . "\n";
+exit (Sabre\HTTP\Version::VERSION === "%{version}" ? 0 : 1);
+'
+
%if %{with tests}
cd tests
@@ -164,13 +166,13 @@ ln -sf %{buildroot}%{_datadir}/php/%{ns_vendor}/%{ns_project}%{major}/autoload.p
: Start a Development web server
PORT=$(expr 8080 + %{?fedora}%{?rhel})
-sed -e "s/localhost/127.0.0.1:$PORT/" -i phpunit.xml
+sed -e "s/localhost:8000/127.0.0.1:$PORT/" -i phpunit.xml
%{_bindir}/php -S 127.0.0.1:$PORT -t $PWD/www &>web.log &
PHPPID=$!
: Run upstream test suite against installed library
ret=0
-for cmdarg in "php %{phpunit}" "php72 %{_bindir}/phpunit8" php73 php74 php80; do
+for cmdarg in "php %{phpunit}" php73 php74 php80 php81; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit9} --verbose || ret=1
@@ -195,6 +197,12 @@ exit $ret
%changelog
+* Thu Nov 4 2021 Remi Collet <remi@remirepo.net> - 5.1.3-1
+- update to 5.1.3
+
+* Thu Nov 4 2021 Remi Collet <remi@remirepo.net> - 5.1.2-1
+- update to 5.1.2
+
* Mon Oct 5 2020 Remi Collet <remi@remirepo.net> - 5.1.1-1
- update to 5.1.1
- switch to phpunit9