summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-02-01 07:55:29 +0100
committerRemi Collet <remi@remirepo.net>2020-02-01 07:55:29 +0100
commit0719368eaf44ae13fc8123e14dd398081cbcd99b (patch)
tree7cc96db029ddb0bfe69cd8c396738a9093c13d69
parent2728b989c68fbf02c4e6efeb0670fe26fbbf4b56 (diff)
update to 5.1.0
-rw-r--r--composer.json10
-rw-r--r--php-sabre-http5.spec26
2 files changed, 22 insertions, 14 deletions
diff --git a/composer.json b/composer.json
index 851a087..198cf23 100644
--- a/composer.json
+++ b/composer.json
@@ -5,7 +5,7 @@
"homepage" : "https://github.com/fruux/sabre-http",
"license" : "BSD-3-Clause",
"require" : {
- "php" : "^7.0",
+ "php" : "^7.1",
"ext-mbstring" : "*",
"ext-ctype" : "*",
"ext-curl" : "*",
@@ -13,7 +13,8 @@
"sabre/uri" : "^2.0"
},
"require-dev" : {
- "phpunit/phpunit" : "^6.0 || ^7.0"
+ "friendsofphp/php-cs-fixer": "~2.16.1",
+ "phpunit/phpunit" : "^7.0 || ^8.0"
},
"suggest" : {
"ext-curl" : " to make http requests with the Client class"
@@ -38,6 +39,11 @@
"Sabre\\HTTP\\" : "lib/"
}
},
+ "autoload-dev" : {
+ "psr-4" : {
+ "Sabre\\HTTP\\" : "tests/HTTP"
+ }
+ },
"config" : {
"bin-dir" : "bin/"
}
diff --git a/php-sabre-http5.spec b/php-sabre-http5.spec
index 3faa153..ab4a6c5 100644
--- a/php-sabre-http5.spec
+++ b/php-sabre-http5.spec
@@ -1,13 +1,13 @@
# remirepo/fedora spec file for php-sabre-http5
#
-# Copyright (c) 2013-2019 Remi Collet
+# Copyright (c) 2013-2020 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
# Github
-%global gh_commit 85962a2ed867e7e5beb9f9d3a15cd53cd521a09b
+%global gh_commit 23446999f1f6e62892bbd89745070aa902dd3539
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sabre-io
%global gh_project http
@@ -22,7 +22,7 @@
Name: php-%{pk_vendor}-%{pk_project}%{major}
Summary: Library for dealing with http requests and responses
-Version: 5.0.5
+Version: 5.1.0
Release: 1%{?dist}
URL: https://github.com/%{gh_owner}/%{gh_project}
@@ -31,7 +31,7 @@ Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit
BuildArch: noarch
%if %{with_tests}
-BuildRequires: php(language) >= 7.0
+BuildRequires: php(language) >= 7.1
BuildRequires: php-mbstring
BuildRequires: php-ctype
# remirepo:1
@@ -39,16 +39,15 @@ BuildRequires: php-ctype
BuildRequires: (php-composer(sabre/event) >= 4.0 with php-composer(sabre/event) < 6)
BuildRequires: (php-composer(sabre/uri) >= 2.0 with php-composer(sabre/uri) < 3)
# From composer.json, "require-dev" : {
-# "phpunit/phpunit" : "^6.0 || ^7.0"
-BuildRequires: phpunit7
-%global phpunit %{_bindir}/phpunit7
+# "friendsofphp/php-cs-fixer": "~2.16.1",
+# "phpunit/phpunit" : "^7.0 || ^8.0"
# remirepo:6
%else
BuildRequires: php-sabre-event5
BuildRequires: php-sabre-uri2
-BuildRequires: phpunit6
-%global phpunit %{_bindir}/phpunit6
%endif
+BuildRequires: phpunit8
+%global phpunit %{_bindir}/phpunit8
BuildRequires: php-curl
BuildRequires: php-date
BuildRequires: php-hash
@@ -60,13 +59,13 @@ BuildRequires: php-xml
BuildRequires: php-fedora-autoloader-devel
# From composer.json, "require" : {
-# "php" : "^7.0",
+# "php" : "^7.1",
# "ext-mbstring" : "*",
# "ext-ctype" : "*",
# "ext-curl" : "*",
# "sabre/event" : ">=4.0 <6.0",
# "sabre/uri" : "~2.0"
-Requires: php(language) >= 7.0
+Requires: php(language) >= 7.1
Requires: php-mbstring
Requires: php-ctype
Requires: php-curl
@@ -163,7 +162,7 @@ PHPPID=$!
: Run upstream test suite against installed library
ret=0
-for cmd in php php71 php72 php73 php74; do
+for cmd in php php72 php73 php74; do
if which $cmd; then
$cmd %{phpunit} --verbose || ret=1
fi
@@ -187,6 +186,9 @@ exit $ret
%changelog
+* Sat Feb 1 2020 Remi Collet <remi@remirepo.net> - 5.1.0-1
+- update to 5.1.0
+
* Fri Nov 29 2019 Remi Collet <remi@remirepo.net> - 5.0.5-1
- update to 5.0.5