summaryrefslogtreecommitdiffstats
path: root/php-sabre-event5.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-10-21 08:55:24 +0200
committerRemi Collet <remi@remirepo.net>2017-10-21 08:55:24 +0200
commitd5b42d2daa8bb2c61aaeff5e0c226c5ef541594f (patch)
tree237655d4c6e2da603e954ff5cf2c9cfed8764ad2 /php-sabre-event5.spec
parent75f5abd3d570c183e03525c5c2a4f966de6a4833 (diff)
v5.0.2
Diffstat (limited to 'php-sabre-event5.spec')
-rw-r--r--php-sabre-event5.spec112
1 files changed, 63 insertions, 49 deletions
diff --git a/php-sabre-event5.spec b/php-sabre-event5.spec
index b3a6a85..303816b 100644
--- a/php-sabre-event5.spec
+++ b/php-sabre-event5.spec
@@ -1,4 +1,4 @@
-# remirepo/fedora spec file for php-sabre-event
+# remirepo/fedora spec file for php-sabre-event5
#
# Copyright (c) 2013-2017 Remi Collet
# License: CC-BY-SA
@@ -6,54 +6,79 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 337b6f5e10ea6e0b21e22c7e5788dd3883ae73ff
+# Github
+%global gh_commit 3cb619803d5e3e38ed7c309250da5589676aedc8
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
-%global gh_owner fruux
-%global gh_project sabre-event
-%global with_tests %{?_without_tests:0}%{!?_without_tests:1}
-
-Name: php-%{gh_project}
+%global gh_owner sabre-io
+%global gh_project event
+# Packagist
+%global pk_vendor sabre
+%global pk_project %{gh_project}
+# Namespace
+%global ns_vendor Sabre
+%global ns_project Event
+# For RPM
+%global major 5
+%global with_tests 0%{!?_without_tests:1}
+
+Name: php-%{pk_vendor}-%{pk_project}%{major}
Summary: Lightweight library for event-based programming
-Version: 2.0.2
-Release: 3%{?dist}
+Version: 5.0.2
+Release: 1%{?dist}
URL: http://sabre.io/event
License: BSD
Group: Development/Libraries
-Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{gh_short}.tar.gz
-Source1: %{name}-autoload.php
+Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{name}-%{version}-%{gh_short}.tar.gz
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
%if %{with_tests}
-BuildRequires: php(language) >= 5.4.1
-BuildRequires: php-composer(phpunit/phpunit)
+BuildRequires: php(language) >= 7.0
+BuildRequires: php-spl
+# From composer.json, "require-dev": {
+# "sabre/cs": "~1.0.0",
+# "phpunit/phpunit" : ">=6"
+BuildRequires: phpunit6
# Autoloader
BuildRequires: php-composer(fedora/autoloader)
%endif
# From composer.json, "require": {
-# "php": ">=5.4.1"
-Requires: php(language) >= 5.4.1
-# From phpcompatinfo report for version 2.0.2
+# "php": ">=7.0"
+Requires: php(language) >= 7.0
+# From phpcompatinfo report for version 5.0.2
Requires: php-spl
# Autoloader
Requires: php-composer(fedora/autoloader)
-Provides: php-composer(sabre/event) = %{version}
+Provides: php-composer(%{pk_vendor}/%{pk_project}) = %{version}
%description
-A lightweight library for event management in PHP.
-It's design is inspired by Node.js's EventEmitter. sabre/event requires PHP 5.4.
+This library provides the following event-based concepts:
+
+* EventEmitter.
+* Promises.
+* An event loop.
+* Co-routines.
-Autoloader: %{_datadir}/php/Sabre/Event/autoload.php
+Full documentation can be found on http://sabre.io/event/
+
+Autoloader: %{_datadir}/php/%{ns_vendor}/%{ns_project}%{major}/autoload.php
%prep
%setup -q -n %{gh_project}-%{gh_commit}
-cp %{SOURCE1} lib/autoload.php
+cat << 'EOF' | tee lib/autoload.php
+<?php
+/* Autoloader for %{name} and its dependencies */
+require_once '/usr/share/php/Fedora/Autoloader/autoload.php';
+\Fedora\Autoloader\Autoload::addPsr4('Sabre\\Event\\', __DIR__);
+require_once __DIR__ . '/coroutine.php';
+require_once __DIR__ . '/Loop/functions.php';
+require_once __DIR__ . '/Promise/functions.php';
+EOF
%build
@@ -61,53 +86,42 @@ cp %{SOURCE1} lib/autoload.php
%install
-rm -rf %{buildroot}
-
-# Install as a PSR-0 library
-mkdir -p %{buildroot}%{_datadir}/php/Sabre
-cp -pr lib %{buildroot}%{_datadir}/php/Sabre/Event
+mkdir -p %{buildroot}%{_datadir}/php/%{ns_vendor}
+cp -pr lib %{buildroot}%{_datadir}/php/%{ns_vendor}/%{ns_project}%{major}
%check
%if %{with_tests}
: Run upstream test suite against installed library
-# remirepo:11
ret=0
-run=0
-if which php71; then
- php71 %{_bindir}/phpunit --bootstrap=%{buildroot}%{_datadir}/php/Sabre/Event/autoload.php || ret=1
- run=1
-fi
-if which php56; then
- php56 %{_bindir}/phpunit --bootstrap=%{buildroot}%{_datadir}/php/Sabre/Event/autoload.php || ret=1
- run=1
-fi
-if [ $run -eq 0 ]; then
-%{_bindir}/phpunit \
- --bootstrap=%{buildroot}%{_datadir}/php/Sabre/Event/autoload.php \
- --verbose
-# remirepo:2
-fi
+for cmd in php php70 php71 php72; do
+ if which $cmd; then
+ $cmd %{_bindir}/phpunit6 \
+ --bootstrap=%{buildroot}%{_datadir}/php/%{ns_vendor}/%{ns_project}%{major}/autoload.php \
+ --verbose || ret=1
+ fi
+done
exit $ret
%else
: Skip upstream test suite
%endif
-%clean
-rm -rf %{buildroot}
-
-
%files
-%defattr(-,root,root,-)
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc *md
%doc composer.json
-%{_datadir}/php/Sabre
+%dir %{_datadir}/php/%{ns_vendor}
+ %{_datadir}/php/%{ns_vendor}/%{ns_project}%{major}
%changelog
+* Sat Oct 21 2017 Remi Collet <remi@remirepo.net> - 5.0.2-1
+- rename to php-sabre-event5
+- update to 5.0.2
+- raise dependency on PHP 7.0
+
* Sat Oct 29 2016 Remi Collet <remi@fedoraproject.org> - 2.0.2-3
- switch from symfony/class-loader to fedora/autoloader