summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-10-05 10:18:49 +0200
committerRemi Collet <remi@remirepo.net>2020-10-05 10:18:49 +0200
commit6711e7baa8045e397a8c5c09ca41a13402422453 (patch)
tree823bc2292b1ce4a7a698168edc4712b918a28f90
parentd24b2a45e9cce3ab50829039e4475a666d4b5a19 (diff)
bcond
-rw-r--r--php-sabre-event5.spec8
1 files changed, 5 insertions, 3 deletions
diff --git a/php-sabre-event5.spec b/php-sabre-event5.spec
index 9ceedbd..2b3fd89 100644
--- a/php-sabre-event5.spec
+++ b/php-sabre-event5.spec
@@ -6,6 +6,9 @@
#
# Please, preserve the changelog entries
#
+
+%bcond_without tests
+
# Github
%global gh_commit c120bec57c17b6251a496efc82b732418b49d50a
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
@@ -19,7 +22,6 @@
%global ns_project Event
# For RPM
%global major 5
-%global with_tests 0%{!?_without_tests:1}
Name: php-%{pk_vendor}-%{pk_project}%{major}
Summary: Lightweight library for event-based programming
@@ -32,7 +34,7 @@ Source0: %{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
BuildArch: noarch
-%if %{with_tests}
+%if %{with tests}
BuildRequires: php(language) >= 7.1
BuildRequires: php-spl
# From composer.json, "require-dev": {
@@ -101,7 +103,7 @@ cp -pr lib %{buildroot}%{_datadir}/php/%{ns_vendor}/%{ns_project}%{major}
%check
-%if %{with_tests}
+%if %{with tests}
: Run upstream test suite against installed library
ret=0
for cmdarg in "php %{phpunit}" "php72 %{_bindir}/phpunit8" php73 php74 php80; do